post #1 of 1
Thread Starter 
I have seemingly solved an issue that has plagued my setup. I haven't moved to NVMe, yet, so am running a rather large amount of SATA drives at 5. On random reboots (hard reset or Ctrl-Alt-Del) or initial POST, SATA1 would not appear, only ports 2-5. I also have a discrete SB X-Fi Titanium card in PCIe x1, slot 5, which also comes from Promontory, but still have onboard audio enabled.

Issue: SATA1 port dropout during reboot or less often, during initial power-on
Frequency: 1-2 reboots in 5 (it was common enough to be annoying; sometimes back-to-back), nearly 100% dropout if PC rebooted from OC instability
BIOS version: ALL up to 1.52 beta
Resolution: Raise Promontory chip voltage from 1.050v to 1.100v
- covering an inefficiency in either the chip itself or its power delivery

Test 1: 5/5 successful consecutive reboots without issue
Test 2: 5/5 successful reboots over time without issue (such as Windows driver updates and the like)
Total: 10/10 or 100% SATA1 port reliability
(Since posting this over at MSI, I've rebooted about 15 more times, and all were without SATA1 issue)

Other notes: I usually enabled SATA1 hot plugging to force BIOS to detect it at any time, and most of the time it was very late and ended up last in the HDD BBS priorities; this caused me to press F11 to get to the boot menu and manually select the drive on SATA1; ended up disabling all other HDDs from booting other than SATA1, so a failed boot ended up with a "No boot media" prompt in legacy boot mode. I've disabled hot plugging for the tests above.

SATA port layout:

SATA1 - Samsung 840 Evo 250GB (Windows 10 boot drive, legacy boot with MBR)
SATA2 - Hitachi 1TB HDD (non-boot)
SATA3 - Hitachi 1TB HDD (non-boot)
SATA4 - HGST (Hitachi) 4TB NAS (non-boot, GPT disk)
SATA5 - LG Blu-ray / DVD writer

SATA2-3 used to be HW RAID, but encountered issues (esp. CPU-Z, which hung on every load), so went back to AHCI for SSD health monitoring (and RAPID support) and just used Windows SW RAID (HW RAID drives used to have an old Windows 7 boot partition though, so lost that). About the same performance, and Ryzen has cores to spare for any overhead.

If it comes back, I'll be sure to update this and say it's NOT solved. But for now, it seems fixed.