Overclock.net › Forums › Components › Monitors and Displays › AMD R9 290 + ViewSonic XG2703‑GS Monitor = Blank Screen "Adjust Voltage Swing" Fix
New Posts  All Forums:Forum Nav:

AMD R9 290 + ViewSonic XG2703‑GS Monitor = Blank Screen "Adjust Voltage Swing" Fix

post #1 of 2
Thread Starter 
Hi All,

I am just creating this thread to talk about a possible fix for people with AMD cards and their monitors getting random signals drops that shows a blank screen for maybe 1 or 2 seconds then recovers.

My R9 290 was working perfectly with the following monitors:

Dell U2715H (1440p 60hz) and Samsung 24CFG70 (144hz 1080p) through displayport.


The Samsung was a good monitor but it was too small for me and I didn't want to run dual-screen with my now limited desk space. So I purchased a ViewSonic XF2703-GS monitor. Yes, this is a G-SYNC monitor but I don't plan on using it anyways. The only reason I purchased it over the cheaper ASUS MG279Q even though I have an AMD card is because the QC for the Viewsonic seems to be better and the monitor I got was very good except for a little minor BLB which is a lot less than some of the MG279Q's I've seen online. Besides I have a 50% chance of grabbing an Nvidia card when I upgrade anyways.


Anyways... I was having an issue with the Viewsonic straight from the start because the screen would go blank randomly at anytime but it did it 99% of the time right away after a restart. When it goes blank, it only does it for 1-2 seconds then the "input displayport" pop-up would show up on my monitor. The Windows "just plugged in new hardware" sound would ring.

I removed all drivers with DDU and re-installed fresh with no luck.

I tried another Displayport cable with no luck and even another displayport cable from Accell that is VESA and DP certified without any luck either. I was ready to pack-up my monitor to return until I started digging in the Crimson drivers (17.4.4) and went to here:

AMD Radeon Settings -> Display -> Under "Display:1" there is a "Specs" option -> Override -> Adjust Voltage Swing -> Change that from 0 to 2

That fixed my issue. I have no idea what this did and could not find anything online about this setting so hopefully someone knowledgeable can chime in.
post #2 of 2
a loose connector can cause the issue as well. screwing in dvi cables (separate monitor!) has fixed display port monitors blanking for me.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › AMD R9 290 + ViewSonic XG2703‑GS Monitor = Blank Screen "Adjust Voltage Swing" Fix