Overclock.net › Forums › Components › Hard Drives & Storage › RAID Controllers and Software › Are you out of luck now if you need drivers or firmware for older LSI cards?
New Posts  All Forums:Forum Nav:

Are you out of luck now if you need drivers or firmware for older LSI cards?

post #1 of 4
Thread Starter 
I was trying to go the LSI's page for my raid card (Megaraid 9260-8i) to check if there were any updates.... and was surprised that I got redirected to Broadcom's page. I guess Broadcom bought LSI recently?

Anyway, so I tried navigating their site... and the oldest card they would list in that model line was the 9266.... I tried a mnaual search, and terms for the 9260 came up... but all of them went to a 404 page.

So I tried just straight going to Broadcom's driver download subpage, which had a drill-down search for what I wanted drivers for...... but again, as soon as I got to card model, the oldest it would let me go back was the 9266, attempting to manually type in 9260 yielded nothing.

Did Broadcom seriously just cut off any LSI card older than the 9266 and not even provide downloads for the firmware/drivers or documentation anymore?
post #2 of 4
Broadcom bought Avago which bought LSI some time ago. You can find what you are looking for at the below link by choosing Legacy Products under Product Group, Legacy RAID controllers under Product Family, and then MegaRAID 9260-8i under Product Name. I usually just select All under Asset Type but you can choose Firmware, Driver, etc if you wish.

https://www.broadcom.com/support/download-search
post #3 of 4
Thread Starter 
That worked, thanks.

... their drivers page seems very incorrect though, it claims there were drivers uploaded just today for my card... but the backlog of drivers just jumps from 2011 to 2016...
post #4 of 4
You're welcome. The thread title made me panic so I had to go double check.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: RAID Controllers and Software
Overclock.net › Forums › Components › Hard Drives & Storage › RAID Controllers and Software › Are you out of luck now if you need drivers or firmware for older LSI cards?