Overclock.net › Forums › Graphics Cards › AMD/ATI › [BIOS Mod] RX480 -> RX580 Conversions + How-to RX470/RX480 -> RX570/RX580
New Posts  All Forums:Forum Nav:

[BIOS Mod] RX480 -> RX580 Conversions + How-to RX470/RX480 -> RX570/RX580 - Page 21

post #201 of 416
Thread Starter 
Quote:
Originally Posted by Black Flag View Post

I own a Sapphire RX 480 4G Nitro+ for a year now. Is there a bios that it will "upgrade" my card without issues?

my conversions from post#1 might have issues, as long as you want to use the ports of the 2nd row. if you want them working correctly, u should try post#3 or the better custom bios project from vento041. He also added the 1000MHz step, but it is still based on the original nitro+ BIOS. You might have to copy&paste the vram info table from your BIOS, you need atombiosreader and a hex-editor for this.
post #202 of 416
Quote:
Originally Posted by hellm View Post

my conversions from post#1 might have issues, as long as you want to use the ports of the 2nd row. if you want them working correctly, u should try post#3 or the better custom bios project from vento041. He also added the 1000MHz step, but it is still based on the original nitro+ BIOS. You might have to copy&paste the vram info table from your BIOS, you need atombiosreader and a hex-editor for this.

Any idea how he was able to add the 1000MHZ memory step to his RX 480 Bios?
post #203 of 416
Thread Starter 
sure, he told in his thread. it isn't just copy and paste, you have to adjust the complete header of the power play table, and some stuff at the end of it; and add the step, of course.

and, there was a little update.. added -50mV IMC for the 1000MHz step. more stability..
Edited by hellm - 9/29/17 at 6:11am
post #204 of 416
Hey Guys i have a small problem i have flashed XTR Edition ref480-580.xtr.1.0013.rom.zip on my Reference RX480 but in Games and Furmark the Clock Speeds are Fixed to 300mhz.
What have i done wrong?



Is this driver related or have i broke my Card.

THX for answers

Edit: stock bios solved the problem.
my fault sorry for the stupid post
Edited by jasonx20ac - 10/1/17 at 12:49am
post #205 of 416
Thread Starter 
it's ok, the 300MHz only problem appeared to me when i was trying to overclock with software and 17.7.2; but i thought they fixed it by now..

so, u really have a problem with the xtr or what was your fault again? i don't think there is something wrong with the xtr ed., but if there is..
post #206 of 416
My first fault an xtr ed was that i forget to look what Settings was in MSI Afterburner. ( only 670mhz)
When i located the first Problem than i hat only 300mhz in Games.
Than i installed the Stock version from you and now it works normaly.
Maybe it was because MSI Afterburner set up on Windows start, when i will have time i will try the xtr Version one more time.

THX
post #207 of 416
Thread Starter 
I believe it was the Afterburner. I almost forgot i also use the XTR ed., a custom version, with only 1175mV max; no problems.

@anyone who experienced mem errors, those are gone now. was the 1000MHz step, the 480 prefers +50mV for that one too, not only for the 2000MHz max.

@anyone with custom cooling on the reference card, i removed zero fan. It caused the fan to spin at max in idle, cause that is the way the pwm signal gets interpreted from standard fans.
if you want to adjust the fan table to your custom cooling: post#3, fan settings, adjust "max fan speed", "target RPM" and "idle PWM". i might add some notes for that in post#1 or something in the future..
post #208 of 416
can I flash my 580 to a 580 xtr?
post #209 of 416
Thread Starter 
The BIOS files i made are for specific cards only. But if you have a 580 already, go ahead and change the voltage to 1225mV (post#3). You don't need a conversion, definitely no need for driver patching, u can mod what u want in your original BIOS.
post #210 of 416
Nitro 8g bios from post #1 causes volt spikes on my card on idle or low load situations. Spikes up to 1.275mv worriedsmiley.gif

At first thought it was only spiking during video playback, but happens at web surfing, photoshop, and idle too. Only getting a few spikes a night and they don't seem to ever happen during benching or gaming.

The spikes must be for only a split second cause the temps don't jump and the volt averages in HWinfo don't rise much. Only tried this bios on 17.9.1 and 17.9.3 drivers btw.

Would it be possible to get a 8g Nitro bios exactly like post #1, but with the 1000mhz memory strap removed?? For testing purposes thumb.gif
    
CPUMotherboardGraphicsRAM
8350 FX @ 4.6ghz /1.404 v Sabertooth 990FX RX 480 Nitro 8GB 2x4GB Mushkin Blackline DDR3 2133 9-11-11-24 1T... 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 Evo 128GB 1 TB Samsung Spinpoint F3 Samsung SH-S224GB Raijintek Themis Evo 
OSMonitorKeyboardPower
10 Pro 64-bit Samsung SyncMaster S27B550 Logitech K520 Corsair HX850 
CaseMouseMouse PadAudio
Storm Scout 2 Logitech G602 Steel Series HQK Logitech Z-2300 Sub (Z-5500 Satelites) 
AudioOther
Asus Xonar DS Intel I210-T1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
8350 FX @ 4.6ghz /1.404 v Sabertooth 990FX RX 480 Nitro 8GB 2x4GB Mushkin Blackline DDR3 2133 9-11-11-24 1T... 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 Evo 128GB 1 TB Samsung Spinpoint F3 Samsung SH-S224GB Raijintek Themis Evo 
OSMonitorKeyboardPower
10 Pro 64-bit Samsung SyncMaster S27B550 Logitech K520 Corsair HX850 
CaseMouseMouse PadAudio
Storm Scout 2 Logitech G602 Steel Series HQK Logitech Z-2300 Sub (Z-5500 Satelites) 
AudioOther
Asus Xonar DS Intel I210-T1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › [BIOS Mod] RX480 -> RX580 Conversions + How-to RX470/RX480 -> RX570/RX580