Overclock.net › Forums › Cooling › Water Cooling › Help! something is wrong with new GPU block.
New Posts  All Forums:Forum Nav:

Help! something is wrong with new GPU block.

post #1 of 3
Thread Starter 
New EK Acetal/Nickel 1080 ti water block. I've only had 2 CPU and 2 GPU blocks but this doesn't look right....Im frickin nervous.

Look at the bottom right of the first image:
https://i.imgur.com/NyeP5wY.jpg





Now look closer:
https://i.imgur.com/PtKXbcE.jpg

What the heck is going on here?

Is it leaking? Or corrosion? It's brand new,whats the dark spot that has moved into the liquid chamber? The brown/orange spots under the dark black spot worries me as water should not be in there correct? I hope its just fungus or bacteria and I can drain it in a few weeks and flush. Looking to the experts here.

EDIT- Added a crappy video if you can FF to the end when the camera somewhat focuses underneath it sort of looks like a crack, or the source of whats wrong? This is my first clear block so not sure if im exaggerating but it looks like cause for concern.
https://www.youtube.com/watch?v=cDlSvXd6MNg
Edited by latexyankee - 10/19/17 at 9:07pm
Gaming Rig
(7 items)
 
  
CPUMotherboardGraphicsRAM
2600k@4.4 Asrock Z68 Extreme 4 7950 X 2 @ 1175/1600 8GB Crucial DDR3 1600 
Hard DriveHard DrivePower
256GB PLEXTOR SSD 2 x 1TB WD STORAGE Seasonic gold 1050 
  hide details  
Reply
Gaming Rig
(7 items)
 
  
CPUMotherboardGraphicsRAM
2600k@4.4 Asrock Z68 Extreme 4 7950 X 2 @ 1175/1600 8GB Crucial DDR3 1600 
Hard DriveHard DrivePower
256GB PLEXTOR SSD 2 x 1TB WD STORAGE Seasonic gold 1050 
  hide details  
Reply
post #2 of 3
maybe
http://www.overclock.net/t/1633647/brown-yellow-stuff-in-my-supremacy-evo-near-rubber-gasket/0_100

I didn't see any crack, too much mirror-effect...
post #3 of 3
Thread Starter 
Quote:
Originally Posted by chimico9 View Post

maybe
http://www.overclock.net/t/1633647/brown-yellow-stuff-in-my-supremacy-evo-near-rubber-gasket/0_100

I didn't see any crack, too much mirror-effect...

More i look at it i don't really notice a crack I think its placebo from the mirror effect. That thread is not encouraging, whats with the black spot though? It looks like it can only be bacteria or algae..never noticed anything like it in any of my blocks before.
Gaming Rig
(7 items)
 
  
CPUMotherboardGraphicsRAM
2600k@4.4 Asrock Z68 Extreme 4 7950 X 2 @ 1175/1600 8GB Crucial DDR3 1600 
Hard DriveHard DrivePower
256GB PLEXTOR SSD 2 x 1TB WD STORAGE Seasonic gold 1050 
  hide details  
Reply
Gaming Rig
(7 items)
 
  
CPUMotherboardGraphicsRAM
2600k@4.4 Asrock Z68 Extreme 4 7950 X 2 @ 1175/1600 8GB Crucial DDR3 1600 
Hard DriveHard DrivePower
256GB PLEXTOR SSD 2 x 1TB WD STORAGE Seasonic gold 1050 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Help! something is wrong with new GPU block.