Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Enable Direct3D in VMware
New Posts  All Forums:Forum Nav:

Enable Direct3D in VMware

post #1 of 3
Thread Starter 
I used VMware 6 to install Windows XP in a vm under Ubuntu 7.04. However, by default, there is no support for Direct3D. After some googling I found that adding the line "mks.enable3d = TRUE" to the .vmx file for the vm should enable Direct3D in the vm. However, when I added that line, I get the following error when I try to power on the vm:

Quote:
VMware Workstation unrecoverable error: (mks)
Unexpected signal: 11.
3d rendering in Linux is working fine. After more googling I learned that this error may be caused if your video card does not support pbuffers, is that correct? If so, how do I check if my video card supports pbuffers?
post #2 of 3
http://www.neowin.net/index.php?act=view&id=40201

"Accelerated Direct3D support has been available since VMware Workstation 5.x. You have to manually enable it in the .vmx file.

Put this line in the .vmx file for your virtual machine:
mks.enable3d = TRUE

And add/change this line to change the amount of video memory for the VM (this one is 32 MB):
svga.vramSize = "33554432""
Abomination
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon 64 3400+ Chaintech ZNF3-250 GeForce 6800 GT 2x Kingston PC3200 DDR SDRAM 512MB 
Hard DriveOSKeyboardPower
WD400 & WD800 WinXP Logitech Classic 200 Sunbeamtech SUNNU550-US 
Mouse
Logitech G5 
  hide details  
Reply
Abomination
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon 64 3400+ Chaintech ZNF3-250 GeForce 6800 GT 2x Kingston PC3200 DDR SDRAM 512MB 
Hard DriveOSKeyboardPower
WD400 & WD800 WinXP Logitech Classic 200 Sunbeamtech SUNNU550-US 
Mouse
Logitech G5 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
Originally Posted by rfarris View Post
http://www.neowin.net/index.php?act=view&id=40201

"Accelerated Direct3D support has been available since VMware Workstation 5.x. You have to manually enable it in the .vmx file.

Put this line in the .vmx file for your virtual machine:
mks.enable3d = TRUE

And add/change this line to change the amount of video memory for the VM (this one is 32 MB):
svga.vramSize = "33554432""
Ya, I did that. I actualy went to that exact same site Problem is, I get the error after putting the lines in the file.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Enable Direct3D in VMware