Overclock.net › Forums › Components › Hard Drives & Storage › Maxtor Primary master disk fail Detected in Bios but not detected in Disk Management
New Posts  All Forums:Forum Nav:

Maxtor Primary master disk fail Detected in Bios but not detected in Disk Management

post #1 of 3
Thread Starter 
Maxtor 80gb ATA hard drive
Model # 4R080L0
FIRMWARE# RAMC1TU0

The problem i am having is the hard drive is detected in the bios but is not detected in windows even in Disk Management but some Programs on Hiren's boot CD detect it but programs like Killdisk , hdd regenerator and even maxtor max blast 5 cannot detect the drive but seagate seatools does i tried repairing bad sectors with the seagate tool but 98 sectors at a time takes a while if i let it detect 99 bad sectors it will say read error most of the sectors get repaired i tried a low level format that did not help
i am guessing the drive needs a firmware update any idea where i can get a update firmware for this drive this is just an extra drive laying around im just curious if i can be revived again.

Here is a few pics of some of the tools that detected the drive and some that dont:














post #2 of 3
Thread Starter 
Just emailed Maxtor about this asking for a Firmware update hope it helps.
post #3 of 3
Thread Starter 
Nick TS174: There are no firmware updates for ATA drives....
Nick TS174: only SATA and SCSI

?????????? is this true?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Hard Drives & Storage
Overclock.net › Forums › Components › Hard Drives & Storage › Maxtor Primary master disk fail Detected in Bios but not detected in Disk Management