Overclock.net › Forums › Industry News › Software News › Microsoft gets nVidia’s SLi and ATi’s Crossfire working in Vista
New Posts  All Forums:Forum Nav:

Microsoft gets nVidia’s SLi and ATi’s Crossfire working in Vista

post #1 of 7
Thread Starter 
Microsoft gets nVidia's SLi and ATi's Crossfire working in Vista Ever since Vista came out, owners of ATi and nVidia graphic cards have been complaining about the lack of WHQL certified drivers which has now been rectified, at least on the nVidia side but one of the problems with the drivers still existed, no multi-GPU support. Microsoft has released a fix for that problem.

It seems that the reason SLi or Crossfire dual GPU solutions weren’t working in Vista was because the operating system failed to send instructions to the second GPU so both cards were still functioning as one board. The purpose of SLi and Crossfire is to allow two graphic cards to function as one.

Neither ATi nor nVidia could have done anything different as this was a problem with Vista itself, they could have released driver after driver and it would not have fixed the problem. Microsoft has heard you, good people of the world and have (sort of) released a fix for Crossfire and SLi not working in Vista.

This problem is described in this Microsoft support article but be forewarned, it was not kind enough to provide a link to download the update. If you suffer from this problem on Vista, you will have to contact Microsoft support and (I suppose) reference the support article or just forgo that whole process and download the update from a third party site, Guru 3D which has so kindly provided a direct download link.

In addition to having this Microsoft update installed, it also wouldn’t hurt to nab the latest Vista drivers from ATi or nVidia based on which side of the fence you are on. Note that most drivers listed on the sites are not applicable to mobile solutions (in laptops).





http://vista.blorge.com/2007/07/22/m...king-in-vista/
post #2 of 7
This is good!
My l33t computer
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon 2.6GHz Dual core 5200+ A-Bit KN9-SLI (freakin' sucks) EVGA 8800GTS 320MB Corsair value select 1GB PC5300 
Hard DriveOptical DriveOSMonitor
250GB SATA Western Digital 16MB cache Memorex 52X Read 52X Write 32X Rewrite 16X DVD Micro$oft Windows XP Home Samsung 17" SyncMaster731b 
KeyboardPowerCaseMouse
Micro$oft black keyboard Ulta 550Watt modular W/ blue LED! Antec p160w Logintech $10 optical mouse 
Mouse Pad
Plain black one 
  hide details  
Reply
My l33t computer
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon 2.6GHz Dual core 5200+ A-Bit KN9-SLI (freakin' sucks) EVGA 8800GTS 320MB Corsair value select 1GB PC5300 
Hard DriveOptical DriveOSMonitor
250GB SATA Western Digital 16MB cache Memorex 52X Read 52X Write 32X Rewrite 16X DVD Micro$oft Windows XP Home Samsung 17" SyncMaster731b 
KeyboardPowerCaseMouse
Micro$oft black keyboard Ulta 550Watt modular W/ blue LED! Antec p160w Logintech $10 optical mouse 
Mouse Pad
Plain black one 
  hide details  
Reply
post #3 of 7
Im fairly sure I read this on here in the last day or two?

http://www.overclock.net/news-overcl...ire-vista.html
post #4 of 7
Just posting to let everyone know that I've noticed no performance increase in my own system with this hotfix installed, nor any increase in benchmark scores. Before installing the hotfix I would only get about 11000ish in 3DMark06 with SLi disabled, and 14387 with SLi enabled. This tells me that SLi was already working anyway before I installed the hotfix.

This patch is only intended to fix certain combinations of hardware.
post #5 of 7
Is there going to be a boost in 06 scores with this fixed?
    
CPUGraphicsRAMHard Drive
Intel Core 2 Duo 2.00GHz ATI Radeon HD 3650 512MB RAM 4GB DDR2 800MHZ One 250GB and one 320GB 
Optical DriveOSMonitorKeyboard
DVD-RW Windows vista  17" Toshiba Toshiba 
PowerCaseMouseMouse Pad
Toshiba Touchpad None 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
Intel Core 2 Duo 2.00GHz ATI Radeon HD 3650 512MB RAM 4GB DDR2 800MHZ One 250GB and one 320GB 
Optical DriveOSMonitorKeyboard
DVD-RW Windows vista  17" Toshiba Toshiba 
PowerCaseMouseMouse Pad
Toshiba Touchpad None 
  hide details  
Reply
post #6 of 7
It's good to know that there has been some fixes. I'll definitely keep that fix in mind if I get another GTX down the road, just in case. Thanks for informing us on it, if it can help out even 1 person then it's worth it.
    
CPUMotherboardGraphicsRAM
Intel Q6600 G0 @ 3.6GHz (lapped) EVGA 780i SLI FTW @ 1600MHz FSB 2 x EVGA 8800GTX 768MB (SLI) @ 625/1500/2000MHz 2x2GB G.Skill PC2-8000 PQ @ 800MHz (linked to FSB) 
Hard DriveOptical DriveOSMonitor
2x160GB WD RAID 0, 750GB Samsung Spinpoint F1 LITE-ON 20X SATA DVD/CD RW Windows 7 Ultimate x64 Viewsonic VA2702w 27" LCD 1920x1080 
KeyboardPowerCaseMouse
Logitech Value 100 (beer magnet) Corsair TX 750W Cooler Master ATCS 840 Logitech SBF-90 (cheapest one on Newegg) 
Mouse Pad
Some kinda rubber thing (beer magnet) 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Q6600 G0 @ 3.6GHz (lapped) EVGA 780i SLI FTW @ 1600MHz FSB 2 x EVGA 8800GTX 768MB (SLI) @ 625/1500/2000MHz 2x2GB G.Skill PC2-8000 PQ @ 800MHz (linked to FSB) 
Hard DriveOptical DriveOSMonitor
2x160GB WD RAID 0, 750GB Samsung Spinpoint F1 LITE-ON 20X SATA DVD/CD RW Windows 7 Ultimate x64 Viewsonic VA2702w 27" LCD 1920x1080 
KeyboardPowerCaseMouse
Logitech Value 100 (beer magnet) Corsair TX 750W Cooler Master ATCS 840 Logitech SBF-90 (cheapest one on Newegg) 
Mouse Pad
Some kinda rubber thing (beer magnet) 
  hide details  
Reply
post #7 of 7
Another pretty fast response. Could have been faster but this kind of fix isnt a walk in the park. I heard many complaints about Vista and multi GPU units. Im glad to see there working on it.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Software News
Overclock.net › Forums › Industry News › Software News › Microsoft gets nVidia’s SLi and ATi’s Crossfire working in Vista