Overclock.net › Forums › Video Games › PC Gaming › good fps on lost planet??? ( full game )
New Posts  All Forums:Forum Nav:

good fps on lost planet??? ( full game )

post #1 of 3
Thread Starter 
hi,

i recently installed lost planet on vista,
so i'm using dx10

whats a decent fps to play?

i only get around 20fps when i have everything maxed out.

it does play verry well but looks like a verry low fps.
<| SkyWareZ |>
(15 items)
 
Clevo P170EM
(11 items)
 
 
CPUMotherboardGraphicsRAM
<| Intel i7 860 @ 4.04Ghz |> <| Asus P7P55D Premium |> <| GIGABYTE GTX970 G1 Gaming |> <| G-Skill Ripjaws 1600 CL7 2x4 |> 
Hard DriveOptical DriveCoolingOS
<| C300 128GB | F3 1TB | 2X WD GREEN 2TB |> <| Plextor PX-L890SA |>  WC loop : CPU <| Windows 10 |> 
MonitorKeyboardPowerCase
<| ASUS PB278Q |> logitech g15 v1 <| Corsair AX1200 |> <| Coolermaster HAF X |> 
MouseMouse PadAudio
<| Logitech G5/G500/G9x |> <| Steelseries Qck+ Tyloo |> <| X-Fi Titanium Fatality + Sennheiser PC360 |> 
CPUMotherboardGraphicsRAM
Intel Core i7-3630Q P170EM GTX 675MX 8GB 1600mhz 2x4 Kingston 
Hard DriveHard DriveOptical DriveOS
Intel 520 120GB WD Scorpio Black 750GB Sony-Optiarc BD-5750H Windows 7 Utimate  
MonitorAudioOther
17.3" WUXGA Led 1920x1080 Glare Onkyo Speakers Intel Wifi 6235 
  hide details  
Reply
<| SkyWareZ |>
(15 items)
 
Clevo P170EM
(11 items)
 
 
CPUMotherboardGraphicsRAM
<| Intel i7 860 @ 4.04Ghz |> <| Asus P7P55D Premium |> <| GIGABYTE GTX970 G1 Gaming |> <| G-Skill Ripjaws 1600 CL7 2x4 |> 
Hard DriveOptical DriveCoolingOS
<| C300 128GB | F3 1TB | 2X WD GREEN 2TB |> <| Plextor PX-L890SA |>  WC loop : CPU <| Windows 10 |> 
MonitorKeyboardPowerCase
<| ASUS PB278Q |> logitech g15 v1 <| Corsair AX1200 |> <| Coolermaster HAF X |> 
MouseMouse PadAudio
<| Logitech G5/G500/G9x |> <| Steelseries Qck+ Tyloo |> <| X-Fi Titanium Fatality + Sennheiser PC360 |> 
CPUMotherboardGraphicsRAM
Intel Core i7-3630Q P170EM GTX 675MX 8GB 1600mhz 2x4 Kingston 
Hard DriveHard DriveOptical DriveOS
Intel 520 120GB WD Scorpio Black 750GB Sony-Optiarc BD-5750H Windows 7 Utimate  
MonitorAudioOther
17.3" WUXGA Led 1920x1080 Glare Onkyo Speakers Intel Wifi 6235 
  hide details  
Reply
post #2 of 3
I tend to say a minimum of 30FPS is playable speeds.

Try dropping the FSAA or AF down by a notch
Desktop
(13 items)
 
  
CPUMotherboardGraphicsRAM
Opteron 165 CCBBE 0615DPMW 2.6GHz (9x290) DFI NF4 SLI-D (HR-05-SLI Passive Chipset Cooler) BFG 8800GTS OC 640MB 620/1860 Mushkin Redline 4x1GB DDR475 (3-3-2-7 2T) 
Hard DriveOptical DriveOSMonitor
3x 74GB WD Raptor (RAID 0) + 2.2TB of SATA HDDs NEC DVD/RW SATA XP Home Edition SP3 IIyama H481S 19' TFT 1280x1024 
KeyboardPowerCaseMouse
Eluminix (Backlight) OCZ Modstream520w 28A,12v Single Rail Antec P182 Razer, Copperhead Blue 
Mouse Pad
Razer Exactamat 
  hide details  
Reply
Desktop
(13 items)
 
  
CPUMotherboardGraphicsRAM
Opteron 165 CCBBE 0615DPMW 2.6GHz (9x290) DFI NF4 SLI-D (HR-05-SLI Passive Chipset Cooler) BFG 8800GTS OC 640MB 620/1860 Mushkin Redline 4x1GB DDR475 (3-3-2-7 2T) 
Hard DriveOptical DriveOSMonitor
3x 74GB WD Raptor (RAID 0) + 2.2TB of SATA HDDs NEC DVD/RW SATA XP Home Edition SP3 IIyama H481S 19' TFT 1280x1024 
KeyboardPowerCaseMouse
Eluminix (Backlight) OCZ Modstream520w 28A,12v Single Rail Antec P182 Razer, Copperhead Blue 
Mouse Pad
Razer Exactamat 
  hide details  
Reply
post #3 of 3
I get around the same fps at 1280x1024 and it seems very playable. To tell you the truth though, DX10 doesn't look any different than DX9 in that game. And with DX9, you get 2-3x more fps. I just play it in DX9.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › good fps on lost planet??? ( full game )