Overclock.net › Forums › Graphics Cards › AMD/ATI › New 3870X2 Problem - Screen going black, red light going on.
New Posts  All Forums:Forum Nav:

New 3870X2 Problem - Screen going black, red light going on.

post #1 of 30
Thread Starter 
I just picked up my new Asus 3870X2, and after installing it, this happens. Sometimes when I boot up the screen turns off and the little red light on my graphics card comes on. It sometimes successfully boots and I tried running Crysis with no luck. Just before the screen conked out, I was getting an awful fps. I just tried the CSS stress test and I get an apauling fps. Well, right before the screen turned off.

I'm not sure what the problem is. Could it be my 600w psu not coping with a quad core and a 3870X2?

Thanks guys!
post #2 of 30
Quote:
Originally Posted by Rusty100 View Post
I just picked up my new Asus 3870X2, and after installing it, this happens. Sometimes when I boot up the screen turns off and the little red light on my graphics card comes on. It sometimes successfully boots and I tried running Crysis with no luck. Just before the screen conked out, I was getting an awful fps. I just tried the CSS stress test and I get an apauling fps. Well, right before the screen turned off.

I'm not sure what the problem is. Could it be my 600w psu not coping with a quad core and a 3870X2?

Thanks guys!
What PSU, link please.
Previous drivers uninstalled correctly?
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
post #3 of 30
Thread Starter 
Yes, uninstalled previous drivers. And it's a generic 600w PSU.
post #4 of 30
all the power cords connected to the card
    
CPUMotherboardGraphicsRAM
Intel Core i7 7820k @4.8GHZ ROG RAMPAGE VI APEX PNY 1080 Ti  64GB Corsair Vengeance 3200MHZ 
Hard DriveOptical DriveCoolingOS
[Samsung 950 Pro 512GB][2X Samsung 840 250GB Ra... 16X LITESCRIDE DVD-RW EK Double Res, Double Pump, GPU, CPU combo Windows 10 x64 
MonitorKeyboardPowerCase
55IN 4K  Ducky Shine Corsair RM 1000i Modular STH10 
Mouse
Corsair m95 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 7820k @4.8GHZ ROG RAMPAGE VI APEX PNY 1080 Ti  64GB Corsair Vengeance 3200MHZ 
Hard DriveOptical DriveCoolingOS
[Samsung 950 Pro 512GB][2X Samsung 840 250GB Ra... 16X LITESCRIDE DVD-RW EK Double Res, Double Pump, GPU, CPU combo Windows 10 x64 
MonitorKeyboardPowerCase
55IN 4K  Ducky Shine Corsair RM 1000i Modular STH10 
Mouse
Corsair m95 
  hide details  
Reply
post #5 of 30
Quote:
Originally Posted by Rusty100 View Post
Yes, uninstalled previous drivers. And it's a generic 600w PSU.

Did you have an ATI card before?
What drivers, disk or D/L?
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
post #6 of 30
Thread Starter 
It needs a 6-pin and an 8-pin, but I've only got 2 6-pins connected as my PSU doesn't have a 8-pin.
post #7 of 30
Thread Starter 
Quote:
Originally Posted by grunion View Post
Did you have an ATI card before?
What drivers, disk or D/L?
Yes, I had an x1950XTX, latest ATI 9.2 drivers which when I got my new card I uninstalled and reinstalled.
post #8 of 30
Quote:
Originally Posted by Rusty100 View Post
It needs a 3-pin and a 4-pin, but I've only got 2 3-pins connected as my PSU doesn't have a 4-pin (I think I'm calling those the correct things).
6pin and 8pin
Edit: Try your other pcie slot.
Black Box 3
(13 items)
 
  
CPUMotherboardGraphicsHard Drive
i7 920 4GHz 1.248 VCore Gig EX58-UD3R 5870 2x160GB Hitachi RAID 0, 500GB WD 
Optical DriveOSPowerCase
ASUS DRW-2014L1T Windows 7 Ultimate 64bit SilverStone Zeus 850w Antec 902 
  hide details  
Reply
Black Box 3
(13 items)
 
  
CPUMotherboardGraphicsHard Drive
i7 920 4GHz 1.248 VCore Gig EX58-UD3R 5870 2x160GB Hitachi RAID 0, 500GB WD 
Optical DriveOSPowerCase
ASUS DRW-2014L1T Windows 7 Ultimate 64bit SilverStone Zeus 850w Antec 902 
  hide details  
Reply
post #9 of 30
Thread Starter 
Quote:
Originally Posted by xdaseinx View Post
6pin and 8pin
Edit: Try your other pcie slot.
My bad! Thanks

Trying my second PCI-E Slot now.

Nope, same problem.
post #10 of 30
Thread Starter 
Guys, please help.

I bought a new power supply (thermaltake toughpower 850w) and the computer seemed to boot faster.

Apon opening the ATI control centre, I find out the GPU is 103 degrees celcius. I mean jesus christ, why? Can anyone help?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › New 3870X2 Problem - Screen going black, red light going on.