New Posts  All Forums:Forum Nav:

wireless - ugh

post #1 of 28
Thread Starter 
i know ive posted this before, but ive been trying and trying and trying - even posting on other distro specific forums for help - all to no avail.

ive had this problem in slackware and suse (specifically this problem)

- Linksys WUSB54GC wireless USB adapter btw, also: connecting to a Linksys WRT54G v1.0 router

i can install my wireless usb adapter driver, i get the Driver installed, Device Present from ndiswrapper -l , kwifimanager AND rutilt show that i am indeed connected - i can ping 192.168.1.1 and get good results, however i cant ping something as simply as www.google.ca

everything leads me to believe i am in fact connected but there seems to be SOMETHING stopping me from being successful.

ive used several different drivers and they all get the same result - ive even tried 32bit vs 64bit drivers (the 64's wouldnt install properly, so that must just be due to slackware 12 not being 64bit?)

If ANYONE has been to this point before and have found a solution, please please PLEASE share it with me as this problem continues to stump me. i'll provide as much information as necessary. hopefully i wont ever need to post a wireless thread again after this one.


add: btw wireless works fine for me in ubuntu 7.10 and Mint (but those arent the distros i want to use )
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
post #2 of 28
If your problem was like mine...you're gonna need a new adapter. My problem was this:

I was using a cable connection (now i have wi-fi on my desktop ) and I could connect to the internet but whenever I tried to go to google.com or whatnot, it would say "error 404 or something". If your problem is that you only get a "unable to establish connection" error, then you might wanna try troubleshooting another wi-fi card/USB adapter.
ridonkulous
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8400 DFI LanParty P45-T2RS Diamond HD4850 (2x2)GB G.Skill DDR2-800 - PKs 
Hard DriveOptical DriveOSPower
WD 160GB Seagate 250GB Asus DVD-Burner Vista Ultimate (64bit) Thermaltake Toughpower 750W 
Case
Antec P180b 
  hide details  
Reply
ridonkulous
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8400 DFI LanParty P45-T2RS Diamond HD4850 (2x2)GB G.Skill DDR2-800 - PKs 
Hard DriveOptical DriveOSPower
WD 160GB Seagate 250GB Asus DVD-Burner Vista Ultimate (64bit) Thermaltake Toughpower 750W 
Case
Antec P180b 
  hide details  
Reply
post #3 of 28
Thread Starter 
i get the whole, "This page cannot be displayed" problem. as i said, my adapter must be working to some level in linux since i can connect to my default gateway, send AND receive packets. ugh lol.
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
post #4 of 28
hmm... try going to cmd (start, run, type 'cmd', press enter) and typing "ipconfig /renew"

If that doesn't work , I'd say troubleshoot a PCI adapter (best bet for you getting wireless on your dektop).

edit: Are you sure linksys has drivers that support your version of linux?
ridonkulous
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8400 DFI LanParty P45-T2RS Diamond HD4850 (2x2)GB G.Skill DDR2-800 - PKs 
Hard DriveOptical DriveOSPower
WD 160GB Seagate 250GB Asus DVD-Burner Vista Ultimate (64bit) Thermaltake Toughpower 750W 
Case
Antec P180b 
  hide details  
Reply
ridonkulous
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8400 DFI LanParty P45-T2RS Diamond HD4850 (2x2)GB G.Skill DDR2-800 - PKs 
Hard DriveOptical DriveOSPower
WD 160GB Seagate 250GB Asus DVD-Burner Vista Ultimate (64bit) Thermaltake Toughpower 750W 
Case
Antec P180b 
  hide details  
Reply
post #5 of 28
Thread Starter 
Quote:
Originally Posted by tofumonster View Post
hmm... try going to cmd (start, run, type 'cmd', press enter) and typing "ipconfig /renew"

If that doesn't work , I'd say troubleshoot a PCI adapter (best bet for you getting wireless on your dektop).

the problem is with wireless + linux, it works fine in windows.
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
post #6 of 28
I've used two different linksys adapters in linux, scratch that, tried to use, and i got my wusb54g working 1 time, out of like 20 installs. those chips just aren't that great with ndiswrapper. I know the one time i got it to work on suse it took me about a day of trying things, and i could never get it to go again. you may need to just get a new adapter.
post #7 of 28
Open a terminal and type:

Code:
dmesg | grep ndiswrapper
Magicbox
(17 items)
 
crapbox
(13 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 AX370-Gamin K7 Nitro+ RX480 Corsair LPX 
Hard DriveHard DriveHard DriveCooling
Samsung 850 EVO  Kingston HyperX 3K Seagate Barracuda 7200.14 Noctua NH-D15 
OSOSMonitorKeyboard
Kubuntu  Windows 10 Pro Dell U2515H CM Quickfire TK (Cherry Blue) 
PowerCaseMouseMouse Pad
EVGA 750 G2 Enthoo Pro Logitech G502 Logitech G440 
CPUMotherboardGraphicsRAM
Sempron 3300+ HP stock mobo (laptop) 200M (IGP) 2x1GB PC3200 
Hard DriveOptical DriveOSMonitor
100GB ATA133 DVD/CDRW Kubuntu 32 bit 14.1" (1280x768) 
Power
6 cell 
  hide details  
Reply
Magicbox
(17 items)
 
crapbox
(13 items)
 
 
CPUMotherboardGraphicsRAM
Ryzen 7 1700 AX370-Gamin K7 Nitro+ RX480 Corsair LPX 
Hard DriveHard DriveHard DriveCooling
Samsung 850 EVO  Kingston HyperX 3K Seagate Barracuda 7200.14 Noctua NH-D15 
OSOSMonitorKeyboard
Kubuntu  Windows 10 Pro Dell U2515H CM Quickfire TK (Cherry Blue) 
PowerCaseMouseMouse Pad
EVGA 750 G2 Enthoo Pro Logitech G502 Logitech G440 
CPUMotherboardGraphicsRAM
Sempron 3300+ HP stock mobo (laptop) 200M (IGP) 2x1GB PC3200 
Hard DriveOptical DriveOSMonitor
100GB ATA133 DVD/CDRW Kubuntu 32 bit 14.1" (1280x768) 
Power
6 cell 
  hide details  
Reply
post #8 of 28
Thread Starter 
Quote:
Originally Posted by Melcar View Post
Open a terminal and type:

Code:
dmesg | grep ndiswrapper

got this:

Code:
ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
usbcore: registered new interface driver ndiswrapper
- the problem hasnt changed after that command.


also, last night i installed steam and was able to login to my account...(before above command)
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
post #9 of 28
Sometimes it's the really simple things.

First, what exactly does "ndiswrapper -l" print out for you? You may have to blacklist the alternate broadcom driver if it's shown (if my memory serves).

Secondly, left click on the networking icon next to your clock and see if network manager sees any wireless signals. I didn't do this and even though I had everything installed right, the simple interface was too far above me to think about. Wasted weeks trying to figure out why it was installed but not connected (just needed to be told which router to connect to). One of my stupid mistakes.
Honor
(13 items)
 
  
CPUMotherboardGraphicsRAM
e2200@9x305Mhz 1.28750V P31-DS3L Gigabyte EVGA 8800gt 512MB OCZ ddr2 Gold 2GB 800 @ 915 
Hard DriveOSMonitorPower
500 GB Maxtor Ubuntu 7.10 with Wine Samsung 2ms 1440x900 LCD Antec TruePower Trio 650 
Case
Cooler Master 690 
  hide details  
Reply
Honor
(13 items)
 
  
CPUMotherboardGraphicsRAM
e2200@9x305Mhz 1.28750V P31-DS3L Gigabyte EVGA 8800gt 512MB OCZ ddr2 Gold 2GB 800 @ 915 
Hard DriveOSMonitorPower
500 GB Maxtor Ubuntu 7.10 with Wine Samsung 2ms 1440x900 LCD Antec TruePower Trio 650 
Case
Cooler Master 690 
  hide details  
Reply
post #10 of 28
Oops, I see you use kwifimanager (from your first post) which I know nothing about, and you may not have an icon next to your clock. Disregard my thoughts in that direction.
Honor
(13 items)
 
  
CPUMotherboardGraphicsRAM
e2200@9x305Mhz 1.28750V P31-DS3L Gigabyte EVGA 8800gt 512MB OCZ ddr2 Gold 2GB 800 @ 915 
Hard DriveOSMonitorPower
500 GB Maxtor Ubuntu 7.10 with Wine Samsung 2ms 1440x900 LCD Antec TruePower Trio 650 
Case
Cooler Master 690 
  hide details  
Reply
Honor
(13 items)
 
  
CPUMotherboardGraphicsRAM
e2200@9x305Mhz 1.28750V P31-DS3L Gigabyte EVGA 8800gt 512MB OCZ ddr2 Gold 2GB 800 @ 915 
Hard DriveOSMonitorPower
500 GB Maxtor Ubuntu 7.10 with Wine Samsung 2ms 1440x900 LCD Antec TruePower Trio 650 
Case
Cooler Master 690 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix