Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Linux creative drivers install issues
New Posts  All Forums:Forum Nav:

Linux creative drivers install issues - Page 3

post #21 of 38
Thread Starter 
dkpg --purge oss-linux failed out. Im at work right now so i dont remember why. Ill give the .tar a go again after work.
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
post #22 of 38
Thread Starter 
This is what i get with a dpkg --purge oss-linux
Quote:
(Reading database ... 101852 files and directories currently installed.)
Removing oss-linux ...
sh: Can't open /usr/lib/oss/scripts/restore_drv.sh
dpkg: error processing oss-linux (--purge):
subprocess pre-removal script returned error exit status 2
Building OSS Modules for Linux-unknown 2.6.24-16-generic
cd: 3: can't cd to /usr/lib/oss/build
sh: Can't open install.sh
Starting Open Sound System
cat: /usr/lib/oss/version.dat: No such file or directory
/usr/lib/oss/etc/devices.list: No such file or directory
No /usr/lib/oss/etc/installed_drivers - cannot continue
Errors were encountered while processing:
oss-linux
And this is what i get when i try to run the tar command.
Quote:
cd: 9: can't cd to /usr/lib/oss/build
./usr/lib/oss/build/install.sh: 27: /usr/sbin/ossvermagic: Permission denied
ln: creating symbolic link `/usr/lib/oss/objects': Permission denied
ln: creating symbolic link `/usr/lib/oss/modules': Permission denied
Error: OSS core module for NOREGPARM kernel are not available
both were run sudo.
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
post #23 of 38
Sounds like the stuff it's trying to delete already isn't there.
post #24 of 38
Thread Starter 
ok so reinstalled ubuntu, reinstalled the dependencies, and started up the deb package again. It got all the way through the install, detected my sound devices, when it go to starting open sound system i got this
Quote:
ERROR: Module snd_hda_intel is in use
ERROR: Module snd_pcm is in use by snd_hda_intel
ERROR: Module snd_page_alloc is in use by snd_hda_intel,snd_pcm
ERROR: Module snd_hwdep is in use by snd_hda_intel
ERROR: Module snd_timer is in use by snd_pcm
and it just repets itself about 20 times.
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
post #25 of 38
Is your onboard sound turned on in the BIOS?
post #26 of 38
Thread Starter 
your joking right? i have to turn the sound in bios off? I gotta go to work, so ill keep learning and giving whatever feeback i can when i get home at midnight.
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
post #27 of 38
This is on your sig rig, correct? I see you have an x-fi. If you're trying to use the x-fi, I would assume you need to turn off your motherboard's onboard sound. Same should go for windows, shouldn't it?
post #28 of 38
Thread Starter 
um no, i can use both in windows, just not at the same time.
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
Deep Blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom 2 X4 940 BE MSI DKA790GX Platinum Sapphire HD4890 OC Corsair C5D8500 2x1Gig Kit 
Hard DriveOptical DriveOSMonitor
WD Cavair Black 500 LG DVD+ RW Windows 7 Ultimate Samsung 2494hs 24 Wide 
KeyboardPowerCaseMouse
Razer Tarantula Enermax Liberty 620W DD Torture Rack Razer Lachesis 
Mouse Pad
Razer Pro Solutions 
  hide details  
Reply
post #29 of 38
Ahh - shame I didn't see that dpkg error before you reinstalled. I went through the same thing, you need to manually purge OSS from dpkg's files. There is some sort of bug that keeps it from removing everything.
http://www.4front-tech.com/forum/viewtopic.php?t=2054

The issue that you are currently having is because ALSA is using your onboard sound, and OSS is trying to allocate it for itself. The simple solution is to kill off ALSA since you won't need it anyways. Go System -> Administration -> Services and uncheck anything related to alsa, then reboot and try again.
Morpheus Mini
(7 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700T SN970 GTX 960 Crucial CT102464BF160B 
Hard DriveOSAudio
Samsung 850 Evo M.2 Windows 10 Pro MOTU Audio Express 
  hide details  
Reply
Morpheus Mini
(7 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700T SN970 GTX 960 Crucial CT102464BF160B 
Hard DriveOSAudio
Samsung 850 Evo M.2 Windows 10 Pro MOTU Audio Express 
  hide details  
Reply
post #30 of 38
Well it looks like there are two things conflicting from the output you posted. You might want to try disabling the onboard (especially if you don't use it in windows anyway).
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Linux creative drivers install issues