Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Raid 0 + Kubuntu 8.04 x64 = ????
New Posts  All Forums:Forum Nav:

Raid 0 + Kubuntu 8.04 x64 = ????

post #1 of 12
Thread Starter 
How does one Raid 0 on Hardy?

I can install Vista fine, but I can't seem to install Kubuntu on Raid 0. Would it be better to make two separate Raid volumes, or a single volume and then partition it?

Also, if the Raid 0 just won't work, is there a way I can use part of the hard drives for a Raid 0 volume, and then the other part of one drive for Ubuntu? The worst part is that even if it installs correctly, I won't be able to make Grub work properly...

Any ideas? Thanks.

(I'm using the KDE4 version, btw. It looks so nice!)
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
post #2 of 12
Quote:
Originally Posted by Muhahahaha View Post
How does one Raid 0 on Hardy?
It doesn't work out of the box, unless they changed it in this version.

It is possible to get it working, but I've never gone through the process.

Quote:
Originally Posted by Muhahahaha View Post
Also, if the Raid 0 just won't work, is there a way I can use part of the hard drives for a Raid 0 volume, and then the other part of one drive for Ubuntu? The worst part is that even if it installs correctly, I won't be able to make Grub work properly...
No, this won't work under the laws of RAID, unfortunately.
post #3 of 12
Thread Starter 
Wow, is that kinda like the laws of Physics? Lol.

Yeah, I saw a tutorial somewhere, and I almost had it working, but now something else weird is happening. I'll have more details later.
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
post #4 of 12
Make sure you backup whenever you're dealing with HDD formatting and/or partitioning... If you lose data, I will laugh.
post #5 of 12
Thread Starter 
Yeah, I don't ever put any data on my OS drives. I have a completely separate 750GB drive that is just for data (as per my sig).

Is there a way to make Linux ignore certain hard drives? For instance, I have Linux installed on one of my old 250GB Sata 1.5Gbps drives, and Windows on my Raid 0 volume. Grub is on the 250GB drive, and I made a Grub entry for booting to (hd1,0), which is the Raid 0, and it works correctly, except for one thing.

Every time I boot into Linux, it sees the Raid as two separate disks, /dev/sdb and /dev/sdc. Even though it doesn't mount them, since they aren't in /etc/fstab, detecting them messes the Raid up temporarily. The next time I reboot, the Raid array is deactivated or something, and I can't boot to it. If I simply shut the computer off for a few seconds, and then turn it on, the Raid usually reactivates and I can boot to it again.

So how do I make Linux NOT detect them at all? Or some other way to fix this.
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
post #6 of 12
dmraid. its in my ubuntu n00b guide within the linux section. PM me if you need help. I have done this on my system
New Build!
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 2500K Gigabyte Z68X-UD5-B3 Sapphire 5770 Microcenter 2x2GB 
Hard DriveOptical DriveOSMonitor
1x64GB SSD, 2TB WD LG Sata DVD+-RW, Sony Blu Ray Windows 7 Enterprise x64 / Debian 6.0 / OSX Samsung SyncMaster P2450 
KeyboardPowerCaseMouse
Logitech Ergo Kingwin 650W CoolerMaster Razer Salmosa 
  hide details  
Reply
New Build!
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 2500K Gigabyte Z68X-UD5-B3 Sapphire 5770 Microcenter 2x2GB 
Hard DriveOptical DriveOSMonitor
1x64GB SSD, 2TB WD LG Sata DVD+-RW, Sony Blu Ray Windows 7 Enterprise x64 / Debian 6.0 / OSX Samsung SyncMaster P2450 
KeyboardPowerCaseMouse
Logitech Ergo Kingwin 650W CoolerMaster Razer Salmosa 
  hide details  
Reply
post #7 of 12
last time I tried this I blasted my whole raid clean...ubuntu sucks for raid support, trust me.
Workstation #1
(17 items)
 
   
CPUMotherboardGraphicsRAM
AMD Ryzen 7 1800X Asus ROG Crosshair VI Gigabyte GTX 1080 Crucial Ballistix Sport 
Hard DriveHard DriveHard DriveHard Drive
Crucial MX300 1TB M.2 SSD Hitachi 2TB Sata 3.0 HDD Crucial MX300 1TB 2.5" SSD WD Caviar Black 4TB HDD 
CoolingOSMonitorKeyboard
Corsiair H110i Windows 10 Pro x64 3x Dell U2717D 2560x1440 monitors Coolermaster Masterkeys TKL 
PowerCaseMouseMouse Pad
Corsair CX750M Corsair 600C Logitech G900 Corsair MM200 XL 
Audio
Onboard 
CPUMotherboardGraphicsRAM
Intel Core i7-3540M Dell Latitude E6430 Intel HD4000 6GB DDR3 
Hard DriveOptical DriveCoolingOS
128GB Samsung 841 SSD DVD-ROM drive Stock Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
1600x900 Latitude E6430 screen Das Keyboard Model S Professional Stock Dell Latitude D6430 Chassis 
MouseMouse PadAudio
Steelseries Kinzu V2 Pro None Onboard 
  hide details  
Reply
Workstation #1
(17 items)
 
   
CPUMotherboardGraphicsRAM
AMD Ryzen 7 1800X Asus ROG Crosshair VI Gigabyte GTX 1080 Crucial Ballistix Sport 
Hard DriveHard DriveHard DriveHard Drive
Crucial MX300 1TB M.2 SSD Hitachi 2TB Sata 3.0 HDD Crucial MX300 1TB 2.5" SSD WD Caviar Black 4TB HDD 
CoolingOSMonitorKeyboard
Corsiair H110i Windows 10 Pro x64 3x Dell U2717D 2560x1440 monitors Coolermaster Masterkeys TKL 
PowerCaseMouseMouse Pad
Corsair CX750M Corsair 600C Logitech G900 Corsair MM200 XL 
Audio
Onboard 
CPUMotherboardGraphicsRAM
Intel Core i7-3540M Dell Latitude E6430 Intel HD4000 6GB DDR3 
Hard DriveOptical DriveCoolingOS
128GB Samsung 841 SSD DVD-ROM drive Stock Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
1600x900 Latitude E6430 screen Das Keyboard Model S Professional Stock Dell Latitude D6430 Chassis 
MouseMouse PadAudio
Steelseries Kinzu V2 Pro None Onboard 
  hide details  
Reply
post #8 of 12
sc30317, if you use dmraid + gparted to sort out your partitions, it'll kill your raid in hardy, the way you have to reload the partition table, it constantly told me that I had none, and it was unallocated or something, and then after fiddling I managed to totally destroy my partitions.

Sorry for double post, I need to remember where buttons are...
Workstation #1
(17 items)
 
   
CPUMotherboardGraphicsRAM
AMD Ryzen 7 1800X Asus ROG Crosshair VI Gigabyte GTX 1080 Crucial Ballistix Sport 
Hard DriveHard DriveHard DriveHard Drive
Crucial MX300 1TB M.2 SSD Hitachi 2TB Sata 3.0 HDD Crucial MX300 1TB 2.5" SSD WD Caviar Black 4TB HDD 
CoolingOSMonitorKeyboard
Corsiair H110i Windows 10 Pro x64 3x Dell U2717D 2560x1440 monitors Coolermaster Masterkeys TKL 
PowerCaseMouseMouse Pad
Corsair CX750M Corsair 600C Logitech G900 Corsair MM200 XL 
Audio
Onboard 
CPUMotherboardGraphicsRAM
Intel Core i7-3540M Dell Latitude E6430 Intel HD4000 6GB DDR3 
Hard DriveOptical DriveCoolingOS
128GB Samsung 841 SSD DVD-ROM drive Stock Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
1600x900 Latitude E6430 screen Das Keyboard Model S Professional Stock Dell Latitude D6430 Chassis 
MouseMouse PadAudio
Steelseries Kinzu V2 Pro None Onboard 
  hide details  
Reply
Workstation #1
(17 items)
 
   
CPUMotherboardGraphicsRAM
AMD Ryzen 7 1800X Asus ROG Crosshair VI Gigabyte GTX 1080 Crucial Ballistix Sport 
Hard DriveHard DriveHard DriveHard Drive
Crucial MX300 1TB M.2 SSD Hitachi 2TB Sata 3.0 HDD Crucial MX300 1TB 2.5" SSD WD Caviar Black 4TB HDD 
CoolingOSMonitorKeyboard
Corsiair H110i Windows 10 Pro x64 3x Dell U2717D 2560x1440 monitors Coolermaster Masterkeys TKL 
PowerCaseMouseMouse Pad
Corsair CX750M Corsair 600C Logitech G900 Corsair MM200 XL 
Audio
Onboard 
CPUMotherboardGraphicsRAM
Intel Core i7-3540M Dell Latitude E6430 Intel HD4000 6GB DDR3 
Hard DriveOptical DriveCoolingOS
128GB Samsung 841 SSD DVD-ROM drive Stock Windows 7 Professional 64-bit 
MonitorKeyboardPowerCase
1600x900 Latitude E6430 screen Das Keyboard Model S Professional Stock Dell Latitude D6430 Chassis 
MouseMouse PadAudio
Steelseries Kinzu V2 Pro None Onboard 
  hide details  
Reply
post #9 of 12
Thread Starter 
Quote:
Originally Posted by sc30317 View Post
dmraid. its in my ubuntu n00b guide within the linux section. PM me if you need help. I have done this on my system
Yeah, I know about dmraid, but it doesn't work. It just gives me errors about the Raid 0. I'll post them here later.

It's really weird, because there was a point at which dmraid worked for me, but now it doesn't.
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
post #10 of 12
Thread Starter 
Here is what it says when I try to use dmraid:

Quote:
root@ubuntu:/etc/apt# fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x16225608

Device Boot Start End Blocks Id System
/dev/sda1 * 1 131 1052226 83 Linux
/dev/sda2 132 1177 8401995 82 Linux swap / Solaris
/dev/sda3 1178 4441 26218080 83 Linux
/dev/sda4 4442 30401 208523700 83 Linux

Disk /dev/sdb: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0005b3e0

Device Boot Start End Blocks Id System

Disk /dev/sdc: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0007648b

Device Boot Start End Blocks Id System


Disk /dev/sdd: 750.1 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf40fd159

Device Boot Start End Blocks Id System
/dev/sdd1 1 91202 732571648 7 HPFS/NTFS
root@ubuntu:/etc/apt# dmraid -ay
ERROR: isw device for volume "Volume0" broken on /dev/sdc in RAID set "isw_ehdgehfia_Volume0"
ERROR: isw: wrong # of devices in RAID set "isw_ehdgehfia_Volume0" [1/2] on /dev/sdc

root@ubuntu:/etc/apt#
I have bolded /dev/sdb and /dev/sdc in the "fdisk -l" above, as those are the two Raid 0 drives.

I will be installing Linux on /dev/sda, one of my old 250GB drives, and all my data is on /dev/sdd, the 750GB drive. I can create a Grub entry for the Raid 0, and it will boot to it, but any time I boot into Linux, the Raid 0 gets messed up temporarily, so I either need Linux to completely ignore those two drives, or to see them correctly as a Raid 0 and not mess them up.

(I say "temporarily messed up" because shutting the machine all the way off and then turning it back on usually fixes it. However, I had a time where Windows would no longer boot, so sometimes it messes it up permanently, I guess.)
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Q6600 G0 @ 3.24GHz w/ 1.36v (L724A760) Gigabyte P35-DS3R rev 1.0 EVGA GTX 285 1GB + ? BIOS (720c/1512s/1377m) 8GB G.Skill PQ @ 1000MHz 5-5-5-15 
Hard DriveOptical DriveOSMonitor
2x320GB 7200.11 Raid0 + 750GB 7200.11 for Storage Samsung SH-S203B Windows 7 Pro x64 Samsung T260HD 1920x1200 + Samsung 226BW 1680x1050 
KeyboardPowerCaseMouse
Saitek Eclipse II PC Power & Cooling Silencer 750W Antec Nine Hundred Razer DeathAdder 
Mouse Pad
Razer Destructor 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Raid 0 + Kubuntu 8.04 x64 = ????