Overclock.net › Forums › Graphics Cards › AMD/ATI › Bought a second HD2900XT, help fixing it?
New Posts  All Forums:Forum Nav:

Bought a second HD2900XT, help fixing it?

post #1 of 8
Thread Starter 
I bought it off ebay as spares/repair as the guy said it wasn't working on his power supply, soo I figured I'd buy it.

But it's still not working. I tried it by itself to begin with, and I just got a black screen. The lights on the card were the same as the one that was working.

I then put it in the other slot (with the other one also) and booted up, and windows detected the broken one fine. I tried connecting another monitor up to the broken card but still no image. Then I tried enabling crossfire, which worked, but when I started up a game the computer crashed.

The card's physical condition looks fine, the only thing I noticed was that when I got it, a piece of clear plastic was over the back of the GPU (on the back of the card). So I'm starting to think maybe he was using this as some kind of prevention to condensation maybe, so therefore he might have been overclocking it and fried it? Not sure though, just a guess.

I thought about maybe a bad bios flash but I don't know what that looks like.

Anyone got any ideas?
Heap O' Junk
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4GHz Asus P6T SE 4850X2 2GB 3x2GB OCZ PC3-12800 
Hard DriveOptical DriveOSMonitor
2x250GB RAID0 7200.10, 320GB 7200.11 Samsung SH-S183ABEBN SATA Windows 7 Pro SM2443BW + HP LP2065 
KeyboardPowerCaseMouse
Logitech G15 v1 Silverstone Zeus ST75ZF TT Lanfire Xaser III Modded Razer Deathadder 
Mouse Pad
Icemat v2 Blue 
  hide details  
Reply
Heap O' Junk
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4GHz Asus P6T SE 4850X2 2GB 3x2GB OCZ PC3-12800 
Hard DriveOptical DriveOSMonitor
2x250GB RAID0 7200.10, 320GB 7200.11 Samsung SH-S183ABEBN SATA Windows 7 Pro SM2443BW + HP LP2065 
KeyboardPowerCaseMouse
Logitech G15 v1 Silverstone Zeus ST75ZF TT Lanfire Xaser III Modded Razer Deathadder 
Mouse Pad
Icemat v2 Blue 
  hide details  
Reply
post #2 of 8
I would start with checking to make sure the cooler is seated properly. Also check to see if its been removed, if possible. Then check the temps when you can get it start in windows as a second card. Im kinda suspect of the plastic cover on the back, exposed PCB area, of the card.

I could be a bad BIOS flash but thats kinda hard to pin down as that. Could be he cooked the card also. Start with those and see what you get back
post #3 of 8
if worst come to worst contact the manufacture and see if you can get it replaced
Coeus
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD 940 Msi 970a-g46 2x xfx 7970 G Skill NQ PC1333 4x2 
Hard DriveOptical DriveOSMonitor
Seagate 7200.9 160gb need Windows 10 64bit Sharp 32inch 
Power
Thermaltake 1350 
  hide details  
Reply
Coeus
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD 940 Msi 970a-g46 2x xfx 7970 G Skill NQ PC1333 4x2 
Hard DriveOptical DriveOSMonitor
Seagate 7200.9 160gb need Windows 10 64bit Sharp 32inch 
Power
Thermaltake 1350 
  hide details  
Reply
post #4 of 8
You mean like this?

No need for giant picture now the question has got across

Its called a backplate mate
    
CPUMotherboardGraphicsRAM
@RMA @RMA EVGA 8800GT @700/1755/2040 2GB OCZ Plat.Rev2 
Hard DriveOSPowerCase
Maxtor Diamondmax 200GB Vista XP Aspire 550W Thermaltake Shark 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
@RMA @RMA EVGA 8800GT @700/1755/2040 2GB OCZ Plat.Rev2 
Hard DriveOSPowerCase
Maxtor Diamondmax 200GB Vista XP Aspire 550W Thermaltake Shark 
  hide details  
Reply
post #5 of 8
Sounds like a bad BIOS flash to me.
post #6 of 8
Quote:
Originally Posted by scottb75 View Post
Sounds like a bad BIOS flash to me.
in which case you might be able to flash it to the proper bios and use it.

or, if it is a bad flash, and it's still not working you might be able to RMA it, but depending on it's condition, they may or may not take the card.

Also. How much did ya pay for it? I hope not much :/
post #7 of 8
Thread Starter 
Quote:
Originally Posted by Pheatton View Post
I would start with checking to make sure the cooler is seated properly. Also check to see if its been removed, if possible. Then check the temps when you can get it start in windows as a second card. Im kinda suspect of the plastic cover on the back, exposed PCB area, of the card.

I could be a bad BIOS flash but thats kinda hard to pin down as that. Could be he cooked the card also. Start with those and see what you get back
Yeh I removed the cooler and reseated it. It had obviously been removed as some threads were cross threaded and some screws were missing, and there was a crappy thermal paste job on it.

And yeh the backplate, forgot that. The plastic was under the backplate

And how would I go about correcting a bad bios flash?

I paid £50 for it inc. delivery.
And I dunno about RMA'ing it really, as it was off ebay, don't you have to provide receipts and stuff?
Heap O' Junk
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4GHz Asus P6T SE 4850X2 2GB 3x2GB OCZ PC3-12800 
Hard DriveOptical DriveOSMonitor
2x250GB RAID0 7200.10, 320GB 7200.11 Samsung SH-S183ABEBN SATA Windows 7 Pro SM2443BW + HP LP2065 
KeyboardPowerCaseMouse
Logitech G15 v1 Silverstone Zeus ST75ZF TT Lanfire Xaser III Modded Razer Deathadder 
Mouse Pad
Icemat v2 Blue 
  hide details  
Reply
Heap O' Junk
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4GHz Asus P6T SE 4850X2 2GB 3x2GB OCZ PC3-12800 
Hard DriveOptical DriveOSMonitor
2x250GB RAID0 7200.10, 320GB 7200.11 Samsung SH-S183ABEBN SATA Windows 7 Pro SM2443BW + HP LP2065 
KeyboardPowerCaseMouse
Logitech G15 v1 Silverstone Zeus ST75ZF TT Lanfire Xaser III Modded Razer Deathadder 
Mouse Pad
Icemat v2 Blue 
  hide details  
Reply
post #8 of 8
Thread Starter 
Ok I flashed the BIOS to a newer version, didnt help

Anyone have any other ideas?
Heap O' Junk
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4GHz Asus P6T SE 4850X2 2GB 3x2GB OCZ PC3-12800 
Hard DriveOptical DriveOSMonitor
2x250GB RAID0 7200.10, 320GB 7200.11 Samsung SH-S183ABEBN SATA Windows 7 Pro SM2443BW + HP LP2065 
KeyboardPowerCaseMouse
Logitech G15 v1 Silverstone Zeus ST75ZF TT Lanfire Xaser III Modded Razer Deathadder 
Mouse Pad
Icemat v2 Blue 
  hide details  
Reply
Heap O' Junk
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4GHz Asus P6T SE 4850X2 2GB 3x2GB OCZ PC3-12800 
Hard DriveOptical DriveOSMonitor
2x250GB RAID0 7200.10, 320GB 7200.11 Samsung SH-S183ABEBN SATA Windows 7 Pro SM2443BW + HP LP2065 
KeyboardPowerCaseMouse
Logitech G15 v1 Silverstone Zeus ST75ZF TT Lanfire Xaser III Modded Razer Deathadder 
Mouse Pad
Icemat v2 Blue 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Bought a second HD2900XT, help fixing it?