Overclock.net › Forums › Graphics Cards › NVIDIA › I think I just screwed up my video card
New Posts  All Forums:Forum Nav:

I think I just screwed up my video card

post #1 of 19
Thread Starter 
Did I just ruin my video card? I noticed when I would try to play Crysis it would crash and sometimes I would get BSOD. I thought it was a video card issue, so I went in the BIOS and set the PCI-E frequency to 100 and it still crashed, so I increased the PCI-E voltage +0.05. And ever since my video card has been crapping. I tried uninstalling the drivers and re-installing the drivers, I tried the CD, I tried an older version, I tried the newer version. But I still can't change the resolution to 1920x1080 like it used to be. What else can I try?
Bloomfield
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-930 Rampage III Extreme [2] GTX 570 SC SLI [3] 2GB Dominator 
Hard DriveOSMonitorPower
[2] 1TB RAID-0 Windows 7 x64 2493HM AX850 
CaseMouse
FT02B G5 
  hide details  
Reply
Bloomfield
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-930 Rampage III Extreme [2] GTX 570 SC SLI [3] 2GB Dominator 
Hard DriveOSMonitorPower
[2] 1TB RAID-0 Windows 7 x64 2493HM AX850 
CaseMouse
FT02B G5 
  hide details  
Reply
post #2 of 19
Ask EVGA for an RMA
    
CPUMotherboardGraphicsRAM
Intel i7-4850HQ  Yes GT 750M 16GB Corsair 
Hard DriveHard DriveOSMonitor
512GB SSD 1TB Buffalo Drivestation OSX Mavericks 15" 2880 x 1800 IPS 
MouseOther
Magic Mouse Mobee Magic Charger 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i7-4850HQ  Yes GT 750M 16GB Corsair 
Hard DriveHard DriveOSMonitor
512GB SSD 1TB Buffalo Drivestation OSX Mavericks 15" 2880 x 1800 IPS 
MouseOther
Magic Mouse Mobee Magic Charger 
  hide details  
Reply
post #3 of 19
No...don't ever mess with the pci-e voltage. If its crashing after resetting the pci-e voltage at stock its rma time.
post #4 of 19
After removing old driver, did you use driver cleaner? and 2nd check your aux power cord to the vid card (common to come loose sometimes). Make sure you have enough volts on the NB.
post #5 of 19
Thread Starter 
This is what it says after I install: "An error occured during the installation of the device, The parameter is incorrect."

Well, I want to try everything I can before I RMA. Any other suggestions?
Bloomfield
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-930 Rampage III Extreme [2] GTX 570 SC SLI [3] 2GB Dominator 
Hard DriveOSMonitorPower
[2] 1TB RAID-0 Windows 7 x64 2493HM AX850 
CaseMouse
FT02B G5 
  hide details  
Reply
Bloomfield
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-930 Rampage III Extreme [2] GTX 570 SC SLI [3] 2GB Dominator 
Hard DriveOSMonitorPower
[2] 1TB RAID-0 Windows 7 x64 2493HM AX850 
CaseMouse
FT02B G5 
  hide details  
Reply
post #6 of 19
Do you have any other rigs to test the card in?
post #7 of 19
Thread Starter 
Quote:
Originally Posted by pig69 View Post
After removing old driver, did you use driver cleaner? and 2nd check your aux power cord to the vid card (common to come loose sometimes). Make sure you have enough volts on the NB.
What's driver cleaner? I just tried installing the CD drivers over the current drivers. That was all I tried.
Bloomfield
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-930 Rampage III Extreme [2] GTX 570 SC SLI [3] 2GB Dominator 
Hard DriveOSMonitorPower
[2] 1TB RAID-0 Windows 7 x64 2493HM AX850 
CaseMouse
FT02B G5 
  hide details  
Reply
Bloomfield
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-930 Rampage III Extreme [2] GTX 570 SC SLI [3] 2GB Dominator 
Hard DriveOSMonitorPower
[2] 1TB RAID-0 Windows 7 x64 2493HM AX850 
CaseMouse
FT02B G5 
  hide details  
Reply
post #8 of 19
Thread Starter 
Quote:
Originally Posted by lemans81 View Post
Do you have any other rigs to test the card in?
None that have PCI-E.
Bloomfield
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-930 Rampage III Extreme [2] GTX 570 SC SLI [3] 2GB Dominator 
Hard DriveOSMonitorPower
[2] 1TB RAID-0 Windows 7 x64 2493HM AX850 
CaseMouse
FT02B G5 
  hide details  
Reply
Bloomfield
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-930 Rampage III Extreme [2] GTX 570 SC SLI [3] 2GB Dominator 
Hard DriveOSMonitorPower
[2] 1TB RAID-0 Windows 7 x64 2493HM AX850 
CaseMouse
FT02B G5 
  hide details  
Reply
post #9 of 19
http://www.softpedia.com/get/Securit...-Cleaner.shtml

Driver cleaner removes "old pieces" of the other driver to ensure a clean install of new drivers. Link above says free trial dl
post #10 of 19
I would just rma, evga is probably the best rma service I have ever worked with.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › I think I just screwed up my video card