Overclock.net › Forums › Video Games › PC Gaming › My computer or Age of Conan?
New Posts  All Forums:Forum Nav:

My computer or Age of Conan?

post #1 of 22
Thread Starter 
Ever since I started playing Age of Conan i noticed that my sig rig can only run it at low DX9 of course and it still stutters. I have upgraded my drivers and even used some different ones to compare and nothing. I even have the view distance and grass density heavily modified to a lower amount to reduce the lagg but still, I get it. So the question is, is it my computer or is it Age of Conan?
Mein Neu Junge!
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon 64 X2 6400+ @ 3.2 Ghz (stock) ASUS M3A78-EM Sapphire Radeon HD 4830 512MB OCZ Platinum PC8500 2GIG 
Hard DriveOptical DriveOSMonitor
250GB Samsung SATA LG DVD-DRIVE IDE Windows 7 Ultimate 64 bit 19'' DeLL LCD 
KeyboardPowerCaseMouse
Saitek Eclipse 430W Antec Earthwatts Full Tower Black-Chemning Logitech MX518 
Mouse Pad
Cloth 
  hide details  
Reply
Mein Neu Junge!
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon 64 X2 6400+ @ 3.2 Ghz (stock) ASUS M3A78-EM Sapphire Radeon HD 4830 512MB OCZ Platinum PC8500 2GIG 
Hard DriveOptical DriveOSMonitor
250GB Samsung SATA LG DVD-DRIVE IDE Windows 7 Ultimate 64 bit 19'' DeLL LCD 
KeyboardPowerCaseMouse
Saitek Eclipse 430W Antec Earthwatts Full Tower Black-Chemning Logitech MX518 
Mouse Pad
Cloth 
  hide details  
Reply
post #2 of 22
im sorry to say but it is most likely your computer i hear that age of conan is very cpu reliant in addition to graphics card reliant. most mmo's have framerates improve throughout first few patches though so if your really broke you might want to give it some time. i would check out what others have to say too since im not a authority around here, others may be better informed. good luck!
M.E.D.
(14 items)
 
  
CPUMotherboardGraphicsRAM
E5200 :( Maximus Formula x38 9600GSO :( G.Skill 2x2gb ddr2 1066 
Hard DriveOptical DriveOSMonitor
Barracuda 7200.12 500GB Samsung DVD Burner /W Lightscribe Windows 7 64bit 17" CRT :( 
KeyboardPowerCaseMouse
Razer Lycosa Corsair 850TX Modded Antec 900 Razer Lachesis 
Mouse PadAudio
Rocketfish Dbl-sided Anodized Aluminum Logitech CRAP speakers.. :( 
  hide details  
Reply
M.E.D.
(14 items)
 
  
CPUMotherboardGraphicsRAM
E5200 :( Maximus Formula x38 9600GSO :( G.Skill 2x2gb ddr2 1066 
Hard DriveOptical DriveOSMonitor
Barracuda 7200.12 500GB Samsung DVD Burner /W Lightscribe Windows 7 64bit 17" CRT :( 
KeyboardPowerCaseMouse
Razer Lycosa Corsair 850TX Modded Antec 900 Razer Lachesis 
Mouse PadAudio
Rocketfish Dbl-sided Anodized Aluminum Logitech CRAP speakers.. :( 
  hide details  
Reply
post #3 of 22
I'd say it's your graphics card and cpu. This game is actually made to be better with dual core..and the graphics are intense so a good card is needed for max.

I run AoC maxed out at 1280x1024. The only things I don't max are AA with I've got at 2x and AF i have at 8.
Maximus
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 (G0) @ 3.0ghz DFI LP DK P35 8800GTS 512mb KO Edition 2x2Gig G.Skill DDR PC 8000 
Hard DriveOSMonitorPower
320gig WD 7200RPM Windows 8 Pro 22" Samsung Corsair TX650w 
Case
Antec 900 
  hide details  
Reply
Maximus
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 (G0) @ 3.0ghz DFI LP DK P35 8800GTS 512mb KO Edition 2x2Gig G.Skill DDR PC 8000 
Hard DriveOSMonitorPower
320gig WD 7200RPM Windows 8 Pro 22" Samsung Corsair TX650w 
Case
Antec 900 
  hide details  
Reply
post #4 of 22
It's your CPU. Maybe your RAM.
Akiyama Mio
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6420 @ stock, 0.98v Asus P5N-E SLI Gainward GTX 460 1GB @ 800/1600/1900 2x2GB Kingston @ 800MHz 5-5-5-15 2T 
Hard DriveOptical DriveOSMonitor
WD 250GB, 320GB SATA/3, 16MB Cache, Seagate 1TB LG GSA-H62N 18x SATA Ubuntu 9.10 x86 & Win7 x86 Asus VW222U 
KeyboardPowerCase
Logitech Classic Corsair 650HX NZXT Apollo Black 
  hide details  
Reply
Akiyama Mio
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6420 @ stock, 0.98v Asus P5N-E SLI Gainward GTX 460 1GB @ 800/1600/1900 2x2GB Kingston @ 800MHz 5-5-5-15 2T 
Hard DriveOptical DriveOSMonitor
WD 250GB, 320GB SATA/3, 16MB Cache, Seagate 1TB LG GSA-H62N 18x SATA Ubuntu 9.10 x86 & Win7 x86 Asus VW222U 
KeyboardPowerCase
Logitech Classic Corsair 650HX NZXT Apollo Black 
  hide details  
Reply
post #5 of 22
Quote:
Originally Posted by PorkyFat View Post
Ever since I started playing Age of Conan i noticed that my sig rig can only run it at low DX9 of course and it still stutters. I have upgraded my drivers and even used some different ones to compare and nothing. I even have the view distance and grass density heavily modified to a lower amount to reduce the lagg but still, I get it. So the question is, is it my computer or is it Age of Conan?
As others have said it's quite a demanding game. To enjoy it at it's best you'd need a Dual Core and at least an 8800GT 512MB
 
X79 Build
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6950X @ 4.0Ghz Asus Rampage V Extreme [Bios:3101] 2x EVGA GeForce Titan X SC Editions in SLI 32GB (4×8) Corsair Dominator Platinums (3000Mhz) 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 950 Pro 512GB M.2 Nvme 2x 256GB Vertex 4 SSD (RAID-0) 2x 2TB Seagate Barracuda [Storage] Pioneer BDR-207DBK Blu-ray Writer 
CoolingOSMonitorPower
Corsair H105 (Push/Pull) Windows 10 Pro x64 2x 27" Asus PG278Q ROG Swift 144hz  Corsair AX1500i Digital ATX 80 Plus Titanium 
CaseAudio
Lian Li PC-O8WX ATX Cube Case Logitech Z906 5.1 Surround 
CPUMotherboardGraphicsRAM
i7-3930K (C2) @ (4.6Ghz) Asus Rampage IV Extreme X79 (Bios 3204) 3x EVGA GTX780Ti's SC Editions 32GB (4x8GB) G-Skill TridentX 2400Mhz 
Hard DriveHard DriveOptical DriveCooling
2x 256GB OCZ Vertex 4's (RAID-0) 2x 2TB Seagate Barracuda 7200.14 64MB Cache Pioneer BDR-207DBK Blu-ray Writer Corsair H105 (Push/Pull) 
OSMonitorPowerCase
Win7 Pro 64Bit & Win10 Pro 64Bit Asus ROG Swift (2560x1440 @144hz) Corsair AX1200 + Corsair RED sleeved cables Coolermaster Cosmos II Ultra 
  hide details  
Reply
 
X79 Build
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6950X @ 4.0Ghz Asus Rampage V Extreme [Bios:3101] 2x EVGA GeForce Titan X SC Editions in SLI 32GB (4×8) Corsair Dominator Platinums (3000Mhz) 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 950 Pro 512GB M.2 Nvme 2x 256GB Vertex 4 SSD (RAID-0) 2x 2TB Seagate Barracuda [Storage] Pioneer BDR-207DBK Blu-ray Writer 
CoolingOSMonitorPower
Corsair H105 (Push/Pull) Windows 10 Pro x64 2x 27" Asus PG278Q ROG Swift 144hz  Corsair AX1500i Digital ATX 80 Plus Titanium 
CaseAudio
Lian Li PC-O8WX ATX Cube Case Logitech Z906 5.1 Surround 
CPUMotherboardGraphicsRAM
i7-3930K (C2) @ (4.6Ghz) Asus Rampage IV Extreme X79 (Bios 3204) 3x EVGA GTX780Ti's SC Editions 32GB (4x8GB) G-Skill TridentX 2400Mhz 
Hard DriveHard DriveOptical DriveCooling
2x 256GB OCZ Vertex 4's (RAID-0) 2x 2TB Seagate Barracuda 7200.14 64MB Cache Pioneer BDR-207DBK Blu-ray Writer Corsair H105 (Push/Pull) 
OSMonitorPowerCase
Win7 Pro 64Bit & Win10 Pro 64Bit Asus ROG Swift (2560x1440 @144hz) Corsair AX1200 + Corsair RED sleeved cables Coolermaster Cosmos II Ultra 
  hide details  
Reply
post #6 of 22
My puter plays AOC slick as wet snot on a glass dootknob, on high with 2x AA. That's at stock speeds 1280x1024. Seems AOC is sensitive to OCing... causes twitches even though ORTHOS says it's fine. Even Blender3d renders run nice and stable. Owell whatever works I guess.
DarkStar
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K@4.4 HT Auto ASROCK|P67 EXTREME4 (B3) EVGA 560TI SC Crysis (SLI) 4Gx2|G.SKIL F3-17000CL9D 
Hard DriveOptical DriveOSMonitor
SSD 64G|ADATA AS599S/HD 1T|SAMSUNG HD103SJ 32M 7K BD BURNER LITE-ON | IHBS212 R Win7 64 bit Pro BenQFP241VW Duals 
KeyboardPowerCaseMouse
EclipseII SEASONIC|SS-850HT SILVER ANTEC|THREE HUNDRED ILLUSION R Mamba 
Mouse Pad
Dell 
  hide details  
Reply
DarkStar
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600K@4.4 HT Auto ASROCK|P67 EXTREME4 (B3) EVGA 560TI SC Crysis (SLI) 4Gx2|G.SKIL F3-17000CL9D 
Hard DriveOptical DriveOSMonitor
SSD 64G|ADATA AS599S/HD 1T|SAMSUNG HD103SJ 32M 7K BD BURNER LITE-ON | IHBS212 R Win7 64 bit Pro BenQFP241VW Duals 
KeyboardPowerCaseMouse
EclipseII SEASONIC|SS-850HT SILVER ANTEC|THREE HUNDRED ILLUSION R Mamba 
Mouse Pad
Dell 
  hide details  
Reply
post #7 of 22
Quote:
Originally Posted by Mhill2029 View Post
As others have said it's quite a demanding game. To enjoy it at it's best you'd need a Dual Core and at least an 8800GT 512MB
maybe I'll try it out now
post #8 of 22
4GB of Ram, Q6600 and an 8800GT will play the game on max settings, x16 AA with ease.

It's probably your CPU and video card.
post #9 of 22
Quote:
Originally Posted by kneeki View Post
4GB of Ram, Q6600 and an 8800GT will play the game on max settings, x16 AA with ease.

It's probably your CPU and video card.
...I don't know what people mean by max settings...because my rig can run it on high with some AA @ 30-50 FPS...but...personally, 50 FPS is usually a min for me... It even drops to 20 sometimes in big grps when I hit my cone heals (playing a bear shaman ATM)
    
CPUMotherboardGraphicsRAM
E6600 @ 3.0 Ghz ASUS P5N32-E SLI eVGA 8800GTS (600/999) Gskill 2gb HZ 
Hard DriveOptical DriveOSMonitor
150g Raptor+160g storage Some random DVD+RW Windows 7 RC Samsung 226BW 
KeyboardPowerCaseMouse
Saitek Eclipse Seasonic 600W SLI TT Armor Logitech MX518 <3 
Mouse Pad
A composition notebook! 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
E6600 @ 3.0 Ghz ASUS P5N32-E SLI eVGA 8800GTS (600/999) Gskill 2gb HZ 
Hard DriveOptical DriveOSMonitor
150g Raptor+160g storage Some random DVD+RW Windows 7 RC Samsung 226BW 
KeyboardPowerCaseMouse
Saitek Eclipse Seasonic 600W SLI TT Armor Logitech MX518 <3 
Mouse Pad
A composition notebook! 
  hide details  
Reply
post #10 of 22
The game seems more GPU heavy than CPU heavy. I OC'ed my GPU (8800GTS 512) to 785/1905/975 and I get 40-50FPS in Tortage on High Settings with AAx16Q, AFx16, and most settings turned all the way up at 1680x1050. It actually went up when I got to Conall, but went down by like 10-15FPS in Aquilonia. I OC'ed my CPU from 3.0 to 3.6 and saw no improvement in performance. My G15 keyboard say the game only uses about 55-60% of my CPU and around 45-50% of my RAM.

That's with Vista 64. Still, even when the game is saying I have 55-60FPS, I still get the occasional stutter without the FPS ever dropping. I'm hoping that will be something that will be fixed over time... though, its not really been an issue with me.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › My computer or Age of Conan?