Overclock.net › Forums › Cooling › Water Cooling › EK 9800gx2 Acetal BLOCK issues
New Posts  All Forums:Forum Nav:

EK 9800gx2 Acetal BLOCK issues

post #1 of 3
Thread Starter 
hey all just curious,as i got my block down here in australia,as im from australia....thermal pads were not included in my package,i dont know if they were suppose to be included or not so i used the stock ones that were on the 9800gx2 card,only to see that the card does not even work anymore,there is no signal and monitor goes straight to power saving mode,iv tried it on a friends pc only to get the same outcome,im not sure if something got fried in the card,but how much do thermal pads play apart in this block working or not,any feedback or information would be greatly appreciated cheers.
post #2 of 3
Well you have to make good contact for them to work right and not fry..That might not be the problem, just RMA the card if you cant get it to work, then contact who ever you got the block from and ask them what pads should be used with it....
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8600 4545Mhz*9 w/1.29V DFI DK P45 XFX 8800 GS D9GKX & D9GMH 
Hard DriveOptical DriveOSPower
2x Seagate 160 Perp. RD-1 2x Asus Vista Premium Corsair HX 620 
Case
Open Bench 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8600 4545Mhz*9 w/1.29V DFI DK P45 XFX 8800 GS D9GKX & D9GMH 
Hard DriveOptical DriveOSPower
2x Seagate 160 Perp. RD-1 2x Asus Vista Premium Corsair HX 620 
Case
Open Bench 
  hide details  
Reply
post #3 of 3
Make sure you dont use conductive thermal paste. That may have/will cause the card to short.

There were two strips of thermal pads with my block, they felt kinda rubbery. It says to cut them up individually for each of the small chips.

Like this.


Maybe youve got too much of the original thermal on the small chips, if this is where you put them. Just a thought.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › EK 9800gx2 Acetal BLOCK issues