Overclock.net › Forums › Components › Power Supplies › X-Connect 2 screeching
New Posts  All Forums:Forum Nav:

X-Connect 2 screeching

post #1 of 3
Thread Starter 
Something inside the unit is causing an unbearable screech anytime I put any load on it.

Anything beyond running a video on break or youtube, it just makes this unbearable screech until I stop what I'm doing. Sometimes for fun, it just does this noise and doesn't stop until I turn the computer off altogether.

Worked fine for a year and a half with the same setup, and just started doing this about 2 months ago.

Also, its not the fan, I jammed a screw driver in to stop the fan and it does nothing.

inb4 "SCREWDRIVER IN A POWER SUPPLY IS BAD!"
post #2 of 3
snap ur freaking alive. and Xconnects go bad after like 2 years, But screeching sounds like a cap bout to blow lol

time for new PSU before ur system go's poof lol
post #3 of 3
Quote:
Also, its not the fan, I jammed a screw driver in to stop the fan and it does nothing


induction coils could be whining, but yeah its most likely on the crapper
Chuckle2Tits
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 2.66 45nm D0 Foxconn BloodRage x58 EVGA GTX 285 6 GB Corsair Dom. DDR3 1600 
Hard DriveOptical DriveOSMonitor
1x300 GB WD Velociraptor Asus 16/48 DVD/CD ROM SATA Windows 7 Pro 64 bit Viewsonic VX2255wmb 22" LCD 
KeyboardPowerCaseMouse
Logitech USB wired Silverstone Decathalon 850 PolymorphiX (PMX_v1s) ms optical, wired 
Mouse Pad
ancient piece of crap :P 
  hide details  
Reply
Chuckle2Tits
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 2.66 45nm D0 Foxconn BloodRage x58 EVGA GTX 285 6 GB Corsair Dom. DDR3 1600 
Hard DriveOptical DriveOSMonitor
1x300 GB WD Velociraptor Asus 16/48 DVD/CD ROM SATA Windows 7 Pro 64 bit Viewsonic VX2255wmb 22" LCD 
KeyboardPowerCaseMouse
Logitech USB wired Silverstone Decathalon 850 PolymorphiX (PMX_v1s) ms optical, wired 
Mouse Pad
ancient piece of crap :P 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › X-Connect 2 screeching