Overclock.net › Forums › Video Games › PC Gaming › Why COD4 so laggy?
New Posts  All Forums:Forum Nav:

Why COD4 so laggy?

post #1 of 20
Thread Starter 
I have been playing COD4 for a few days now and it runs pretty decent but then like every 45 seconds to a minute it starts lagging horribly for like 15 seconds. I have the settings all pretty low. my comp runs an super clocked 8800 gt 2gb ram and a duo core processor.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 6400 @ 2.13GHz Asus P5NSLI Series Zotac 8800GT 512Mb 2GB DDR2 
Hard DriveOSMonitorCase
160GB HDD WinXp Pro Asus 22" Widescreen Nikao Ogre II 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 6400 @ 2.13GHz Asus P5NSLI Series Zotac 8800GT 512Mb 2GB DDR2 
Hard DriveOSMonitorCase
160GB HDD WinXp Pro Asus 22" Widescreen Nikao Ogre II 
  hide details  
Reply
post #2 of 20
Your ram isn't helping and is likely slowing your system down, get 2GB ram. You also could have a faulty or inadequate PSU. Something aint right, you should be able to do far better than "pretty low settings" with your rig. Again, the amount of ram is likely the culprit.

1: Insufficient Memory
2: Faulty PSU or insufficient (unlikely though)
3: GPU Overheating
 
X79 Build
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6950X @ 4.0Ghz Asus Rampage V Extreme [Bios:3101] 2x EVGA GeForce Titan X SC Editions in SLI 32GB (4×8) Corsair Dominator Platinums (3000Mhz) 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 950 Pro 512GB M.2 Nvme 2x 256GB Vertex 4 SSD (RAID-0) 2x 2TB Seagate Barracuda [Storage] Pioneer BDR-207DBK Blu-ray Writer 
CoolingOSMonitorPower
Corsair H105 (Push/Pull) Windows 10 Pro x64 2x 27" Asus PG278Q ROG Swift 144hz  Corsair AX1500i Digital ATX 80 Plus Titanium 
CaseAudio
Lian Li PC-O8WX ATX Cube Case Logitech Z906 5.1 Surround 
CPUMotherboardGraphicsRAM
i7-3930K (C2) @ (4.6Ghz) Asus Rampage IV Extreme X79 (Bios 3204) 3x EVGA GTX780Ti's SC Editions 32GB (4x8GB) G-Skill TridentX 2400Mhz 
Hard DriveHard DriveOptical DriveCooling
2x 256GB OCZ Vertex 4's (RAID-0) 2x 2TB Seagate Barracuda 7200.14 64MB Cache Pioneer BDR-207DBK Blu-ray Writer Corsair H105 (Push/Pull) 
OSMonitorPowerCase
Win7 Pro 64Bit & Win10 Pro 64Bit Asus ROG Swift (2560x1440 @144hz) Corsair AX1200 + Corsair RED sleeved cables Coolermaster Cosmos II Ultra 
  hide details  
Reply
 
X79 Build
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6950X @ 4.0Ghz Asus Rampage V Extreme [Bios:3101] 2x EVGA GeForce Titan X SC Editions in SLI 32GB (4×8) Corsair Dominator Platinums (3000Mhz) 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 950 Pro 512GB M.2 Nvme 2x 256GB Vertex 4 SSD (RAID-0) 2x 2TB Seagate Barracuda [Storage] Pioneer BDR-207DBK Blu-ray Writer 
CoolingOSMonitorPower
Corsair H105 (Push/Pull) Windows 10 Pro x64 2x 27" Asus PG278Q ROG Swift 144hz  Corsair AX1500i Digital ATX 80 Plus Titanium 
CaseAudio
Lian Li PC-O8WX ATX Cube Case Logitech Z906 5.1 Surround 
CPUMotherboardGraphicsRAM
i7-3930K (C2) @ (4.6Ghz) Asus Rampage IV Extreme X79 (Bios 3204) 3x EVGA GTX780Ti's SC Editions 32GB (4x8GB) G-Skill TridentX 2400Mhz 
Hard DriveHard DriveOptical DriveCooling
2x 256GB OCZ Vertex 4's (RAID-0) 2x 2TB Seagate Barracuda 7200.14 64MB Cache Pioneer BDR-207DBK Blu-ray Writer Corsair H105 (Push/Pull) 
OSMonitorPowerCase
Win7 Pro 64Bit & Win10 Pro 64Bit Asus ROG Swift (2560x1440 @144hz) Corsair AX1200 + Corsair RED sleeved cables Coolermaster Cosmos II Ultra 
  hide details  
Reply
post #3 of 20
Thread Starter 
i do have 2 gb. I run crysis single player on high no problem so m thinking its a connection issue or some proxy **** or something
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 6400 @ 2.13GHz Asus P5NSLI Series Zotac 8800GT 512Mb 2GB DDR2 
Hard DriveOSMonitorCase
160GB HDD WinXp Pro Asus 22" Widescreen Nikao Ogre II 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 6400 @ 2.13GHz Asus P5NSLI Series Zotac 8800GT 512Mb 2GB DDR2 
Hard DriveOSMonitorCase
160GB HDD WinXp Pro Asus 22" Widescreen Nikao Ogre II 
  hide details  
Reply
post #4 of 20
Quote:
Originally Posted by Rampage07 View Post
i do have 2 gb. I run crysis single player on high no problem so m thinking its a connection issue or some proxy **** or something
You just answered your own question lol
 
X79 Build
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6950X @ 4.0Ghz Asus Rampage V Extreme [Bios:3101] 2x EVGA GeForce Titan X SC Editions in SLI 32GB (4×8) Corsair Dominator Platinums (3000Mhz) 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 950 Pro 512GB M.2 Nvme 2x 256GB Vertex 4 SSD (RAID-0) 2x 2TB Seagate Barracuda [Storage] Pioneer BDR-207DBK Blu-ray Writer 
CoolingOSMonitorPower
Corsair H105 (Push/Pull) Windows 10 Pro x64 2x 27" Asus PG278Q ROG Swift 144hz  Corsair AX1500i Digital ATX 80 Plus Titanium 
CaseAudio
Lian Li PC-O8WX ATX Cube Case Logitech Z906 5.1 Surround 
CPUMotherboardGraphicsRAM
i7-3930K (C2) @ (4.6Ghz) Asus Rampage IV Extreme X79 (Bios 3204) 3x EVGA GTX780Ti's SC Editions 32GB (4x8GB) G-Skill TridentX 2400Mhz 
Hard DriveHard DriveOptical DriveCooling
2x 256GB OCZ Vertex 4's (RAID-0) 2x 2TB Seagate Barracuda 7200.14 64MB Cache Pioneer BDR-207DBK Blu-ray Writer Corsair H105 (Push/Pull) 
OSMonitorPowerCase
Win7 Pro 64Bit & Win10 Pro 64Bit Asus ROG Swift (2560x1440 @144hz) Corsair AX1200 + Corsair RED sleeved cables Coolermaster Cosmos II Ultra 
  hide details  
Reply
 
X79 Build
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6950X @ 4.0Ghz Asus Rampage V Extreme [Bios:3101] 2x EVGA GeForce Titan X SC Editions in SLI 32GB (4×8) Corsair Dominator Platinums (3000Mhz) 
Hard DriveHard DriveHard DriveOptical Drive
Samsung 950 Pro 512GB M.2 Nvme 2x 256GB Vertex 4 SSD (RAID-0) 2x 2TB Seagate Barracuda [Storage] Pioneer BDR-207DBK Blu-ray Writer 
CoolingOSMonitorPower
Corsair H105 (Push/Pull) Windows 10 Pro x64 2x 27" Asus PG278Q ROG Swift 144hz  Corsair AX1500i Digital ATX 80 Plus Titanium 
CaseAudio
Lian Li PC-O8WX ATX Cube Case Logitech Z906 5.1 Surround 
CPUMotherboardGraphicsRAM
i7-3930K (C2) @ (4.6Ghz) Asus Rampage IV Extreme X79 (Bios 3204) 3x EVGA GTX780Ti's SC Editions 32GB (4x8GB) G-Skill TridentX 2400Mhz 
Hard DriveHard DriveOptical DriveCooling
2x 256GB OCZ Vertex 4's (RAID-0) 2x 2TB Seagate Barracuda 7200.14 64MB Cache Pioneer BDR-207DBK Blu-ray Writer Corsair H105 (Push/Pull) 
OSMonitorPowerCase
Win7 Pro 64Bit & Win10 Pro 64Bit Asus ROG Swift (2560x1440 @144hz) Corsair AX1200 + Corsair RED sleeved cables Coolermaster Cosmos II Ultra 
  hide details  
Reply
post #5 of 20
o' so its doing that in a multiplayer game. they some times tend to have lag
|Black Tornado|
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel | C2Q Q6600 | 1.2375 VID | 3.8Ghz EVGA | 750i FTW EVGA | 2x 8800GT | 763c/1917s/1150m | Volt Modded OCZ | Platnium XTC | 1386 MHz | 2GBx2 
Hard DriveOptical DriveOSMonitor
Western Digital | 500 GB LG | DVD Buner Windows Vista Home Premium x86 DELL 22" and SONY 26" TV 
KeyboardPowerCaseMouse
Microsoft | Wireless Comfort 4000 Corsiar | 750TX Antec | 1200 Microsoft | Wireless Laser 5000 
Mouse Pad
ALLSOP | Hard Surface Pad 
  hide details  
Reply
|Black Tornado|
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel | C2Q Q6600 | 1.2375 VID | 3.8Ghz EVGA | 750i FTW EVGA | 2x 8800GT | 763c/1917s/1150m | Volt Modded OCZ | Platnium XTC | 1386 MHz | 2GBx2 
Hard DriveOptical DriveOSMonitor
Western Digital | 500 GB LG | DVD Buner Windows Vista Home Premium x86 DELL 22" and SONY 26" TV 
KeyboardPowerCaseMouse
Microsoft | Wireless Comfort 4000 Corsiar | 750TX Antec | 1200 Microsoft | Wireless Laser 5000 
Mouse Pad
ALLSOP | Hard Surface Pad 
  hide details  
Reply
post #6 of 20
Quote:
Originally Posted by Rampage07 View Post
i do have 2 gb. I run crysis single player on high no problem so m thinking its a connection issue or some proxy **** or something
Ya. From experience, CoD4 seems to be picky with those things. Check those. And ya, you did answer your own question.
     
CPUMotherboardGraphicsRAM
e8500 E0 @ 4.37GHz 1.328V Gigabyte EP45-UD3P SAPPHIRE Radeon HD4850 702-1160 G Skill PI 2x2GB/2x1GB 
Hard DriveOptical DriveOSMonitor
Seagate 500GB/WD 640GB Black/WD 160GB Blue 2x LG Lightscribe 22x DVD Combos W7 Professional 64bit/Ubuntu Studio 10.04 64bit Asus PW201 20" VA-Type 
KeyboardPowerCaseMouse
Saitek Eclipse II Kingwin Mach 1 800W "Afterburner Midnight" CM Centurion 590 Mod Razer Death Adder LH 
Mouse Pad
Steel Series NP+ 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
e8500 E0 @ 4.37GHz 1.328V Gigabyte EP45-UD3P SAPPHIRE Radeon HD4850 702-1160 G Skill PI 2x2GB/2x1GB 
Hard DriveOptical DriveOSMonitor
Seagate 500GB/WD 640GB Black/WD 160GB Blue 2x LG Lightscribe 22x DVD Combos W7 Professional 64bit/Ubuntu Studio 10.04 64bit Asus PW201 20" VA-Type 
KeyboardPowerCaseMouse
Saitek Eclipse II Kingwin Mach 1 800W "Afterburner Midnight" CM Centurion 590 Mod Razer Death Adder LH 
Mouse Pad
Steel Series NP+ 
  hide details  
Reply
post #7 of 20
COD4 with Vista 64 was laggy for me using wireless internet connection. Once wired, lag is gone.
The Boss
(13 items)
 
  
CPUMotherboardGraphics
FX8350 GIGABYTE GA-990FXA-UD3 R9 280X 
  hide details  
Reply
The Boss
(13 items)
 
  
CPUMotherboardGraphics
FX8350 GIGABYTE GA-990FXA-UD3 R9 280X 
  hide details  
Reply
post #8 of 20
Get more ram.
Get XP.
And Buy a better hard drive, because it sounds like every time your game needs to load a new part of the map, it dies on you

And overclock that damned processor!
Von Strauss
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon 5000x2 BE @ 3.2 ASUS M2R-32 MVP Sapphire HD4850 700/1100 2x1gb G.Skill HZs 
Hard DriveOptical DriveOSMonitor
250gb WD IDE lol LG DVD-RAM w/ Lightscribe Vista Ultimate 32-bit Sceptre, 1280x1024, 5ms 
PowerCase
Corsair TX 650W Enermax Chakra w/ 250mm Side Panel Fan 
  hide details  
Reply
Von Strauss
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon 5000x2 BE @ 3.2 ASUS M2R-32 MVP Sapphire HD4850 700/1100 2x1gb G.Skill HZs 
Hard DriveOptical DriveOSMonitor
250gb WD IDE lol LG DVD-RAM w/ Lightscribe Vista Ultimate 32-bit Sceptre, 1280x1024, 5ms 
PowerCase
Corsair TX 650W Enermax Chakra w/ 250mm Side Panel Fan 
  hide details  
Reply
post #9 of 20
Thread Starter 
well if its my internet is there anyway to fix it?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 6400 @ 2.13GHz Asus P5NSLI Series Zotac 8800GT 512Mb 2GB DDR2 
Hard DriveOSMonitorCase
160GB HDD WinXp Pro Asus 22" Widescreen Nikao Ogre II 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 6400 @ 2.13GHz Asus P5NSLI Series Zotac 8800GT 512Mb 2GB DDR2 
Hard DriveOSMonitorCase
160GB HDD WinXp Pro Asus 22" Widescreen Nikao Ogre II 
  hide details  
Reply
post #10 of 20
Wait..do you mean the plays fine then it lags for a couple seconds. Goes fine for like 2 seconds lags again, fine again, etc?
I get it sometimes too.
Its SO annoying.
Some say kill ntune and and other monitoring stuff. Not sure why.
ragequit
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9550 4ghz @ 1.25v Asus Max 2 formula 8800gtx 610/1ghz OCZ LV blade 1:1 950mhz 
Hard DriveOptical DriveOSMonitor
7200.10 250gb dvd leetlinucks 24" Westy 
KeyboardPowerCaseMouse
G15 750w Toughpower Lian li pc-65 Copperhead 
Mouse Pad
Thermtaltake? 
  hide details  
Reply
ragequit
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9550 4ghz @ 1.25v Asus Max 2 formula 8800gtx 610/1ghz OCZ LV blade 1:1 950mhz 
Hard DriveOptical DriveOSMonitor
7200.10 250gb dvd leetlinucks 24" Westy 
KeyboardPowerCaseMouse
G15 750w Toughpower Lian li pc-65 Copperhead 
Mouse Pad
Thermtaltake? 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Why COD4 so laggy?