Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers BIG Performance Difference
New Posts  All Forums:Forum Nav:

ATI Drivers BIG Performance Difference

post #1 of 9
Thread Starter 
When I upgraded to new ATI 8.6 driver from Diamond 8.43, my 3DMark06 went down from 11600 to 10055. That's a huge performance difference. What's the deal??? Is there a better driver for performance boosting?
Current System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E8400 @ 4GHz 1.4V (chip is incredible) Asus Maximus Formula 1201 Bios 445FSB CF 2x Powercolor HD 4850 512MB 660/1060 G.Skill 2x2GB 1066Mhz PC2-8500 
Hard DriveOSMonitorPower
Seagate 650GB Windows XP Pro SP3 Acer 22" AL2216W CoolerMaster 600W 
Case
CoolerMaster CM690 
  hide details  
Reply
Current System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E8400 @ 4GHz 1.4V (chip is incredible) Asus Maximus Formula 1201 Bios 445FSB CF 2x Powercolor HD 4850 512MB 660/1060 G.Skill 2x2GB 1066Mhz PC2-8500 
Hard DriveOSMonitorPower
Seagate 650GB Windows XP Pro SP3 Acer 22" AL2216W CoolerMaster 600W 
Case
CoolerMaster CM690 
  hide details  
Reply
post #2 of 9
Did you clean the other driver elements properly with Driver Cleaner ?. Have you checked that you used all the same settings aswel ?
post #3 of 9
Thread Starter 
Just did the 8.6 installation only. No Driver Cleaner. I'll give it a shot a see.
Current System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E8400 @ 4GHz 1.4V (chip is incredible) Asus Maximus Formula 1201 Bios 445FSB CF 2x Powercolor HD 4850 512MB 660/1060 G.Skill 2x2GB 1066Mhz PC2-8500 
Hard DriveOSMonitorPower
Seagate 650GB Windows XP Pro SP3 Acer 22" AL2216W CoolerMaster 600W 
Case
CoolerMaster CM690 
  hide details  
Reply
Current System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E8400 @ 4GHz 1.4V (chip is incredible) Asus Maximus Formula 1201 Bios 445FSB CF 2x Powercolor HD 4850 512MB 660/1060 G.Skill 2x2GB 1066Mhz PC2-8500 
Hard DriveOSMonitorPower
Seagate 650GB Windows XP Pro SP3 Acer 22" AL2216W CoolerMaster 600W 
Case
CoolerMaster CM690 
  hide details  
Reply
post #4 of 9
Never install drivers on top of drivers, they usually cause performance decrease.
post #5 of 9
i dont really buy into the whole driver cleaner thing especially since ati has that driver removal tool that comes with the new drivers now. i would say roll back if you had better performance with the old drivers
    
CPUMotherboardGraphicsRAM
i7 2600k 5000mhz(so far) ASUS MAXIMUS IV EXTREME msi 6970 and 2 6950's Mushkin Enhanced Blackline 2133mhz 
Hard DriveOptical DriveOSMonitor
Force GT(os) M4 64gb(games) f3 1tb(other) Samsung Windows 7 64bit Samsung BX2450 
KeyboardPowerCaseMouse
Black widow XFX ProSeries 1050W PSU 80+Gold  Corsair 700D Deathadder 
Mouse Pad
nope! 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 2600k 5000mhz(so far) ASUS MAXIMUS IV EXTREME msi 6970 and 2 6950's Mushkin Enhanced Blackline 2133mhz 
Hard DriveOptical DriveOSMonitor
Force GT(os) M4 64gb(games) f3 1tb(other) Samsung Windows 7 64bit Samsung BX2450 
KeyboardPowerCaseMouse
Black widow XFX ProSeries 1050W PSU 80+Gold  Corsair 700D Deathadder 
Mouse Pad
nope! 
  hide details  
Reply
post #6 of 9
I am 100 percent positive that installing over old drivers causes problems. It has for me, every single time I've done it with Nvidia OR ATI. last ATI card was an x850xt though, we'll see if this holds true when I grab an HD4870.

I do the same thing every time, and it works for me every time.

Uninstall old drivers.
Reboot
Cancel auto install of vid drivers
run driver cleaner OR Driver Sweeper. (I prefer driver sweeper)
Install new drivers
Reboot


'I haven't experimented in Vista as much as XP with this meathod.' But I think it works the same.
Microwave Mojo
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 4690K @ 4.5ghz Gigabyte Z97X-UD3H Sapphire R9 280 Dual X 8GB DDR3 Kingston @ 1866 
Hard DriveOSMonitorPower
256GB Crucial SSD Windows 8.1 x64 24" Corsair TX650W 
  hide details  
Reply
Microwave Mojo
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 4690K @ 4.5ghz Gigabyte Z97X-UD3H Sapphire R9 280 Dual X 8GB DDR3 Kingston @ 1866 
Hard DriveOSMonitorPower
256GB Crucial SSD Windows 8.1 x64 24" Corsair TX650W 
  hide details  
Reply
post #7 of 9
Thread Starter 
I downloaded DCPro 1.5 from Guru3D forum and ran it after uninstalling all ATI programs and rebooted machine. I ran the DCPro and deleted all ATI files and registries. I fired up the File Manager and went into \\Windows\\System32\\ and ATI files are back. I kept deleting them but they kept coming back. What's da deal here? Are those part of XP and it's restoring them?
Current System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E8400 @ 4GHz 1.4V (chip is incredible) Asus Maximus Formula 1201 Bios 445FSB CF 2x Powercolor HD 4850 512MB 660/1060 G.Skill 2x2GB 1066Mhz PC2-8500 
Hard DriveOSMonitorPower
Seagate 650GB Windows XP Pro SP3 Acer 22" AL2216W CoolerMaster 600W 
Case
CoolerMaster CM690 
  hide details  
Reply
Current System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E8400 @ 4GHz 1.4V (chip is incredible) Asus Maximus Formula 1201 Bios 445FSB CF 2x Powercolor HD 4850 512MB 660/1060 G.Skill 2x2GB 1066Mhz PC2-8500 
Hard DriveOSMonitorPower
Seagate 650GB Windows XP Pro SP3 Acer 22" AL2216W CoolerMaster 600W 
Case
CoolerMaster CM690 
  hide details  
Reply
post #8 of 9
Quote:
Originally Posted by Me_XMan View Post
I downloaded DCPro 1.5 from Guru3D forum and ran it after uninstalling all ATI programs and rebooted machine. I ran the DCPro and deleted all ATI files and registries. I fired up the File Manager and went into WindowsSystem32 and ATI files are back. I kept deleting them but they kept coming back. What's da deal here? Are those part of XP and it's restoring them?
Default xp ati drivers which are protected and can't be deleted nothing to worry about.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9550 Asus P5Q Pro eVGA GTX260 Core 216 G.Skill 2x2GB DDR2 1000 
Hard DriveOptical DriveOSMonitor
WD6400AAKS Pioneer DVR-216D Vista Home Premium x64 SM-2032BW 
KeyboardPowerCaseMouse
Logitech G11 Corsair HX620W Antec P182 Razer DeathAdder 
Mouse Pad
Razer Goliathus Speed Alpha 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9550 Asus P5Q Pro eVGA GTX260 Core 216 G.Skill 2x2GB DDR2 1000 
Hard DriveOptical DriveOSMonitor
WD6400AAKS Pioneer DVR-216D Vista Home Premium x64 SM-2032BW 
KeyboardPowerCaseMouse
Logitech G11 Corsair HX620W Antec P182 Razer DeathAdder 
Mouse Pad
Razer Goliathus Speed Alpha 
  hide details  
Reply
post #9 of 9
Thread Starter 
Ahhh...all is well. Reinstalled 8.6 version and performance is back.
Thanks guys!
Current System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E8400 @ 4GHz 1.4V (chip is incredible) Asus Maximus Formula 1201 Bios 445FSB CF 2x Powercolor HD 4850 512MB 660/1060 G.Skill 2x2GB 1066Mhz PC2-8500 
Hard DriveOSMonitorPower
Seagate 650GB Windows XP Pro SP3 Acer 22" AL2216W CoolerMaster 600W 
Case
CoolerMaster CM690 
  hide details  
Reply
Current System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E8400 @ 4GHz 1.4V (chip is incredible) Asus Maximus Formula 1201 Bios 445FSB CF 2x Powercolor HD 4850 512MB 660/1060 G.Skill 2x2GB 1066Mhz PC2-8500 
Hard DriveOSMonitorPower
Seagate 650GB Windows XP Pro SP3 Acer 22" AL2216W CoolerMaster 600W 
Case
CoolerMaster CM690 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers BIG Performance Difference