Overclock.net › Forums › Video Games › PC Gaming › CS:S Server Help
New Posts  All Forums:Forum Nav:

CS:S Server Help

post #1 of 22
Thread Starter 
I recently built a dedicated server for a couple games of CS:S and one Garry's Mod 10. Everything is working fine but I am having a bit of a problem. For some reason, only the first server that I start up is VAC secured any others I start up after are not. I have tried different things on all four servers to get them VAC secured, but still it is always the first server I start that is VAC secured.

I have tried finding an answer on Google and not much comes up. Can anyone help me get all my servers VAC secured?
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
post #2 of 22
did you set it up properly with cheats disabled in the command prompt is so then i'm clueless
folder 4 life!
(13 items)
 
  
CPUMotherboardGraphicsRAM
E2180 foxconn p965 evga 8800gs 2x1gb adata 800MHz 
Hard DriveOptical DriveOSMonitor
160gb western digital cd/dvd burner xp 32bit 19" lcd 
PowerCaseMouse
500w raidmax smilodon fatal1ty 
  hide details  
Reply
folder 4 life!
(13 items)
 
  
CPUMotherboardGraphicsRAM
E2180 foxconn p965 evga 8800gs 2x1gb adata 800MHz 
Hard DriveOptical DriveOSMonitor
160gb western digital cd/dvd burner xp 32bit 19" lcd 
PowerCaseMouse
500w raidmax smilodon fatal1ty 
  hide details  
Reply
post #3 of 22
Thread Starter 
Quote:
Originally Posted by t3rr0r View Post
did you set it up properly with cheats disabled in the command prompt is so then i'm clueless
Yep, I even tried re-installing all of them and just starting them up stock and it was still the same.


Here are my srcds start up batch files:

Scrim
c:\\srcds1\\srcds.exe -console -game cstrike -secure -autoupdate +map de_dust2 +maxplayers 11 -secure 1 -tickrate 100 -boost 3 -fps_max 0 +tv_port 27020

Public
c:\\srcds2\\srcds.exe -console -game cstrike -autoupdate -debug -secure +map de_dust2 +maxplayers 18 +port 27000 -tickrate 100 +tv_port 27019 +fps_max 600

Gun Game
c:\\srcds3\\srcds.exe -console -autoupdate -game cstrike +map gg_simpsons_x +maxplayers 32 -port 27013 -tickrate 100 +tv_port 27017 +exec server.cfg +fps_max 600

Garry's Mod 10
c:\\gmod1\\orangebox\\srcds.exe -autoupdate -console -game "garrysmod" +map gm_construct +maxplayers 10 -port 27012 -tickrate 66 +tv_port 27016 +fps_max 600



Here are my srcds server.cfg's:

http://www.mediafire.com/?2dtdnbkmbmd
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
post #4 of 22
i have no idea then last time i set up a server was 2 years ago sorry i can't help you more
folder 4 life!
(13 items)
 
  
CPUMotherboardGraphicsRAM
E2180 foxconn p965 evga 8800gs 2x1gb adata 800MHz 
Hard DriveOptical DriveOSMonitor
160gb western digital cd/dvd burner xp 32bit 19" lcd 
PowerCaseMouse
500w raidmax smilodon fatal1ty 
  hide details  
Reply
folder 4 life!
(13 items)
 
  
CPUMotherboardGraphicsRAM
E2180 foxconn p965 evga 8800gs 2x1gb adata 800MHz 
Hard DriveOptical DriveOSMonitor
160gb western digital cd/dvd burner xp 32bit 19" lcd 
PowerCaseMouse
500w raidmax smilodon fatal1ty 
  hide details  
Reply
post #5 of 22
Thread Starter 
Quote:
Originally Posted by t3rr0r View Post
i have no idea then last time i set up a server was 2 years ago sorry i can't help you more
Well thanks anyways



Anyone else? I really don't want to have to sign up for another forum to fix my problem =/
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
post #6 of 22
Thread Starter 
aw even the srcds forum has no clue


...anyone?
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
post #7 of 22
Thread Starter 
ok well I just installed two instances of SRCDS CS:S on my laptop to test to see if it had something to do with my server pc. I am still having the same error on my laptop as I had on the server. I noticed that the one that connects to VAC says "Connection to Steam Servers Successful." while the other one that didn't connect to vac doesn't.. Here is a screenshot.

Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
post #8 of 22
Is your game server in the DMZ? Can you/have you put it in the DMZ to make sure it's not some weird router issue (or used a direct connection)? What are you using to verify that VAC is enabled/disabled?

Also, slightly unrelated, but you don't need "-secure" in the launch options. All servers are secure by default and "-insecure" will turn VAC off.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
3800x2 DFI NF4 SLI-D HD4850 2gb GSkill ZX 
Hard DriveOSMonitorPower
6+TB of insanity XP Pro L2410NM + DYLM24D6 Corsair 750TX 
CaseMouse
Rocketfish MX 510 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
3800x2 DFI NF4 SLI-D HD4850 2gb GSkill ZX 
Hard DriveOSMonitorPower
6+TB of insanity XP Pro L2410NM + DYLM24D6 Corsair 750TX 
CaseMouse
Rocketfish MX 510 
  hide details  
Reply
post #9 of 22
Yeah this sound likes a firewall issue and ports being forwarded incorrectly.
Nightshade
(20 items)
 
  
CPUMotherboardGraphicsGraphics
i7-4930k Asus Rampage IV Extreme EVGA - Titan-X Superclocked EVGA - Titan-X 
RAMHard DriveHard DriveHard Drive
64 GB Corsair Vengance DDR3 OCZ Agility 3 Intel 540 240GB 7200 RPM Platter Drive 
Hard DriveCoolingOSMonitor
1TB Mushkin SSD Watercooled Windows 10 Pro x64 ASUS ROG Swift 
KeyboardPowerCaseMouse
Razer Black Widow Chroma Corsair RM1000 Corsair 900D Razer Deathadder Chroma 
Mouse PadAudioOther
Steelseries Soundblaster Z Speakers: Logitech z5500 
  hide details  
Reply
Nightshade
(20 items)
 
  
CPUMotherboardGraphicsGraphics
i7-4930k Asus Rampage IV Extreme EVGA - Titan-X Superclocked EVGA - Titan-X 
RAMHard DriveHard DriveHard Drive
64 GB Corsair Vengance DDR3 OCZ Agility 3 Intel 540 240GB 7200 RPM Platter Drive 
Hard DriveCoolingOSMonitor
1TB Mushkin SSD Watercooled Windows 10 Pro x64 ASUS ROG Swift 
KeyboardPowerCaseMouse
Razer Black Widow Chroma Corsair RM1000 Corsair 900D Razer Deathadder Chroma 
Mouse PadAudioOther
Steelseries Soundblaster Z Speakers: Logitech z5500 
  hide details  
Reply
post #10 of 22
Thread Starter 
Quote:
Originally Posted by heretic View Post
Is your game server in the DMZ? Can you/have you put it in the DMZ to make sure it's not some weird router issue (or used a direct connection)? What are you using to verify that VAC is enabled/disabled?

Also, slightly unrelated, but you don't need "-secure" in the launch options. All servers are secure by default and "-insecure" will turn VAC off.
yep the game server is dmz and I have all ports forwarded for it as well 0-70000 or something like that.

yeah I know I don't need it, but everytime I don't post that on a forum half the people say oh you need -secure in your .bat startup command line...


If someone thinks they could fix the problem I am willing to grant access via Remote Desktop connection.



(im prolly just doing something wrong, or missing something)
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
Main PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 6600K @ 4.65GHz 1.328v MSI Z170A Gaming M7 GTX 970 4GB FTW @ 1502Mhz CORSAIR Vengeance LPX 32GB (4 x 8GB) 
Hard DriveHard DriveCoolingMonitor
PNY Optima 240GB SSD Samsung 830 64GB SSD Custom Watercooling Loop Asus PB278Q 27" 2560x1440 
MonitorMonitorKeyboardPower
Lenovo Ll2323swA 24" 1920x1080 Dell E2414H 24" 1920x1080 Logitech G910 Orion Spectrum  Cooler Master Real Power Pro 1000W 
MouseMouse PadAudio
Logitech G900 Chaos Spectrum Logitech G440 Creative Sound Blaster Z - Sound Card 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › CS:S Server Help