Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › PPPoE + Slackware 12
New Posts  All Forums:Forum Nav:

PPPoE + Slackware 12

post #1 of 11
Thread Starter 
hey guys, im having some troubles getting my PPPoE working in slack12..i've configured it using pppoe-setup, then i used pppoe-start - it connected successfully - i checked to see if it was up and running with ifconfig and it showed a good connection sending and receiving packets on eth0 and also the same sort of stuff on ppp0.


problem is i still cant use my browser or pidgin or anything...i can ping my router just fine. i had the same problems before but at the time i was on wireless. any ideas?
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
post #2 of 11
Do you happen to have a router? I remember trying to set up PPPoE in linux, its a massive headache. I don't remember if I really ever got it working without the router.
BlackMesa
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x6 Gigabyte XFX RF460 16gb G.Skill 
Hard DriveHard DriveOSMonitor
OCZ Vertex2 Sata II Coorsair Force GS Sata III Debian (testing) Shimian 27" 
KeyboardMouse
Filco w/ blue cherries Who needs a mouse? 
  hide details  
Reply
BlackMesa
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x6 Gigabyte XFX RF460 16gb G.Skill 
Hard DriveHard DriveOSMonitor
OCZ Vertex2 Sata II Coorsair Force GS Sata III Debian (testing) Shimian 27" 
KeyboardMouse
Filco w/ blue cherries Who needs a mouse? 
  hide details  
Reply
post #3 of 11
It sounds like maybe the PPPoE connection isn't setting your route or DNS correctly. Try adding a default route to go over that interface and adding your own DNS servers to your resolv.conf.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
3800x2 DFI NF4 SLI-D HD4850 2gb GSkill ZX 
Hard DriveOSMonitorPower
6+TB of insanity XP Pro L2410NM + DYLM24D6 Corsair 750TX 
CaseMouse
Rocketfish MX 510 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
3800x2 DFI NF4 SLI-D HD4850 2gb GSkill ZX 
Hard DriveOSMonitorPower
6+TB of insanity XP Pro L2410NM + DYLM24D6 Corsair 750TX 
CaseMouse
Rocketfish MX 510 
  hide details  
Reply
post #4 of 11
Thread Starter 
Quote:
Originally Posted by dangerousHobo View Post
Do you happen to have a router? I remember trying to set up PPPoE in linux, its a massive headache. I don't remember if I really ever got it working without the router.
yeah i have a router, i had it working before over TWO routers - at the time i didnt need PPPoE stuff though..

Quote:
Originally Posted by heretic View Post
It sounds like maybe the PPPoE connection isn't setting your route or DNS correctly. Try adding a default route to go over that interface and adding your own DNS servers to your resolv.conf.
what if i were to put my username/pass for PPPoE on my routers settings and then see if i cant just connect normally through eth0?

know if i can do that with a Linksys WRT54G?
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
post #5 of 11
Quote:
Originally Posted by Flatliner View Post
what if i were to put my username/pass for PPPoE on my routers settings and then see if i cant just connect normally through eth0?

know if i can do that with a Linksys WRT54G?
Thats how I had set mine up. The router took care of the PPPoE and the machines were just connected to it like normal.
BlackMesa
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x6 Gigabyte XFX RF460 16gb G.Skill 
Hard DriveHard DriveOSMonitor
OCZ Vertex2 Sata II Coorsair Force GS Sata III Debian (testing) Shimian 27" 
KeyboardMouse
Filco w/ blue cherries Who needs a mouse? 
  hide details  
Reply
BlackMesa
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x6 Gigabyte XFX RF460 16gb G.Skill 
Hard DriveHard DriveOSMonitor
OCZ Vertex2 Sata II Coorsair Force GS Sata III Debian (testing) Shimian 27" 
KeyboardMouse
Filco w/ blue cherries Who needs a mouse? 
  hide details  
Reply
post #6 of 11
Quote:
Originally Posted by Flatliner View Post
what if i were to put my username/pass for PPPoE on my routers settings and then see if i cant just connect normally through eth0?

know if i can do that with a Linksys WRT54G?
That's what I'd recommend. I'm surprised you need to put in PPPoE info in at all. Every modem I've seen in the past 3-4 years has all that stuff built in.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
3800x2 DFI NF4 SLI-D HD4850 2gb GSkill ZX 
Hard DriveOSMonitorPower
6+TB of insanity XP Pro L2410NM + DYLM24D6 Corsair 750TX 
CaseMouse
Rocketfish MX 510 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
3800x2 DFI NF4 SLI-D HD4850 2gb GSkill ZX 
Hard DriveOSMonitorPower
6+TB of insanity XP Pro L2410NM + DYLM24D6 Corsair 750TX 
CaseMouse
Rocketfish MX 510 
  hide details  
Reply
post #7 of 11
Thread Starter 
k i think i found where to input my PPPoE info. there is a drop down box (currently set to automatic - DHCP), but has the option for PPPoE. ill wait until my dad is off his computer before i start tinkering.
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
post #8 of 11
Thread Starter 
UPDATE: so i switched around a couple things in my router settings, added my login info and now the internet works flawlessly on slack!

now if only i could get my usb headset working...
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
post #9 of 11
1+8
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Celeron G530 AsRock H61M-VS ASUS 8800 GS 384MB 2x2GB DDR3 1333MHz 
Hard DriveOSMonitorPower
WD Caviar Blue 500GB Gentoo Samsung 226BW HiPro 480W 
  hide details  
Reply
1+8
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Celeron G530 AsRock H61M-VS ASUS 8800 GS 384MB 2x2GB DDR3 1333MHz 
Hard DriveOSMonitorPower
WD Caviar Blue 500GB Gentoo Samsung 226BW HiPro 480W 
  hide details  
Reply
post #10 of 11
Thread Starter 
i cant find the asound.conf file, though i do have an asound.state file..(/etc/asound.state)
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core-i5 6500 ASRock H110M-DGS XFX RX480 8GB Corsair Vengeance LPX 2x4GB DDR4 
Hard DriveHard DriveOptical DriveCooling
Sandisk SSD Plus 240GB Seagate Barracuda 3TB HP Blu-ray Corsair H55 
OSMonitorKeyboardPower
Windows 10 Pro x64 Apple 24" LED Cinema Display Razer BlackWidow Ultimate Corsair CX550M 
CaseMouse
Rosewill SRM-01 Corsair M45 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › PPPoE + Slackware 12