Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Can't get Internet Connection Sharing to work
New Posts  All Forums:Forum Nav:

Can't get Internet Connection Sharing to work

post #1 of 20
Thread Starter 
I am trying to share my desktop's wireless internet connection with my laptop. I have everything setup for auto-detect. When I plug the laptop into the desktop via crossover cable, both network ports spend a minute 'acquiring network 'address'. During this time, the desktop cannot access the internet.

When the laptop gives up trying to get an address, it fails, and desktop can access internet as usual.

Something's wrong with the desktop, as I've also tried connecting a 360 through the desktop, and the same thing happens. I just can't work out what's wrong though.
post #2 of 20
Are you bridging the connections?
Bravo
(13 items)
 
  
CPUMotherboardGraphicsRAM
X4 955 @ 3.6 Asus M479T 4870 1GB 8 GB DDR3 
Hard DriveOSPowerCase
160 GB Win 7 Antec 750w Antec 300 
  hide details  
Reply
Bravo
(13 items)
 
  
CPUMotherboardGraphicsRAM
X4 955 @ 3.6 Asus M479T 4870 1GB 8 GB DDR3 
Hard DriveOSPowerCase
160 GB Win 7 Antec 750w Antec 300 
  hide details  
Reply
post #3 of 20
Thread Starter 
Oh, should I be? I give that a go.
post #4 of 20
Thread Starter 
Slight update, the internet on desktop is now working while laptop is acquiring a network address.

Tried bridging, but only works with connections not being used with ICS. Ie, I have no connections that can be bridged.
post #5 of 20
On your desktop you should select your wireless connection and your LAN and bridge them.

Last time I did this, i was using my laptop to give internet to my PS3. I know when i got it setup it showed that my laptop was disconnected on both sides, but it was working fine. So after you bridge them, try the connections out even if it says disconnected.
Bravo
(13 items)
 
  
CPUMotherboardGraphicsRAM
X4 955 @ 3.6 Asus M479T 4870 1GB 8 GB DDR3 
Hard DriveOSPowerCase
160 GB Win 7 Antec 750w Antec 300 
  hide details  
Reply
Bravo
(13 items)
 
  
CPUMotherboardGraphicsRAM
X4 955 @ 3.6 Asus M479T 4870 1GB 8 GB DDR3 
Hard DriveOSPowerCase
160 GB Win 7 Antec 750w Antec 300 
  hide details  
Reply
post #6 of 20
Thread Starter 
If I bridge both connections, I get no internet on either desktop or laptop, and laptop fails to find a network address.
post #7 of 20
Is it possible that there is a 3rd party firewall/Antivirus causing a problem? I've tried networking with Norton installed on a machine and after 2 hours of trying to troubleshoot, it was Norton doing what it does best... interfering.

And I used to love Norton back in the Win 3.1 days. ;(
Nacho Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
q9550 4.0GHz @1.3v GA-EP45-UD3P MSI 460 810/1800 2x2GB Gskill 800/894 
Hard DriveOptical DriveOSMonitor
2x WD 640 Blue RAID0 ASUS DVD+-RW WIN7 / XP 64 / Linux ACER 23" 
PowerCase
Corsair HX750 Custom CM690 
  hide details  
Reply
Nacho Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
q9550 4.0GHz @1.3v GA-EP45-UD3P MSI 460 810/1800 2x2GB Gskill 800/894 
Hard DriveOptical DriveOSMonitor
2x WD 640 Blue RAID0 ASUS DVD+-RW WIN7 / XP 64 / Linux ACER 23" 
PowerCase
Corsair HX750 Custom CM690 
  hide details  
Reply
post #8 of 20
I had the exact same prob as Aardobard....check your firewall settings
Lailonie
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 @ Stock EVGA 790i Ultra Sli EVGA GTX 280 4GB Muskin 1600 OC'd 1800 
Hard DriveOptical DriveOSMonitor
2x Seagate 500GB (0RAID) + 1 750 WD 1 Samsung DVDRW Vista 64 Samsung 26" 
PowerCaseMouse
Antec 1000w LIAN LI Logitech G5 
  hide details  
Reply
Lailonie
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9650 @ Stock EVGA 790i Ultra Sli EVGA GTX 280 4GB Muskin 1600 OC'd 1800 
Hard DriveOptical DriveOSMonitor
2x Seagate 500GB (0RAID) + 1 750 WD 1 Samsung DVDRW Vista 64 Samsung 26" 
PowerCaseMouse
Antec 1000w LIAN LI Logitech G5 
  hide details  
Reply
post #9 of 20
Thread Starter 
The desktop has no firewall at all (not exactly my computer).

But I now have a major problem. I can't enable ICS anymore. Some sort of IP conflict:

"Internet connection sharing cannot be enabled. A LAN connection is already configured with the IP address required for automatic IP addressing."

Everything's on auto (including the LAN port on desktop), none of the computers connected to router are using 192.168.0.1, which I think is the address the computer is trying to assign to LAN.
post #10 of 20
Try setting a static IP.
 
Event Ryzen
(19 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6700k MSI Z170M Mortar  Sapphire RX470 8GB  Crucial Ballistix Sport (grey & black) 
Hard DriveHard DriveHard DriveCooling
240GB Transcend SSD  512GB Transcend SSD 5TB Toshiba Corsair H80i V2 
OSOSMonitorKeyboard
Windows 10 Pro Fedora 23 Workstation LG 29UM68-P & LG 23MP48HQ-P CoolMaster MasterKeys Pro L(MX Reds) 
PowerCaseMouseMouse Pad
SeaSonic M12II 620 Bronze RaidMax Hyperion (Black & Silver) Logitech 300s & 303 Hot Eagle XL mousepad 
AudioAudioAudioAudio
Klipsch R-14M's Presonus audiobox usb. Akai Pro MPK Mini Audio-Technica ATH-M50x, Phillips SHP9500's 
Audio
Audio-Technica AT2020USB Plus 
CPUMotherboardGraphicsRAM
Ryzen 1700  ASROCK AB350 matx Sapphire RX 470 8GB  Crucial Ballistic Sport LT 32GB 
Hard DriveHard DriveHard DriveCooling
x2 Intel S3500 240GB  x1 Intel DC S3700 800GB SSDs x2 Intel S3700 400GB  NZXT Kraken x52  
OSOSMonitorMonitor
Windows 10 Pro Fedora workstation 25  29in LG ultrawide  25in LG ultrawide 
KeyboardPowerCaseMouse
Drevo Excalibur (MX Browns) SeaSonic 620 Corsair Air 240 Logitech G900  
Mouse PadAudioOther
xxl mousepad Same as before  Mellanox x8 10GBe Network Adapter 
  hide details  
Reply
 
Event Ryzen
(19 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6700k MSI Z170M Mortar  Sapphire RX470 8GB  Crucial Ballistix Sport (grey & black) 
Hard DriveHard DriveHard DriveCooling
240GB Transcend SSD  512GB Transcend SSD 5TB Toshiba Corsair H80i V2 
OSOSMonitorKeyboard
Windows 10 Pro Fedora 23 Workstation LG 29UM68-P & LG 23MP48HQ-P CoolMaster MasterKeys Pro L(MX Reds) 
PowerCaseMouseMouse Pad
SeaSonic M12II 620 Bronze RaidMax Hyperion (Black & Silver) Logitech 300s & 303 Hot Eagle XL mousepad 
AudioAudioAudioAudio
Klipsch R-14M's Presonus audiobox usb. Akai Pro MPK Mini Audio-Technica ATH-M50x, Phillips SHP9500's 
Audio
Audio-Technica AT2020USB Plus 
CPUMotherboardGraphicsRAM
Ryzen 1700  ASROCK AB350 matx Sapphire RX 470 8GB  Crucial Ballistic Sport LT 32GB 
Hard DriveHard DriveHard DriveCooling
x2 Intel S3500 240GB  x1 Intel DC S3700 800GB SSDs x2 Intel S3700 400GB  NZXT Kraken x52  
OSOSMonitorMonitor
Windows 10 Pro Fedora workstation 25  29in LG ultrawide  25in LG ultrawide 
KeyboardPowerCaseMouse
Drevo Excalibur (MX Browns) SeaSonic 620 Corsair Air 240 Logitech G900  
Mouse PadAudioOther
xxl mousepad Same as before  Mellanox x8 10GBe Network Adapter 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Windows
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Windows › Can't get Internet Connection Sharing to work