Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Dead integrated LAN card?!
New Posts  All Forums:Forum Nav:

Dead integrated LAN card?!

post #1 of 10
Thread Starter 
Hey guys,

A few days ago I got a lappy, a 12" Dell L400. It's very cool, but has some annoying issues like this one with the LAN.

What it does:
- I did a fresh install of Win 2000 (only 256MB ram) and installed the LAN drivers
- there's an icon on the taskbar showing "cable unplugged" if it's unplugged, and "active network" if the cable is plugged
- still, it doesn't "see" the network, and in task manager I have no network adapter to speak of; in device manager it looks like it installed just fine

What do you think? Bad win install, bad driver, maybe the card could be fried?

/waiting for ideaas
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
post #2 of 10
What happens in the Device Manager? Is there a Red or Yellow Icon next to it.
Gaming
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1090T Crosshair IV Formula GTX 560 GTX 580 
RAMRAMRAMRAM
G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI  G. Skill F3-12800CL6D-4GBPI 
Hard DriveHard DriveHard DriveOptical Drive
Seagate Hard Drive Seagate Hard Drive Crucial M4 SSD Sony Optiarc 
CoolingOSMonitorMonitor
Corsair H70 Windows 7 Professional x64 ASUS VH242H 23" Monitor ASUS VH242H 23" Monitor 
MonitorKeyboardPowerCase
Samsung SyncMaster 906BW 19" Monitor Logitech G15 Corsair 1K PSU Lian-Li 70A 
MouseMouse PadAudio
Logitech Performance MX Razer Vespula HT Omega Pro+ 
  hide details  
Reply
Gaming
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1090T Crosshair IV Formula GTX 560 GTX 580 
RAMRAMRAMRAM
G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI  G. Skill F3-12800CL6D-4GBPI 
Hard DriveHard DriveHard DriveOptical Drive
Seagate Hard Drive Seagate Hard Drive Crucial M4 SSD Sony Optiarc 
CoolingOSMonitorMonitor
Corsair H70 Windows 7 Professional x64 ASUS VH242H 23" Monitor ASUS VH242H 23" Monitor 
MonitorKeyboardPowerCase
Samsung SyncMaster 906BW 19" Monitor Logitech G15 Corsair 1K PSU Lian-Li 70A 
MouseMouse PadAudio
Logitech Performance MX Razer Vespula HT Omega Pro+ 
  hide details  
Reply
post #3 of 10
You could try uninstalling the nic via device manager,rebooting and see if it come back online.Updating or reinstalling the drivers is also something to try if you haven't already.
Edited by reezin14 - 2/20/09 at 2:21pm
 
Event Ryzen
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6700k MSI Z170M Mortar  Sapphire RX470 8GB  Crucial Ballistix Sport (grey & black) 
Hard DriveHard DriveCoolingOS
240GB Transcend SSD  512GB Transcend SSD Corsair H80i V2 Windows 10 Pro 
MonitorKeyboardPowerCase
LG 29UM68-P & LG 23MP48HQ-P CODE 61(MX Clears) Evga SN 550w RaidMax Hyperion (Black & Silver) 
MouseMouse PadAudioAudio
Logitech G900 Hot Eagle XL mousepad Klipsch R-14M's Presonus audiobox usb. 
AudioAudioAudio
Akai Pro MPK Mini Audio-Technica ATH-M50x, Phillips SHP9500's MXL 990/991 
CPUMotherboardOSOS
Ryzen 1600x  ASROCK AB350M PRO Windows 10 Pro Fedora workstation 25 
Case
???? Open Air-Haven't decided 
  hide details  
Reply
 
Event Ryzen
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6700k MSI Z170M Mortar  Sapphire RX470 8GB  Crucial Ballistix Sport (grey & black) 
Hard DriveHard DriveCoolingOS
240GB Transcend SSD  512GB Transcend SSD Corsair H80i V2 Windows 10 Pro 
MonitorKeyboardPowerCase
LG 29UM68-P & LG 23MP48HQ-P CODE 61(MX Clears) Evga SN 550w RaidMax Hyperion (Black & Silver) 
MouseMouse PadAudioAudio
Logitech G900 Hot Eagle XL mousepad Klipsch R-14M's Presonus audiobox usb. 
AudioAudioAudio
Akai Pro MPK Mini Audio-Technica ATH-M50x, Phillips SHP9500's MXL 990/991 
CPUMotherboardOSOS
Ryzen 1600x  ASROCK AB350M PRO Windows 10 Pro Fedora workstation 25 
Case
???? Open Air-Haven't decided 
  hide details  
Reply
post #4 of 10
Thread Starter 
Thanks for the ideas here's what I got:

Quote:
Originally Posted by GH0 View Post
What happens in the Device Manager? Is there a Red or Yellow Icon next to it.
In the Device Manager all is fine (green so to speak), it sees no problem whatsoever.

Quote:
Originally Posted by reezin14 View Post
You could try uninstalling the nic via device manager,rebooting and see if it come back online.Updating or reinstalling the drivers is also something to try if you haven't already.
Tried, no-go. Even more, I've installed XP, here's more wierdness: Device manager OK, I see the NIC in the Task Manager as non-operational if the cable is unplugged, operational if it's plugged, but it receives no IP adress.

Could it be a weird incompatibility with my router? From around 20 computers ever connected on this router this would be the second time it happens, if it's the case.
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
post #5 of 10
What router do you have? Have you tried to ping anything or swapped out the cable? Try giving it a static ip and check to make sure it's(the nic)enabled.
 
Event Ryzen
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6700k MSI Z170M Mortar  Sapphire RX470 8GB  Crucial Ballistix Sport (grey & black) 
Hard DriveHard DriveCoolingOS
240GB Transcend SSD  512GB Transcend SSD Corsair H80i V2 Windows 10 Pro 
MonitorKeyboardPowerCase
LG 29UM68-P & LG 23MP48HQ-P CODE 61(MX Clears) Evga SN 550w RaidMax Hyperion (Black & Silver) 
MouseMouse PadAudioAudio
Logitech G900 Hot Eagle XL mousepad Klipsch R-14M's Presonus audiobox usb. 
AudioAudioAudio
Akai Pro MPK Mini Audio-Technica ATH-M50x, Phillips SHP9500's MXL 990/991 
CPUMotherboardOSOS
Ryzen 1600x  ASROCK AB350M PRO Windows 10 Pro Fedora workstation 25 
Case
???? Open Air-Haven't decided 
  hide details  
Reply
 
Event Ryzen
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6700k MSI Z170M Mortar  Sapphire RX470 8GB  Crucial Ballistix Sport (grey & black) 
Hard DriveHard DriveCoolingOS
240GB Transcend SSD  512GB Transcend SSD Corsair H80i V2 Windows 10 Pro 
MonitorKeyboardPowerCase
LG 29UM68-P & LG 23MP48HQ-P CODE 61(MX Clears) Evga SN 550w RaidMax Hyperion (Black & Silver) 
MouseMouse PadAudioAudio
Logitech G900 Hot Eagle XL mousepad Klipsch R-14M's Presonus audiobox usb. 
AudioAudioAudio
Akai Pro MPK Mini Audio-Technica ATH-M50x, Phillips SHP9500's MXL 990/991 
CPUMotherboardOSOS
Ryzen 1600x  ASROCK AB350M PRO Windows 10 Pro Fedora workstation 25 
Case
???? Open Air-Haven't decided 
  hide details  
Reply
post #6 of 10
Thread Starter 
Quote:
Originally Posted by reezin14 View Post
What router do you have? Have you tried to ping anything or swapped out the cable? Try giving it a static ip and check to make sure it's(the nic)enabled.
I've tried these, nothing - the router is a cheapo' box received along with the ADLS connection, it's an ADSL mored/router. I intend to buy a Linksys router in a couple of weeks. I'll try to test the lappy on some other guy's network, maybe it works.

Still, how about the XP issues? The LAN card appears in Task Manager (as opposed to win 2k)... could that mean it a driver issue?
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
post #7 of 10
I have a feeling this is going to lean more towards some form of hardware failure.
However, if you could run some software like a Linux LiveCD, and if that does pick up the hardware, and IP address then I would think it is a driver or software problem. Otherwise, make sure you are using DHCP, not static settings, make sure the default gateway is correct.
Gaming
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1090T Crosshair IV Formula GTX 560 GTX 580 
RAMRAMRAMRAM
G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI  G. Skill F3-12800CL6D-4GBPI 
Hard DriveHard DriveHard DriveOptical Drive
Seagate Hard Drive Seagate Hard Drive Crucial M4 SSD Sony Optiarc 
CoolingOSMonitorMonitor
Corsair H70 Windows 7 Professional x64 ASUS VH242H 23" Monitor ASUS VH242H 23" Monitor 
MonitorKeyboardPowerCase
Samsung SyncMaster 906BW 19" Monitor Logitech G15 Corsair 1K PSU Lian-Li 70A 
MouseMouse PadAudio
Logitech Performance MX Razer Vespula HT Omega Pro+ 
  hide details  
Reply
Gaming
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1090T Crosshair IV Formula GTX 560 GTX 580 
RAMRAMRAMRAM
G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI  G. Skill F3-12800CL6D-4GBPI 
Hard DriveHard DriveHard DriveOptical Drive
Seagate Hard Drive Seagate Hard Drive Crucial M4 SSD Sony Optiarc 
CoolingOSMonitorMonitor
Corsair H70 Windows 7 Professional x64 ASUS VH242H 23" Monitor ASUS VH242H 23" Monitor 
MonitorKeyboardPowerCase
Samsung SyncMaster 906BW 19" Monitor Logitech G15 Corsair 1K PSU Lian-Li 70A 
MouseMouse PadAudio
Logitech Performance MX Razer Vespula HT Omega Pro+ 
  hide details  
Reply
post #8 of 10
Thread Starter 
I have another question, maybe it'll help diagnose this one also: it seems impossible to install the graphics card... I haven't noticed until now, on 2000 worked fine, on XP it doesn't. Could it be the mobo needing ome chipset drivers or the same mobo failing?

10x
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
post #9 of 10
It could possibly be the motherboard failing. I would definitely suggest using a LiveCD. Doesn't really matter the distro. Ubuntu or Mandriva will work.

If it does happen to be the board, you can try to RMA it (if it is still within the warranty period).
Gaming
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1090T Crosshair IV Formula GTX 560 GTX 580 
RAMRAMRAMRAM
G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI  G. Skill F3-12800CL6D-4GBPI 
Hard DriveHard DriveHard DriveOptical Drive
Seagate Hard Drive Seagate Hard Drive Crucial M4 SSD Sony Optiarc 
CoolingOSMonitorMonitor
Corsair H70 Windows 7 Professional x64 ASUS VH242H 23" Monitor ASUS VH242H 23" Monitor 
MonitorKeyboardPowerCase
Samsung SyncMaster 906BW 19" Monitor Logitech G15 Corsair 1K PSU Lian-Li 70A 
MouseMouse PadAudio
Logitech Performance MX Razer Vespula HT Omega Pro+ 
  hide details  
Reply
Gaming
(23 items)
 
  
CPUMotherboardGraphicsGraphics
AMD Phenom II X6 1090T Crosshair IV Formula GTX 560 GTX 580 
RAMRAMRAMRAM
G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI G. Skill F3-12800CL6D-4GBPI  G. Skill F3-12800CL6D-4GBPI 
Hard DriveHard DriveHard DriveOptical Drive
Seagate Hard Drive Seagate Hard Drive Crucial M4 SSD Sony Optiarc 
CoolingOSMonitorMonitor
Corsair H70 Windows 7 Professional x64 ASUS VH242H 23" Monitor ASUS VH242H 23" Monitor 
MonitorKeyboardPowerCase
Samsung SyncMaster 906BW 19" Monitor Logitech G15 Corsair 1K PSU Lian-Li 70A 
MouseMouse PadAudio
Logitech Performance MX Razer Vespula HT Omega Pro+ 
  hide details  
Reply
post #10 of 10
Quote:
Originally Posted by GH0 View Post
It could possibly be the motherboard failing. I would definitely suggest using a LiveCD. Doesn't really matter the distro. Ubuntu or Mandriva will work.
Good suggestion GHO,I was thinking about this last night. Have you tried booting up the XP disc and repairing the install? Maybe it will pick-up the problems and correct them. And I would still try giving it a static ip.
 
Event Ryzen
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6700k MSI Z170M Mortar  Sapphire RX470 8GB  Crucial Ballistix Sport (grey & black) 
Hard DriveHard DriveCoolingOS
240GB Transcend SSD  512GB Transcend SSD Corsair H80i V2 Windows 10 Pro 
MonitorKeyboardPowerCase
LG 29UM68-P & LG 23MP48HQ-P CODE 61(MX Clears) Evga SN 550w RaidMax Hyperion (Black & Silver) 
MouseMouse PadAudioAudio
Logitech G900 Hot Eagle XL mousepad Klipsch R-14M's Presonus audiobox usb. 
AudioAudioAudio
Akai Pro MPK Mini Audio-Technica ATH-M50x, Phillips SHP9500's MXL 990/991 
CPUMotherboardOSOS
Ryzen 1600x  ASROCK AB350M PRO Windows 10 Pro Fedora workstation 25 
Case
???? Open Air-Haven't decided 
  hide details  
Reply
 
Event Ryzen
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6700k MSI Z170M Mortar  Sapphire RX470 8GB  Crucial Ballistix Sport (grey & black) 
Hard DriveHard DriveCoolingOS
240GB Transcend SSD  512GB Transcend SSD Corsair H80i V2 Windows 10 Pro 
MonitorKeyboardPowerCase
LG 29UM68-P & LG 23MP48HQ-P CODE 61(MX Clears) Evga SN 550w RaidMax Hyperion (Black & Silver) 
MouseMouse PadAudioAudio
Logitech G900 Hot Eagle XL mousepad Klipsch R-14M's Presonus audiobox usb. 
AudioAudioAudio
Akai Pro MPK Mini Audio-Technica ATH-M50x, Phillips SHP9500's MXL 990/991 
CPUMotherboardOSOS
Ryzen 1600x  ASROCK AB350M PRO Windows 10 Pro Fedora workstation 25 
Case
???? Open Air-Haven't decided 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Dead integrated LAN card?!