Overclock.net › Forums › Components › Sound Cards and Computer Audio › I hear myself in my headset!
New Posts  All Forums:Forum Nav:

I hear myself in my headset!

post #1 of 12
Thread Starter 
Well i want to pay some games on steam with friends but recently i can't use my headset without hearing myself when i speak, making it extremely annoying and pretty much pointless to use them. They worked fine without this issue until recently and i haven't changed anything about the settings. I use an X-Fi Xtremegamer. Can anyone help?
post #2 of 12
It maybe someone elses mic. It usally does that to me on xbox live but I havent had any pc problems like that.
amd <3
(14 items)
 
   
CPUMotherboardGraphicsGraphics
FX-8350@4.2GHz Gigabyte GA-990FXA-UD3 EVGA GTX 660 SC  EVGA GTX 660 SC  
RAMHard DriveCoolingOS
12 GB G.Skill Ripjaw DDR3 1333 Kingston SSDNow V100 64GB, WD Blue 500GB Corsair H60 Windows 7 Professional 64bit 
MonitorKeyboardPowerCase
LG Flatron W2442PA Cooler Master QuickFire Rapid Corsair HX650 Corsair C70  
MouseMouse Pad
Steelseries Sensei Steel Series QCK XL 
CPUMotherboardGraphicsGraphics
Intel i5 760 4.0GHz Asus Maximus III Gene Asus 5850 1GB Sapphire 5850 1GB 
RAMHard DriveOSMonitor
12GB G.Skill Ripjaw Kingston SSDNow V100 64GB, WD Blue 500GB Windows 7 Professional 64bit LG Flatron W2442PA 
KeyboardPowerCaseMouse
Cooler Master QuickFire Rapid Corsair HX650 Fractal Design Define Mini Steelseries Sensei 
Mouse Pad
Steel Series QCK XL 
  hide details  
Reply
amd <3
(14 items)
 
   
CPUMotherboardGraphicsGraphics
FX-8350@4.2GHz Gigabyte GA-990FXA-UD3 EVGA GTX 660 SC  EVGA GTX 660 SC  
RAMHard DriveCoolingOS
12 GB G.Skill Ripjaw DDR3 1333 Kingston SSDNow V100 64GB, WD Blue 500GB Corsair H60 Windows 7 Professional 64bit 
MonitorKeyboardPowerCase
LG Flatron W2442PA Cooler Master QuickFire Rapid Corsair HX650 Corsair C70  
MouseMouse Pad
Steelseries Sensei Steel Series QCK XL 
CPUMotherboardGraphicsGraphics
Intel i5 760 4.0GHz Asus Maximus III Gene Asus 5850 1GB Sapphire 5850 1GB 
RAMHard DriveOSMonitor
12GB G.Skill Ripjaw Kingston SSDNow V100 64GB, WD Blue 500GB Windows 7 Professional 64bit LG Flatron W2442PA 
KeyboardPowerCaseMouse
Cooler Master QuickFire Rapid Corsair HX650 Fractal Design Define Mini Steelseries Sensei 
Mouse Pad
Steel Series QCK XL 
  hide details  
Reply
post #3 of 12
go into your sound settings and mute the playback volume
Dirty Intel
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.4GHz 1.33v GA-Z68X-UD3H-B3 Sapphire Vapor-X HD7970 GHz 16GB DDR3 1600 Corsair Vengeance 
Hard DriveHard DriveOptical DriveCooling
OCZ Vertex 4 OCZ Agility 2 120GB + WD 500GB Black + WD 320GB 2xSamsung DVD-RW Silver Arrow 
OSMonitorKeyboardPower
Windows 7 Pro 64-bit Acer 23" H233H 1080P Logitech G19 Corsair 750TX 
CaseMouseAudio
Coolermaster 690 Logitech G500 X-Fi Titanium 
  hide details  
Reply
Dirty Intel
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.4GHz 1.33v GA-Z68X-UD3H-B3 Sapphire Vapor-X HD7970 GHz 16GB DDR3 1600 Corsair Vengeance 
Hard DriveHard DriveOptical DriveCooling
OCZ Vertex 4 OCZ Agility 2 120GB + WD 500GB Black + WD 320GB 2xSamsung DVD-RW Silver Arrow 
OSMonitorKeyboardPower
Windows 7 Pro 64-bit Acer 23" H233H 1080P Logitech G19 Corsair 750TX 
CaseMouseAudio
Coolermaster 690 Logitech G500 X-Fi Titanium 
  hide details  
Reply
post #4 of 12
Yeah, the same thing happened to me.

Quote:
Originally Posted by Lxcivic2k1 View Post
go into your sound settings and mute the playback volume
Pretty much.

Control Panel -> Sound -> Recording Tab -> Right click properties on the mic -> uncheck "Listen to this device"
Missingno.
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k (@4.2 GHz) MSI P67A-GD55 Quad CrossfireX HD4870 X2 @ 800/940 G.Skill Ripjaws 1600MHz (2x4GB) 
Hard DriveHard DriveHard DriveOS
300GB VelociRaptor 1.5TB 7200rpm Seagate 3 TB Seagate External USB 3.0 Windows 7 Ultimate 64-bit 
MonitorKeyboardPowerCase
Gateway XHD3000 30" Razer Lycosa Enermax Evo Galaxy 1250W Lian Li A05 
Mouse
Razer Lachesis 
  hide details  
Reply
Missingno.
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k (@4.2 GHz) MSI P67A-GD55 Quad CrossfireX HD4870 X2 @ 800/940 G.Skill Ripjaws 1600MHz (2x4GB) 
Hard DriveHard DriveHard DriveOS
300GB VelociRaptor 1.5TB 7200rpm Seagate 3 TB Seagate External USB 3.0 Windows 7 Ultimate 64-bit 
MonitorKeyboardPowerCase
Gateway XHD3000 30" Razer Lycosa Enermax Evo Galaxy 1250W Lian Li A05 
Mouse
Razer Lachesis 
  hide details  
Reply
post #5 of 12
^like he said

mute microphone in ur volume settings
    
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Gigabyte GA-EP45-UD3R Sapphire 7870 2gb Crucial Ballistix 4x1gb 
Hard DriveOptical DriveCoolingOS
WD Blue 320gb Sony Optiarc DVDRW Corsair H50 Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
LG 22" L226W (1680x1050) Logitech Standard w/ Media Controls Seasonic M12D 850w Coolermaster 690 II 
MouseMouse PadAudio
Razer Naga Standard Mouse Pad Polk 2.1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Q6600 G0 Gigabyte GA-EP45-UD3R Sapphire 7870 2gb Crucial Ballistix 4x1gb 
Hard DriveOptical DriveCoolingOS
WD Blue 320gb Sony Optiarc DVDRW Corsair H50 Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
LG 22" L226W (1680x1050) Logitech Standard w/ Media Controls Seasonic M12D 850w Coolermaster 690 II 
MouseMouse PadAudio
Razer Naga Standard Mouse Pad Polk 2.1 
  hide details  
Reply
post #6 of 12
Thread Starter 
Cool Beans! Thanks for the help guys.
post #7 of 12
Where do i have to look? I'm dutch so i don't know of every word what it means. I got the same problem. I got my headset for a few months. But now i hear myself throught it. I use skype, but even when i'm not online on skype i still hear myself in my headset.
post #8 of 12
HI there - I bought one of these headsets last week - I mostly use it for teamspeak on the PC... i too encountered the "hearing myself" issue... i did find the box to tick to not listen to myself talking the whole time... but it wasn't ticked!! - I ticked it, hit apply, then unticked it again & hey presto - problem fixed.... or so I thought...

Problem is... if I unplug the usb connection, reboot the PC (WIN-7 Ultimate x64) and then plug the headset's USB adaptor back in, the settings revert to to hearing myself (again... the box in Control Panel -> Sound -> Recording Tab is again not ticked, but self listen is active!!

when I check the box & hit apply, i hear myself but with a fraction of a second delay.... VERY off-putting indeed!! then when I un-check the box & apply, its fine...

my issue seems to be repeatable... every time I reboot & then plug the headset, the fold-back or "listen" gets turned on, without the box being checked.

has anyone else had this issue, and resolved it?? or do I send the headset back a PoS? as it is really beginning to upset me that after spending what I consider to be a lot of money, the flipping thing doesn't perform as it should frown.gif

i look forward to hearing from anyone that has a suggestion.

Thanks
Burt
post #9 of 12
Quote:
Originally Posted by Oldboy View Post

I hear myself in my headset! , help?
Just checking, are you sure your not going crazy?
post #10 of 12
hi - yes - i may be a little 'wonky' in my middle age, but it is repeatable, and I'm assured that I'm not delusional... yet tongue.gif

Regards
Burt
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › I hear myself in my headset!