Overclock.net › Forums › Components › Hard Drives & Storage › RAID Controllers and Software › HowTo : Recover Intel RAID "Non-Member Disk" Error..
New Posts  All Forums:Forum Nav:

HowTo : Recover Intel RAID "Non-Member Disk" Error..

post #1 of 278
Thread Starter 
Greets..

Just something I'm sure has been here but since the changes to the searching of the site I can no longer go back more than 5 pages and I've lost tons of info because I failed to bookmark or subscribe. Here is a new attempt at fixing this as I just lost and recovered my Intel RAID0 Array without loss of data.

I have the Gigabyte UD3P and it has the Intel ICH10R chipset which has given myself, as others out there on the interwebz, some problems with an unsuspecting action such as a reboot, BIOS Flash or OC'ing crash and leaving 1 or more of your drives in the RAID Array now showing "Non-Member Disk".

Essentially this means it's lost it's RAID configuration and I just got through my 3rd time with this issue. The prior 2 times I wasn't able to find info and had to "bite the bullet" and re-established my array from scratch and installing everything again. Quite a PITA.

Again tonight, after a BIOS Flash and restart on my UD3P, I saw in the RAID BIOS again the "Non-Member Disk" flag and my array in "Failure" mode

Fear not. The steps listed below are NOT mine but I found them and followed them to a T and unbelieveably they worked like a charm! My RAID0 is back and no data loss. Unbelieveable!

I provided this as-is but the thread where this was sourced had many with the same success. I cannot vouch for anyone but myself and my success as well possible controllers it may or may not work with so BE SAFE and do your dilegence!

Source Thread

Quote:
Originally Posted by The Source Thread Above
Thanks to everyone who tried to help. I found a solution and I thought I'd share it. I was able to recover the broken array using following steps.

1. Reset both HDs to non-member using Intel BIOS utility - the utility warns that all data will be lost - in fact only metadata is lost and can be recreated using steps below.

2. Create a new array with identical settings as the broken array. It is critical that the HDs are in the array the same order as before. I was reconnecting the drives several times and lost track of correct order. Because of that I had to go through the steps twice (I guessed wrong the first time).

3. Get TestDisk from http://www.cgsecurity.org. I used Windows version (I installed a new Vista on a separate HD for this purpose).

4. Run TestDisk according to steps on the web site. If your HDs are connected in correct order, TestDisk should find the lost partition(s) within a few seconds. It ran for several hours, scanning my array and never found anything because I had HDs were connected in wrong order. After I changed the order and restarted from step #1 TestDisk found the missing partition immediately.

5. Have the TestDisk write the fixed partition table to the drive and reboot.

6. Now all your data on the array should be readable but the system might not boot (it didn't for me).

7. Run Vista repair from installation CD to fix the MBR.

Quote:
Originally Posted by Ictinike

On this part, a gent and myself went through this for Win 7 as well I've done Vista and we had to run the 3 bootrec commands to get his viable. I can't remember if I did this on Vista but it might be wise to run all three to fix the MBR in Vista as listed above. To do so:

in Command Prompt from the Recover console enter:

bootrec /fixmbr (should success)
bootrec /fixboot (should success)
bootrec /rebuildbcd (detects the Windows installation and asks you to add it to the BCD, hit YES)


8. Last but not least, send a donation to Mr. Grenier, the author of TestDisk.
Now I'm bookmarking as well subscribing to this thread so I never lose it and have to find this info again!

Cheers!

~Ictinike
Edited by Ictinike - 8/1/09 at 9:00pm
Refreshed Duo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 E0@4.25Ghz (500x8.5) Gigabyte GA-EP45-UD3P EVGA GTX285 (720/1674/2772) 2x2gb G.SKILL PC8500 
Hard DriveOptical DriveOSMonitor
3xWD 250GB RAID0 Sony DVD/CDR/RW Windows 7 Ultimate x64 ACER 24" P241WAID LCD 
KeyboardPowerCaseMouse
Logitech G15 (Original) OCZ GameXStream 700w SLI ThermalTake Armor Black Logitech G5 
Mouse Pad
Razor XACT 
  hide details  
Reply
Refreshed Duo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 E0@4.25Ghz (500x8.5) Gigabyte GA-EP45-UD3P EVGA GTX285 (720/1674/2772) 2x2gb G.SKILL PC8500 
Hard DriveOptical DriveOSMonitor
3xWD 250GB RAID0 Sony DVD/CDR/RW Windows 7 Ultimate x64 ACER 24" P241WAID LCD 
KeyboardPowerCaseMouse
Logitech G15 (Original) OCZ GameXStream 700w SLI ThermalTake Armor Black Logitech G5 
Mouse Pad
Razor XACT 
  hide details  
Reply
post #2 of 278
Good man, I hope I never have to use this...
    
CPUMotherboardGraphicsRAM
Xeon E5645 Asus Rampage II Gene eVGA GTX460 SSC 3x4GB Corsair Dominator PC3-12800 
Hard DriveHard DriveHard DriveOS
Crucial C300 64GB Seagate Momentus XT 750 Western Digital GP 2TB EARS Windows 7 Premium 
MonitorKeyboardPowerCase
Asus VE278Q DSI SMK-88 Seasonic X-660 Lian Li U6B 2011 SE 
MouseMouse Pad
Logitech G500 KAI.g3 HIEN - HARD 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Xeon E5645 Asus Rampage II Gene eVGA GTX460 SSC 3x4GB Corsair Dominator PC3-12800 
Hard DriveHard DriveHard DriveOS
Crucial C300 64GB Seagate Momentus XT 750 Western Digital GP 2TB EARS Windows 7 Premium 
MonitorKeyboardPowerCase
Asus VE278Q DSI SMK-88 Seasonic X-660 Lian Li U6B 2011 SE 
MouseMouse Pad
Logitech G500 KAI.g3 HIEN - HARD 
  hide details  
Reply
post #3 of 278
Thought I'd use this rather than a new thread.

I can recover all my data but I'm struggling to get vista 64 to boot, managed it once but itnow gets to the part where the loadin bar comes up the restarts. Any ideas?

I can recover the data now as everything shows up on the recovery disk's command prompt.

The vista startup repair fails because of bad drivers, what drivers do I need?
Fortress
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9550 E0 1.225 VID @ 4ghz Gigabyte EP45-UD3P 768mb 8800 GTX 8GB OCZ Platinum 1066mhz 
Hard DriveOptical DriveOSMonitor
2x Seagate Barracuda 500gb LG Sata Bluray ROM + LG IDE DVD RW Vista Home Premium x64 Samsung T260HD 1920x1200 
PowerCase
Corsair HX620 Silverstone FT01B-W 
  hide details  
Reply
Fortress
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9550 E0 1.225 VID @ 4ghz Gigabyte EP45-UD3P 768mb 8800 GTX 8GB OCZ Platinum 1066mhz 
Hard DriveOptical DriveOSMonitor
2x Seagate Barracuda 500gb LG Sata Bluray ROM + LG IDE DVD RW Vista Home Premium x64 Samsung T260HD 1920x1200 
PowerCase
Corsair HX620 Silverstone FT01B-W 
  hide details  
Reply
post #4 of 278
Alright this post is a life saver! I thought I had lost all of data on my raptorX's in Raid0.

What had happened was when I turned my rig on with my WM phone synced and charging. It cut my raid array and my drives were showing as NON MEMBER. I tried everything I could think of, but this fixed it right up.

+rep
Hexa-potens
(0 items)
  
Reply
Hexa-potens
(0 items)
  
Reply
post #5 of 278
I can say this definitely works. My RAID has been giving me trouble lately (since taken it out temporarily) and did this probably a dozen times. Perfectly safe to do and can be scary at first, but it will WORK!

I seriously wish I knew this back in January when it wouldn't boot and I had to reformat and lost about 2 months worth of stuff.
quad core madness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Lapped Intel Core 2 Quad - Q6600 G0 Stepping Asus P5K Deluxe WiFi ATi Sapphire HD 6950 2GB Unlocked 8GB G.Skill Pi Black DDR2-800 PC2-6400 
Hard DriveOptical DriveOSMonitor
60GB OCZ Solid 2 SSD Samsung SATA 18X DVD Burner Windows 7 Ultimate x64 Dell 3007WFP-HC + 2x 2007FP in PLP 
KeyboardPowerCaseMouse
Ducky Shine Blue, MX Red Corsair HX620 620W Lian Li V1000 Plus Black Razer Mamba 2012 
Mouse PadAudio
XTrack Ripper XL Creative X-Fi XtremeMusic 
  hide details  
Reply
quad core madness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Lapped Intel Core 2 Quad - Q6600 G0 Stepping Asus P5K Deluxe WiFi ATi Sapphire HD 6950 2GB Unlocked 8GB G.Skill Pi Black DDR2-800 PC2-6400 
Hard DriveOptical DriveOSMonitor
60GB OCZ Solid 2 SSD Samsung SATA 18X DVD Burner Windows 7 Ultimate x64 Dell 3007WFP-HC + 2x 2007FP in PLP 
KeyboardPowerCaseMouse
Ducky Shine Blue, MX Red Corsair HX620 620W Lian Li V1000 Plus Black Razer Mamba 2012 
Mouse PadAudio
XTrack Ripper XL Creative X-Fi XtremeMusic 
  hide details  
Reply
post #6 of 278
Thread Starter 
Bump for the masses.. Had to do this again within the past month or two and missed the last few comments being away from the OCN forums a bit..

Cheers!
Refreshed Duo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 E0@4.25Ghz (500x8.5) Gigabyte GA-EP45-UD3P EVGA GTX285 (720/1674/2772) 2x2gb G.SKILL PC8500 
Hard DriveOptical DriveOSMonitor
3xWD 250GB RAID0 Sony DVD/CDR/RW Windows 7 Ultimate x64 ACER 24" P241WAID LCD 
KeyboardPowerCaseMouse
Logitech G15 (Original) OCZ GameXStream 700w SLI ThermalTake Armor Black Logitech G5 
Mouse Pad
Razor XACT 
  hide details  
Reply
Refreshed Duo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 E0@4.25Ghz (500x8.5) Gigabyte GA-EP45-UD3P EVGA GTX285 (720/1674/2772) 2x2gb G.SKILL PC8500 
Hard DriveOptical DriveOSMonitor
3xWD 250GB RAID0 Sony DVD/CDR/RW Windows 7 Ultimate x64 ACER 24" P241WAID LCD 
KeyboardPowerCaseMouse
Logitech G15 (Original) OCZ GameXStream 700w SLI ThermalTake Armor Black Logitech G5 
Mouse Pad
Razor XACT 
  hide details  
Reply
post #7 of 278
Absolutely awesome, I wish I had this a couple weeks ago
BOOKMARKED!!!
REP+
post #8 of 278
Thread Starter 
Update to the original post concerning Win7 as well the 3 commands needed to get the Vista boot manager working once you reset the RAID config..

Another success story here!
http://www.overclock.net/hard-drives...ml#post6837244

This works with Win7 but the navigation to the Command Prompt in the recovery console is a bit more `hidden` but have it go through Repair and when asked after it states it's fixed something hit NO and go to the Recovery Tools area where you'll find the Command Prompt option

~Ictinike
Refreshed Duo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 E0@4.25Ghz (500x8.5) Gigabyte GA-EP45-UD3P EVGA GTX285 (720/1674/2772) 2x2gb G.SKILL PC8500 
Hard DriveOptical DriveOSMonitor
3xWD 250GB RAID0 Sony DVD/CDR/RW Windows 7 Ultimate x64 ACER 24" P241WAID LCD 
KeyboardPowerCaseMouse
Logitech G15 (Original) OCZ GameXStream 700w SLI ThermalTake Armor Black Logitech G5 
Mouse Pad
Razor XACT 
  hide details  
Reply
Refreshed Duo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 E0@4.25Ghz (500x8.5) Gigabyte GA-EP45-UD3P EVGA GTX285 (720/1674/2772) 2x2gb G.SKILL PC8500 
Hard DriveOptical DriveOSMonitor
3xWD 250GB RAID0 Sony DVD/CDR/RW Windows 7 Ultimate x64 ACER 24" P241WAID LCD 
KeyboardPowerCaseMouse
Logitech G15 (Original) OCZ GameXStream 700w SLI ThermalTake Armor Black Logitech G5 
Mouse Pad
Razor XACT 
  hide details  
Reply
post #9 of 278
Is there anything i can do if when i create the raid volume over again it says Failed right away and the 2nd disk is still a Non-raid disk?

Thanks,
Philippe

EDIT: Never mind... ran diag on it.. its fried :/ RMAed
Edited by pip8786 - 8/11/09 at 8:49pm
Desktop
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6700 Core 2 Duo Foxconn 975X7AB XFX HD 5700 4GB 800mhz (2 ADATA, 2 Corsair) 
Hard DriveOSMonitorPower
2xRaptor67GB, 1xSeagate300GB Windows 7 ASUS VW266H, Compaq WF1907 X2 Raidmax 530W 
Mouse
MX518 
  hide details  
Reply
Desktop
(13 items)
 
  
CPUMotherboardGraphicsRAM
E6700 Core 2 Duo Foxconn 975X7AB XFX HD 5700 4GB 800mhz (2 ADATA, 2 Corsair) 
Hard DriveOSMonitorPower
2xRaptor67GB, 1xSeagate300GB Windows 7 ASUS VW266H, Compaq WF1907 X2 Raidmax 530W 
Mouse
MX518 
  hide details  
Reply
post #10 of 278
I'm trying to use this solution to my problem, but I can't boot to my spare drive when the motherboard is in RAID mode. It just crashes on windows startup. If I turn raid off in the bios then I can boot to it, but then test disk only sees each drive separately and not as a raid, so it can't find any partitions. Any tips?
Tyrant
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core 2 Duo E8400 Gigabyte GA-EP35-DS3R Saphire HD4870 OCZ Reaper 6GB DDR2 6400 
Hard DriveOSMonitorKeyboard
Seagate Barracuda Windows XP Professional Dell 20" Widescreen Saitek Eclipse II 
PowerCaseMouseMouse Pad
Hiper Type-R 580W NZXT Lexa Series Logitech MX518/Razer Copperhead Razer Mantis Control 
  hide details  
Reply
Tyrant
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core 2 Duo E8400 Gigabyte GA-EP35-DS3R Saphire HD4870 OCZ Reaper 6GB DDR2 6400 
Hard DriveOSMonitorKeyboard
Seagate Barracuda Windows XP Professional Dell 20" Widescreen Saitek Eclipse II 
PowerCaseMouseMouse Pad
Hiper Type-R 580W NZXT Lexa Series Logitech MX518/Razer Copperhead Razer Mantis Control 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: RAID Controllers and Software
Overclock.net › Forums › Components › Hard Drives & Storage › RAID Controllers and Software › HowTo : Recover Intel RAID "Non-Member Disk" Error..