Overclock.net › Forums › AMD › AMD Motherboards › [OFFICIAL] Asus CrossHair III Formula AM3 Club
New Posts  All Forums:Forum Nav:

[OFFICIAL] Asus CrossHair III Formula AM3 Club - Page 60

post #591 of 1767
Quote:
Originally Posted by metal_gunjee View Post
That's most unfortunate for those who don't have 8-pin 12V connector on their power supply. There are boards that will allow operation with only 4 pins even though they would have an 8-pin connector, too bad this isn't one of them. The plug on 4 of the pins would lead you to think this would be possible on this motherboard.
Then again any system builder should do their research and know what they have and are getting before they make a purchase.
Most unfortunate indeed, I wonder if its possible to use an adapter?
I would guess it would draw a substansial amount of power, but it`s
still only 4x12v+ and 4x12v- . But in the long run a better power supply that supports the new ATX standard would be preferable.

Half the fun of being on a bugdet is the ninjasolutions

If I were to have this problem and no cash, I would use one of my
adapters I got left over from my hd4850 cards, done some "blacksmithing"
and ofc made sure I got the right polarity on the connections
Depending on the 12v rails on the current PSU I would atleast get the mobo
to b00t
The Dark Side
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500k Gigabyte z77x-udh3 hd6950 crossfire 16gb Corsair vengeance 1600mhz 
Hard DriveCoolingOSMonitor
250gb WD , seagate 320gb Antec 920 integrated watercooler windows 7 x64 Optoma HD67 720p/120hz 
KeyboardPowerCaseMouse
Logitech mx5000 Corsair TX750w Customized Dragon Chieftec Tower Sidewinder x8 
Mouse PadAudio
Razer exactmat Yamaha rx-v3800 surround reciever  
  hide details  
Reply
The Dark Side
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500k Gigabyte z77x-udh3 hd6950 crossfire 16gb Corsair vengeance 1600mhz 
Hard DriveCoolingOSMonitor
250gb WD , seagate 320gb Antec 920 integrated watercooler windows 7 x64 Optoma HD67 720p/120hz 
KeyboardPowerCaseMouse
Logitech mx5000 Corsair TX750w Customized Dragon Chieftec Tower Sidewinder x8 
Mouse PadAudio
Razer exactmat Yamaha rx-v3800 surround reciever  
  hide details  
Reply
post #592 of 1767
Found this btw http://www.frozencpu.com/psu-147.html , and your
current PSU got a 20A 12v rail (I would have divided the molex to get power from both rails though)
The Dark Side
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500k Gigabyte z77x-udh3 hd6950 crossfire 16gb Corsair vengeance 1600mhz 
Hard DriveCoolingOSMonitor
250gb WD , seagate 320gb Antec 920 integrated watercooler windows 7 x64 Optoma HD67 720p/120hz 
KeyboardPowerCaseMouse
Logitech mx5000 Corsair TX750w Customized Dragon Chieftec Tower Sidewinder x8 
Mouse PadAudio
Razer exactmat Yamaha rx-v3800 surround reciever  
  hide details  
Reply
The Dark Side
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500k Gigabyte z77x-udh3 hd6950 crossfire 16gb Corsair vengeance 1600mhz 
Hard DriveCoolingOSMonitor
250gb WD , seagate 320gb Antec 920 integrated watercooler windows 7 x64 Optoma HD67 720p/120hz 
KeyboardPowerCaseMouse
Logitech mx5000 Corsair TX750w Customized Dragon Chieftec Tower Sidewinder x8 
Mouse PadAudio
Razer exactmat Yamaha rx-v3800 surround reciever  
  hide details  
Reply
post #593 of 1767
Hello all, new to the forums, have read a lot of good info here, but have a question that I have not been able to find an answer too.

I have an Asus Crosshair III Formula Mobo running the 1403 Bios. I also have 8GB of G.SKILL Ripjaws Series(4 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-4GBRL.

Now to my understanding this is supposed to be running at 1600Mhz. I check the Bios and its running at 1333Mhz.

When I change it to 1600 it will reboot after showing the windows logo, and or give me a BSOD. I tried to up the voltage, and it ran fine just idling for about 10 minutes before a BSOD.

Question is, has any one run into similar problems that can recommend a solution? Cause I feel I may be missing something to get my RAM to run at its advertised 1600Mhz.
New AMD PC
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 C3 @3.6 Asus Crosshair III Formula Asus ATI HD5870 8gb G.Skill DDR3-1600 
Hard DriveOSMonitorKeyboard
WD Caviar Black 1TB Windows 7 64bit Ultimate Asus 24" VW264H Logitech G110 
PowerCaseMouse
Antec CP-1000 1000W Antec 1200 Logitech G500 
  hide details  
Reply
New AMD PC
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 C3 @3.6 Asus Crosshair III Formula Asus ATI HD5870 8gb G.Skill DDR3-1600 
Hard DriveOSMonitorKeyboard
WD Caviar Black 1TB Windows 7 64bit Ultimate Asus 24" VW264H Logitech G110 
PowerCaseMouse
Antec CP-1000 1000W Antec 1200 Logitech G500 
  hide details  
Reply
post #594 of 1767
Quote:
Originally Posted by Boomer1979 View Post
Hello all, new to the forums, have read a lot of good info here, but have a question that I have not been able to find an answer too.

I have an Asus Crosshair III Formula Mobo running the 1403 Bios. I also have 8GB of G.SKILL Ripjaws Series(4 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-4GBRL.

Now to my understanding this is supposed to be running at 1600Mhz. I check the Bios and its running at 1333Mhz.

When I change it to 1600 it will reboot after showing the windows logo, and or give me a BSOD. I tried to up the voltage, and it ran fine just idling for about 10 minutes before a BSOD.

Question is, has any one run into similar problems that can recommend a solution? Cause I feel I may be missing something to get my RAM to run at its advertised 1600Mhz.
check you timings as well.
I think best way to answer for me is I bought the mushkin 996657 2 sets for a total of 8gb like you . They are advertised to run at 1600 7-7-7-20-1t 1.85v-1.95v according to mushkin. What I did was go and in bios switched it to 1600, i actually kept voltage on auto, and manually put the timings to 7-7-7-20-1t rest on auto and it worked for me EXCEPT intel maximum burn test would bsod or freeze. I put my volts to 1.90 (since thats what cpuz the jpec shows hwat it recommends ) and since than I can run a full 20 runs of maximun intel burn test ( @stock everything else btw)

I think an easy way of seeing what your ram timings should be is if you have cpu z under the jpec std, it should tell you what timings and voltages ur ram should be set too , KEEP in mind that for 1600 its under 800mhz (dual channel you double it for the 1600 mhz)

Hope this helps ( ps and btw yes if you put your ram volts to over I think 1.75 manually it turns yellow and the led light on mobo will turn amber but I guess this is normal)
Pavo Gaming
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD 8350 Crosshair V Formula Z Gigabyte 7870 oc version G Skill Trident 2133 cl 9 16gb (2 x 8 gb) 
Hard DriveOptical DriveOSMonitor
Samsung 840 256 gb SSD Plextor Bluray and Msi dvd Windows 7 x64 Ult Sony 60" LED 3D 
PowerCaseOtherOther
Corsair HX 1050 Azza Solano temp Stinger V8 Waterblock w Monsta 420 Radiator All... Stinger V8 Waterblock w Monsta 420 Radiator All... 
  hide details  
Reply
Pavo Gaming
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD 8350 Crosshair V Formula Z Gigabyte 7870 oc version G Skill Trident 2133 cl 9 16gb (2 x 8 gb) 
Hard DriveOptical DriveOSMonitor
Samsung 840 256 gb SSD Plextor Bluray and Msi dvd Windows 7 x64 Ult Sony 60" LED 3D 
PowerCaseOtherOther
Corsair HX 1050 Azza Solano temp Stinger V8 Waterblock w Monsta 420 Radiator All... Stinger V8 Waterblock w Monsta 420 Radiator All... 
  hide details  
Reply
post #595 of 1767
Quote:
Originally Posted by roxxphatcox View Post
I have a problem with this board, the northbridge is getting hot as hell (90C and shuts down)

I can get a stable overclock @ 3.84ghz with a aftermarket air cooler,
the cpu maxes at 56C full load over 2 hrs but then the NB overheats (90c)

I tried upping the volts on NB and NB/CPU to no avail, I wonder if any1 else
has this problem?

I have the c2 step 140wTDP phII x4 965be.

Running on a safe 3.6ghz and still the NB is at about 80c
Same problem but with the Phenom II x4 965BE C3 125W. Dumb question, but all you did was pull the pinned heatsink off, cleaned up the "damage", and new grease?

Quote:
Originally Posted by SystemTech View Post
Thats far too high, the highest i have seen is like 40*C on mine. You should possibly try re-seating your NB heatsink. you will be required to remove the whole thing though because of the heatpipes. I think that its not making proper contact with the northbridge processor.
Will this way work better than just pulling the iROG pinned heatsink off the NB heatpipe assembly?

Sorry if these are dumb questions, I'm just wondering at the best method. I'm kinda PO'd that I had to wait nearly a month to order this as a replacement to my M4A79T Deluxe (started acting funky), only to think I got a piece of crap. However it seems that this isn't an extremely common problem but it is enough to start a few threads on various forums.
It's Classified
(17 items)
 
ASUS ROG G74SX-A1
(15 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 G74Sx NVIDIA GeForce GTX 560M  Corsair VENGEANCE 
Hard DriveHard DriveOptical DriveOS
Corsair Force Series GT Seagate BD Combo Windows 7 Home Premium SP1 x64 
MonitorKeyboardPowerCase
17.3" 1920x1080 Integrated Chicklet 150W Brick ASUS G74SX 
MouseMouse PadAudio
ASUS Gaming Mouse Corsair Integrated 
  hide details  
Reply
It's Classified
(17 items)
 
ASUS ROG G74SX-A1
(15 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 G74Sx NVIDIA GeForce GTX 560M  Corsair VENGEANCE 
Hard DriveHard DriveOptical DriveOS
Corsair Force Series GT Seagate BD Combo Windows 7 Home Premium SP1 x64 
MonitorKeyboardPowerCase
17.3" 1920x1080 Integrated Chicklet 150W Brick ASUS G74SX 
MouseMouse PadAudio
ASUS Gaming Mouse Corsair Integrated 
  hide details  
Reply
post #596 of 1767
Quote:
Originally Posted by LoneWolf3574 View Post
Same problem but with the Phenom II x4 965BE C3 125W. Dumb question, but all you did was pull the pinned heatsink off, cleaned up the "damage", and new grease?



Will this way work better than just pulling the iROG pinned heatsink off the NB heatpipe assembly?

Sorry if these are dumb questions, I'm just wondering at the best method. I'm kinda PO'd that I had to wait nearly a month to order this as a replacement to my M4A79T Deluxe (started acting funky), only to think I got a piece of crap. However it seems that this isn't an extremely common problem but it is enough to start a few threads on various forums.
1, Well basically, yeah 2 screws , sanded down the damage so the heatsink could connect with the surface and new grease.


2. If taking off the heatsink alone shows no anomalities , u probably
will have to take off the whole heatpipe assembly.
The Dark Side
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500k Gigabyte z77x-udh3 hd6950 crossfire 16gb Corsair vengeance 1600mhz 
Hard DriveCoolingOSMonitor
250gb WD , seagate 320gb Antec 920 integrated watercooler windows 7 x64 Optoma HD67 720p/120hz 
KeyboardPowerCaseMouse
Logitech mx5000 Corsair TX750w Customized Dragon Chieftec Tower Sidewinder x8 
Mouse PadAudio
Razer exactmat Yamaha rx-v3800 surround reciever  
  hide details  
Reply
The Dark Side
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500k Gigabyte z77x-udh3 hd6950 crossfire 16gb Corsair vengeance 1600mhz 
Hard DriveCoolingOSMonitor
250gb WD , seagate 320gb Antec 920 integrated watercooler windows 7 x64 Optoma HD67 720p/120hz 
KeyboardPowerCaseMouse
Logitech mx5000 Corsair TX750w Customized Dragon Chieftec Tower Sidewinder x8 
Mouse PadAudio
Razer exactmat Yamaha rx-v3800 surround reciever  
  hide details  
Reply
post #597 of 1767
Thread Starter 
Quote:
no problem, i suggested a few pages back getting the soundmax drivers on the front page, OP heed my call!!
Its already there and has been since you suggested it.

Welcoms to :
roxxphatcox
metal_gunjee
Boomer1979
LoneWolf3574
(If i am missing anyone please let me know)


Quote:
Then again any system builder should do their research and know what they have and are getting before they make a purchase.
Lol, i never did. bought a new PSU a month before i ordered my board and was complete and absolute grace that my new PSU had a 8pin CPU connector.
   
Cores Galore
(16 items)
 
CPUGraphicsRAMHard Drive
i7-6700HQ GTX 1070 8GB, GPU AMP Waiting for BIG Vega 16GB 2667mhz Alienware Crucial BX100 1TB 
Hard DriveMonitorMonitorKeyboard
Samsung 960 Pro 512GB Acer XR341CK 34" 3440x1440 @ 85hz awesomness Stock 1920x1080 Logitech G410 Atlas Spectrum 
MouseMouse PadAudio
Logitech G700S Roccat Taito Logitech G930 
CPUMotherboardGraphicsHard Drive
i7-4700QM Alienware M14X Nvidia Geforce GTX 765M Samsung Evo 850 mSATA 256 GB 
Hard DriveOSMonitorMonitor
Crucial BX100 1TB Windows 10 Acer XR341CK Stock 14" 1920x1080 IPS 
KeyboardPowerMouseMouse Pad
Logitech G410 Atlas Spectrum Stock Alienware 180W Logitech G700S Roccat MTW 
AudioAudio
Logitech G930 Audio Technica ATH-M50X 
CPUMotherboardGraphicsRAM
I7 3960X Rampage IV Extreme Black Edition MSI R9 390X Gaming 32GB Corsair Vengence 
Hard DriveHard DriveCoolingOS
Crucial MX200 240GB 1TB Crucial BX100 Custom WC Loop Windows 10 
MonitorMonitorKeyboardPower
Acer P243W Acer P243W Logitech G510S Corsair AX850 
CaseMouseMouse PadAudio
None rght now Logitech G500S Roccat Taito MTW Logitech G930 
  hide details  
Reply
   
Cores Galore
(16 items)
 
CPUGraphicsRAMHard Drive
i7-6700HQ GTX 1070 8GB, GPU AMP Waiting for BIG Vega 16GB 2667mhz Alienware Crucial BX100 1TB 
Hard DriveMonitorMonitorKeyboard
Samsung 960 Pro 512GB Acer XR341CK 34" 3440x1440 @ 85hz awesomness Stock 1920x1080 Logitech G410 Atlas Spectrum 
MouseMouse PadAudio
Logitech G700S Roccat Taito Logitech G930 
CPUMotherboardGraphicsHard Drive
i7-4700QM Alienware M14X Nvidia Geforce GTX 765M Samsung Evo 850 mSATA 256 GB 
Hard DriveOSMonitorMonitor
Crucial BX100 1TB Windows 10 Acer XR341CK Stock 14" 1920x1080 IPS 
KeyboardPowerMouseMouse Pad
Logitech G410 Atlas Spectrum Stock Alienware 180W Logitech G700S Roccat MTW 
AudioAudio
Logitech G930 Audio Technica ATH-M50X 
CPUMotherboardGraphicsRAM
I7 3960X Rampage IV Extreme Black Edition MSI R9 390X Gaming 32GB Corsair Vengence 
Hard DriveHard DriveCoolingOS
Crucial MX200 240GB 1TB Crucial BX100 Custom WC Loop Windows 10 
MonitorMonitorKeyboardPower
Acer P243W Acer P243W Logitech G510S Corsair AX850 
CaseMouseMouse PadAudio
None rght now Logitech G500S Roccat Taito MTW Logitech G930 
  hide details  
Reply
post #598 of 1767
Quote:
Originally Posted by SystemTech View Post
Its already there and has been since you suggested it.

Welcoms to :
roxxphatcox
metal_gunjee
Boomer1979
LoneWolf3574
(If i am missing anyone please let me know)



Lol, i never did. bought a new PSU a month before i ordered my board and was complete and absolute grace that my new PSU had a 8pin CPU connector.
im only seeing the x fi utility on the front page :s
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 965 @ 4GHZ Asus Crosshair V Formula NB@ 2.8GHZ VTX 5850 @ 800/1000 Corsair Vengeance LP 8GB 1600 9 9 9 27 1T 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 256GB 000F WD Green 3TB WD30EZRX LG Prolimetech Megahalems + San Ace 
OSMonitorPowerCase
Windows 7 64bit Dell U2312HM Antec CP-850 Antec 1200 
MouseAudio
Razer Salmosa Asus Xonar Xense + PC350 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 965 @ 4GHZ Asus Crosshair V Formula NB@ 2.8GHZ VTX 5850 @ 800/1000 Corsair Vengeance LP 8GB 1600 9 9 9 27 1T 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 256GB 000F WD Green 3TB WD30EZRX LG Prolimetech Megahalems + San Ace 
OSMonitorPowerCase
Windows 7 64bit Dell U2312HM Antec CP-850 Antec 1200 
MouseAudio
Razer Salmosa Asus Xonar Xense + PC350 
  hide details  
Reply
post #599 of 1767
Quote:
Originally Posted by richie_2010 View Post
hi just wondering if anyone could helpme does the motherboard use the 8 pin powert or only the 4 pin, just asking becausethe cover over 4 of the connections
i read some answers and they were wrong, so i'll help you out..
this board has the 8pin power mode, yet you can use it as a 4pin, like i'm doing till you get a newer PSU, you might get lower performance overall, but i'm still very happy with it..
the "other" 4pin is covered with a plastic thingy which also means you dont need the 8pin to make it work..it's only recomended...
Graveyard
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I5 6600K Asus SABERTOOTH Z170 S Intel Z170 Asus GTX1060 Turbo 6GB GDDR5 G.Skill Ripjaws 4 Red DDR4 8GB 2400MHz CAS15 
Hard DriveHard DriveHard DriveCooling
Western Digital Caviar Blue Seagate Barracuda SATAIII 64MB (6GB/S) Samsung Evo 850 SSD 2.5 SATA III Raijintek Triton CORE Watercooling 240mm 
CoolingOSMonitorKeyboard
CoolerMaster SickleFlow Red 2000 RPM Microsoft Windows 10 Profissional 64Bit Panasonic TX-L32E5E Razer Deathstalker Expert 
PowerCaseMouseMouse Pad
Nox Hummer 80 PLUS Bronze 750W NZXT Source 340 - White Logitech G602 Asus GM50 
Other
Logitech F310 Gamepad 
  hide details  
Reply
Graveyard
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core I5 6600K Asus SABERTOOTH Z170 S Intel Z170 Asus GTX1060 Turbo 6GB GDDR5 G.Skill Ripjaws 4 Red DDR4 8GB 2400MHz CAS15 
Hard DriveHard DriveHard DriveCooling
Western Digital Caviar Blue Seagate Barracuda SATAIII 64MB (6GB/S) Samsung Evo 850 SSD 2.5 SATA III Raijintek Triton CORE Watercooling 240mm 
CoolingOSMonitorKeyboard
CoolerMaster SickleFlow Red 2000 RPM Microsoft Windows 10 Profissional 64Bit Panasonic TX-L32E5E Razer Deathstalker Expert 
PowerCaseMouseMouse Pad
Nox Hummer 80 PLUS Bronze 750W NZXT Source 340 - White Logitech G602 Asus GM50 
Other
Logitech F310 Gamepad 
  hide details  
Reply
post #600 of 1767
Quote:
Hello all, new to the forums, have read a lot of good info here, but have a question that I have not been able to find an answer too.

I have an Asus Crosshair III Formula Mobo running the 1403 Bios. I also have 8GB of G.SKILL Ripjaws Series(4 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-4GBRL.

Now to my understanding this is supposed to be running at 1600Mhz. I check the Bios and its running at 1333Mhz.

When I change it to 1600 it will reboot after showing the windows logo, and or give me a BSOD. I tried to up the voltage, and it ran fine just idling for about 10 minutes before a BSOD.

Question is, has any one run into similar problems that can recommend a solution? Cause I feel I may be missing something to get my RAM to run at its advertised 1600Mhz.
This happens because the native speed the board is set to run memory at is 1333 MHZ, it lists 1600 under an (OC) profile. My ram is rated to run at 1600 as well, though after reading around and seeing if the higher speeds were worth it, I opted for tighter timings, I've tested both and I have found that AMD systems generally like tighter ram timings vs Higher speeds, the extra 267 MHZ doesnt really give much of an increase (For me at least) and it was a little harder to get my ram to run at 1600, whereas all I had to do for my timings, was lower them from CL-8 to CL-7, they were already running under-clocked so I had no issues =) Yay for extra clock cycles!
XaphanII
(16 items)
 
   
CPUMotherboardGraphicsRAM
Core i7 4770k Asus Maximus Vi Formula Gigabyte GTX 770 Windforce (Second one coming s...  8Gb G-Skill Trident-X 2400 Mhz 
Hard DriveHard DriveHard DriveCooling
Intel 530 series 120GB SSD. WD Black 1Tb x 2 Seagate barracuda 2Tb Swiftech H220 
OSMonitorKeyboardPower
Windows 7 Home Premium Samsung 32" HD Tv Logitech G11 Corsair HX 750 
CaseMouseMouse PadAudio
Corsair Graphite 600t Razer Deathadder Razer Vespula Logitech Z5500's + integrated home audio. 
CPUMotherboardGraphicsRAM
Phenom II x 4 965 BE @ 3.8 1.42v Crosshair III Formula NB @ 2700 mhz HD 5770 Vapor-x Corsair XMS 3 4GB 1600 MHZ 
Hard DriveOptical DriveCoolingOS
Intel X-25 40 Gig SSD(OS) 2x1TB WD Black in Raid-0 LG Multi Dvd-R Cooler Master V8 Windows 7 Ultimate 
MonitorKeyboardPowerCase
21.5" Samsung 2243SWX + 19" sony CRT dualview Razer Lycosa Corsair TX 750W Cooler Master CM 690 II Advance 
MouseMouse PadAudio
Razer Deathadder Razer Vespula Logitech Z5500 / Steelseries Sibera V2 
  hide details  
Reply
XaphanII
(16 items)
 
   
CPUMotherboardGraphicsRAM
Core i7 4770k Asus Maximus Vi Formula Gigabyte GTX 770 Windforce (Second one coming s...  8Gb G-Skill Trident-X 2400 Mhz 
Hard DriveHard DriveHard DriveCooling
Intel 530 series 120GB SSD. WD Black 1Tb x 2 Seagate barracuda 2Tb Swiftech H220 
OSMonitorKeyboardPower
Windows 7 Home Premium Samsung 32" HD Tv Logitech G11 Corsair HX 750 
CaseMouseMouse PadAudio
Corsair Graphite 600t Razer Deathadder Razer Vespula Logitech Z5500's + integrated home audio. 
CPUMotherboardGraphicsRAM
Phenom II x 4 965 BE @ 3.8 1.42v Crosshair III Formula NB @ 2700 mhz HD 5770 Vapor-x Corsair XMS 3 4GB 1600 MHZ 
Hard DriveOptical DriveCoolingOS
Intel X-25 40 Gig SSD(OS) 2x1TB WD Black in Raid-0 LG Multi Dvd-R Cooler Master V8 Windows 7 Ultimate 
MonitorKeyboardPowerCase
21.5" Samsung 2243SWX + 19" sony CRT dualview Razer Lycosa Corsair TX 750W Cooler Master CM 690 II Advance 
MouseMouse PadAudio
Razer Deathadder Razer Vespula Logitech Z5500 / Steelseries Sibera V2 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › [OFFICIAL] Asus CrossHair III Formula AM3 Club