Overclock.net › Forums › Video Games › PC Gaming › Sanders54's ArmA 2 optimization, how to force SLi/Crossfire and other FPS tweaks
New Posts  All Forums:Forum Nav:

Sanders54's ArmA 2 optimization, how to force SLi/Crossfire and other FPS tweaks - Page 5

post #41 of 103
Quote:
Originally Posted by Sanders54 View Post
Thank you, Pen

Everything up yet?
Yeah it's all up and running; I'm at work at the moment though. I'll do the testing tonight.
post #42 of 103
So I have the game up and running (steam version) using the -winxp -maxmem=2047 -cpuCount=2 -nosplash -window tags on launch properties.

I'm running the cat 9.5's as the 9.6's caused a flicker effect and some insane blur issues and my crossfire is NOT working in the game I have had absolutely zero load on the second card.

Edit: scary enough, once I got rid of the windowed mode crossfire works now! I'm running everything on Very High with no AA and getting about 25-28FPS and that's in 16/4 crossfire with C.G.I running.
Edited by Penicilyn - 7/13/09 at 12:42pm
post #43 of 103
Thread Starter 
Quote:
Originally Posted by Penicilyn View Post
So I have the game up and running (steam version) using the -winxp -maxmem=2047 -cpuCount=2 -nosplash -window tags on launch properties.

I'm running the cat 9.5's as the 9.6's caused a flicker effect and some insane blur issues and my crossfire is NOT working in the game I have had absolutely zero load on the second card.

Edit: scary enough, once I got rid of the windowed mode crossfire works now! I'm running everything on Very High with no AA and getting about 25-28FPS and that's in 16/4 crossfire with C.G.I running.
Nice one, mate!

Yeah, CF doesn't work when in windowed for some wierd reason.
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
post #44 of 103
Using the WHQL 9.7 drivers fixed the crossfire problem for me. Both cores on the 4870X2 are now being used without the need for -winxp.

Driver download links:
[quote]2k/XP x86&x64 drivers download (8.631):
http://www.megaupload.com/?d=L8AIWSOP

Vista/7 x86&x64 (8.630) :
http://www.mediafire.com/?zdyudnzmmyj

Source: http://www.ngohq.com/graphic-cards/1...vista-7-a.html
Edited by MakubeX - 7/20/09 at 4:47am
post #45 of 103
Thread Starter 
Thank you, mate! This is excellent

Updated
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
post #46 of 103
I posted this over at the BI forums. This is a test using ArmaII Mark v1.0. I'm running the 9.7 drivers.

I restarted the game between runs in order to flush the memory. If you run the test back to back, you get a much higher score the second time, ex: 2347 the first time and 2549 the second. There was a lot less steaming in of textures and models the second run. Memory usage by arma2.exe at the end of the first run was 756MB, and 942MB at the end of the second.

Here are the results of the benchmark. The score is average fps x100. 'Max' is all settings as high as possible in the game menu. 'Min' is the lowest settings. When I overclocked to 3.8Ghz, the RAM stayed at 800Mhz. All other tests are at stock CPU and video card speeds.


GPU usage according to Rivatuner during a test run, graphics at max, stock speeds.

Edited by Nuxes - 7/19/09 at 8:14pm
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600k ASUS Z170-PRO ZOTAC GeForce GTX 970 4GB  Kingston HyperX Fury 32GB (2 x 16G) DDR4 2400 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 128GB + Seagate 1TB SATA LG Blu-Ray Corsair H60 Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
24" ASUS VG248QE CM Storm QuickFire TK Corsair CMPSU-850TX 850W Phanteks Enthoo Pro 
MouseAudio
Corsair Vengeance M65 ASUS Xonar U7 
  hide details  
Reply
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600k ASUS Z170-PRO ZOTAC GeForce GTX 970 4GB  Kingston HyperX Fury 32GB (2 x 16G) DDR4 2400 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 128GB + Seagate 1TB SATA LG Blu-Ray Corsair H60 Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
24" ASUS VG248QE CM Storm QuickFire TK Corsair CMPSU-850TX 850W Phanteks Enthoo Pro 
MouseAudio
Corsair Vengeance M65 ASUS Xonar U7 
  hide details  
Reply
post #47 of 103
Nice bench. Changing the view distance shouldn't make a difference since ArmaMark sets it for you on each test.

New link for 9.7 64-bit drivers: http://www.mediafire.com/?zdyudnzmmyj
Edited by MakubeX - 7/20/09 at 4:48am
post #48 of 103
Quote:
Originally Posted by MakubeX View Post
Nice bench. Changing the view distance shouldn't make a difference since ArmaMark sets it for you on each test.

New link for 9.7 64-bit drivers: http://www.mediafire.com/?zdyudnzmmyj
Yep, that's what I used. Are these still the "leaked" drivers? I didn't test on 9.6 but I've heard that it wouldn't use Crossfire or SLI. 9.7 seems to fix this problem, but it still doesn't help very much.
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600k ASUS Z170-PRO ZOTAC GeForce GTX 970 4GB  Kingston HyperX Fury 32GB (2 x 16G) DDR4 2400 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 128GB + Seagate 1TB SATA LG Blu-Ray Corsair H60 Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
24" ASUS VG248QE CM Storm QuickFire TK Corsair CMPSU-850TX 850W Phanteks Enthoo Pro 
MouseAudio
Corsair Vengeance M65 ASUS Xonar U7 
  hide details  
Reply
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600k ASUS Z170-PRO ZOTAC GeForce GTX 970 4GB  Kingston HyperX Fury 32GB (2 x 16G) DDR4 2400 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 128GB + Seagate 1TB SATA LG Blu-Ray Corsair H60 Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
24" ASUS VG248QE CM Storm QuickFire TK Corsair CMPSU-850TX 850W Phanteks Enthoo Pro 
MouseAudio
Corsair Vengeance M65 ASUS Xonar U7 
  hide details  
Reply
post #49 of 103
Quote:
Originally Posted by Nuxes View Post
Yep, that's what I used. Are these still the "leaked" drivers? I didn't test on 9.6 but I've heard that it wouldn't use Crossfire or SLI. 9.7 seems to fix this problem, but it still doesn't help very much.
Yeah, I noticed you were using the 9.7 drivers. I was just re-linking it because the original link was down.

Yes, 9.7 are still leaked. They do offer a bit better performance over 9.6, at least for me. However, ArmA 2's problems lies more on CPU usage.
post #50 of 103
Thread Starter 
Thanks for replies, folks.

Thank you for updated 9.7 link, MakubeX

Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Sanders54's ArmA 2 optimization, how to force SLi/Crossfire and other FPS tweaks