Overclock.net › Forums › Video Games › PC Gaming › Sanders54's ArmA 2 optimization, how to force SLi/Crossfire and other FPS tweaks
New Posts  All Forums:Forum Nav:

Sanders54's ArmA 2 optimization, how to force SLi/Crossfire and other FPS tweaks - Page 6

post #51 of 103
System:
Core i7 920 @ 3.6ghz
Nvidia GTX 280 SLI
Windows 7 RC x64

Things that did not work:
Turn off hyperthreading
Turn off physx
Nvidia profile patch

Things that made slight improvement:
Vsync off (global setting)
Maximum pre-rendered frames 8

Things that solved the problem for me:
EVGA SLI patch for 190 drivers.

Finally the game now runs smooth and is playable

It appears in my case at least that Arma2 does not like SLI systems as it does not seem to know what to do with them.

I can now play the game using very high settings all round and get a framerate of 30 - 40 fps in game. (120+ at menu screen).

Thank you Sanders54 for this great guide

And thank you EVGA for making this amazing game fly!
Edited by ch3ck5um - 7/30/09 at 3:04am
post #52 of 103
The ATI 9.8 beta drivers are out already.
http://www.overclock.net/software-ne...-9-8-beta.html
No performance increases yet.
Edited by Nuxes - 7/31/09 at 12:42am
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600k ASUS Z170-PRO ZOTAC GeForce GTX 970 4GB  Kingston HyperX Fury 32GB (2 x 16G) DDR4 2400 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 128GB + Seagate 1TB SATA LG Blu-Ray Corsair H60 Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
24" ASUS VG248QE CM Storm QuickFire TK Corsair CMPSU-850TX 850W Phanteks Enthoo Pro 
MouseAudio
Corsair Vengeance M65 ASUS Xonar U7 
  hide details  
Reply
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600k ASUS Z170-PRO ZOTAC GeForce GTX 970 4GB  Kingston HyperX Fury 32GB (2 x 16G) DDR4 2400 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 128GB + Seagate 1TB SATA LG Blu-Ray Corsair H60 Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
24" ASUS VG248QE CM Storm QuickFire TK Corsair CMPSU-850TX 850W Phanteks Enthoo Pro 
MouseAudio
Corsair Vengeance M65 ASUS Xonar U7 
  hide details  
Reply
post #53 of 103
Hi chaps, Finally got ARMA2...wow a lot of tweaking is needed. What a stunning game.

Very strange how similar machines with diff O/S's are having such drastic differences in performance.

I am very happy with my FPS and GFX settings...I would love to get them on HIGH like a friend of mine Delta on SGS, who is on a similar rig.....



Delta Quote
Quote:
I have a core2 2.4gb, 2 gb ram and a xfx 8800gts 512 xxx running on XP sp3. game runs fine. no bugs, no hassles at all. not a single issue. currently running it on high settings, except shadows and AA which are both normal, at 1400x900 with 100% texture resolution. the benchie says 31fps

My Settings:

View distance: 1600
Texture Detail: Normal
Video Memory: Normal
Anisotropic Filtering: Low
Antialising: Disabled
Terrain Detail: Normal
Object Detail: Normal
Shadow Detail: High
Postprocess Effects: Disabled

In Nvidia CP:

3 max rendered frames...setting to 8 like some suggested, was laggy.

Forcing V sync off didn't help me at all, made it worse.

Any help would be great, I'm sure my GFX card should out perform a 8800 Gts?
BlackBlitz
(13 items)
 
  
CPUMotherboardGraphicsHard Drive
Q6600 2.4 ASUS P5Q XFX 8800GT XXX Alpha Dog 250 Seagate 
OSMonitorPowerCase
Vista 64 Ultimate 19" CRT Vantec iON2 600W Coolermaster CM690 
Mouse
G5 
  hide details  
Reply
BlackBlitz
(13 items)
 
  
CPUMotherboardGraphicsHard Drive
Q6600 2.4 ASUS P5Q XFX 8800GT XXX Alpha Dog 250 Seagate 
OSMonitorPowerCase
Vista 64 Ultimate 19" CRT Vantec iON2 600W Coolermaster CM690 
Mouse
G5 
  hide details  
Reply
post #54 of 103
anyone with an i7?? and windows 7 got this thing to run smoothly??

ive got an i7@3.8ghz (200 X 19)
gtx 275 Superclocked - no overclock
1920X2000 resolution

any advice would be awesome, i had it running pretty good, until i got into the city of chernagosk, or whatever, and then everything went to ****, at one point my fps dropped to like 8, was getting 25-35 previously

also get some stuttering

i tried updating nvidia, raised rendered frames, turned hyperthreading off.

anyone with an i7 wanna help me out??

this game looks amazing, i wish i could get it to play right! i hope they are working dilligently on a patch to fix these issues
The Beast
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 d0 @ 3.8 ghz Gigabyte EX58-UD4P 2XEVGA GTX 275 SC SLI 6GB OCZ Platinum 1600 7-7-7-24 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 1TB Sumsung Blu-Ray RW Windows 7 Home Premium x64 Dell 23" 1080p S2309W 
KeyboardPowerCaseMouse
Logitech Corsair 750TX HAF 932 Razer Deathadder 
  hide details  
Reply
The Beast
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 d0 @ 3.8 ghz Gigabyte EX58-UD4P 2XEVGA GTX 275 SC SLI 6GB OCZ Platinum 1600 7-7-7-24 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 1TB Sumsung Blu-Ray RW Windows 7 Home Premium x64 Dell 23" 1080p S2309W 
KeyboardPowerCaseMouse
Logitech Corsair 750TX HAF 932 Razer Deathadder 
  hide details  
Reply
post #55 of 103
Quote:
Originally Posted by chronicbucks View Post
anyone with an i7?? and windows 7 got this thing to run smoothly??
Look through this thread on the BI forums. There are some systems similar to yours, and they seem to be getting about the same results.
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600k ASUS Z170-PRO ZOTAC GeForce GTX 970 4GB  Kingston HyperX Fury 32GB (2 x 16G) DDR4 2400 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 128GB + Seagate 1TB SATA LG Blu-Ray Corsair H60 Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
24" ASUS VG248QE CM Storm QuickFire TK Corsair CMPSU-850TX 850W Phanteks Enthoo Pro 
MouseAudio
Corsair Vengeance M65 ASUS Xonar U7 
  hide details  
Reply
Desktop
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 6600k ASUS Z170-PRO ZOTAC GeForce GTX 970 4GB  Kingston HyperX Fury 32GB (2 x 16G) DDR4 2400 
Hard DriveOptical DriveCoolingOS
Samsung 840 Pro 128GB + Seagate 1TB SATA LG Blu-Ray Corsair H60 Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
24" ASUS VG248QE CM Storm QuickFire TK Corsair CMPSU-850TX 850W Phanteks Enthoo Pro 
MouseAudio
Corsair Vengeance M65 ASUS Xonar U7 
  hide details  
Reply
post #56 of 103
Thread Starter 
Quote:
Originally Posted by ch3ck5um View Post
System:
Core i7 920 @ 3.6ghz
Nvidia GTX 280 SLI
Windows 7 RC x64

Things that did not work:
Turn off hyperthreading
Turn off physx
Nvidia profile patch

Things that made slight improvement:
Vsync off (global setting)
Maximum pre-rendered frames 8

Things that solved the problem for me:
EVGA SLI patch for 190 drivers.

Finally the game now runs smooth and is playable

It appears in my case at least that Arma2 does not like SLI systems as it does not seem to know what to do with them.

I can now play the game using very high settings all round and get a framerate of 30 - 40 fps in game. (120+ at menu screen).

Thank you Sanders54 for this great guide

And thank you EVGA for making this amazing game fly!
Thank you

Quote:
Originally Posted by Nuxes View Post
The ATI 9.8 beta drivers are out already.
http://www.overclock.net/software-ne...-9-8-beta.html
No performance increases yet.
Okay, thanks for testing

Quote:
Originally Posted by Vitblitz View Post
Hi chaps, Finally got ARMA2...wow a lot of tweaking is needed. What a stunning game.

Very strange how similar machines with diff O/S's are having such drastic differences in performance.

I am very happy with my FPS and GFX settings...I would love to get them on HIGH like a friend of mine Delta on SGS, who is on a similar rig.....



Delta Quote


My Settings:

View distance: 1600
Texture Detail: Normal
Video Memory: Normal
Anisotropic Filtering: Low
Antialising: Disabled
Terrain Detail: Normal
Object Detail: Normal
Shadow Detail: High
Postprocess Effects: Disabled

In Nvidia CP:

3 max rendered frames...setting to 8 like some suggested, was laggy.

Forcing V sync off didn't help me at all, made it worse.

Any help would be great, I'm sure my GFX card should out perform a 8800 Gts?
Not really, the 8800 GT is not much more powerful than a 8800 GTS(G92)
ArmA 2 tend to run bad on G80 and early G92 cards.

Quote:
Originally Posted by chronicbucks View Post
anyone with an i7?? and windows 7 got his thing to run smoothly??

ive got an i7@3.8ghz (200 X 19)
gtx 275 Superclocked - no overclock
1920X2000 resolution

any advice would be awesome, i had it running pretty good, until i got into the city of chernagosk, or whatever, and then everything went to ****, at one point my fps dropped to like 8, was getting 25-35 previously

also get some stuttering

i tried updating nvidia, raised rendered frames, turned hyperthreading off.

anyone with an i7 wanna help me out??

this game looks amazing, i wish i could get it to play right! i hope they are working dilligently on a patch to fix these issues
I also stutter in large cities before 9.7 drivers, seems it's just too much to load

Quote:
Originally Posted by Nuxes View Post
Look through this thread on the BI forums. There are some systems similar to yours, and they seem to be getting about the same results.
Thank you once more, will add a W7 section soon.

Also, updated OP.

Cheers.
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
post #57 of 103
Patch 1.03 has been released! It might help with some of these issues. Downloading now.

source: http://forums.bistudio.com/showthrea...12#post1393212
Edited by MakubeX - 8/5/09 at 1:41pm
post #58 of 103
I'm still tweaking, but I think I got it down.

I have 940 BE @ 3.6....

was running my SINGLE 4870 at 815 and 825 last night - 1000 and 975 for the memory

Very high for everything I could except post processing which I left low (HATE)

resolution is 1900 by 1200 and distance was 2000 until I bumped it to 3500 (looked way nicer)

anyways.... I thought it was running fine - shot a FRAPS video but didn't have time to upload it - will upload tonight for everyone, and will shoot another and tweak further....

LOVE this game so far... played my first multiplayer game....

give it time - tweak it... do it right..

TWEAK TWEAK TWEAK - when you see it on youtube you'll know why, it looks insane!!
Lazarus
(14 items)
 
  
CPUMotherboardGraphicsGraphics
Ryzen 7 1700 AsRock Killer SLI/ac X370 AM4 XFX RX580 8GB PowerColor RX480 4GB 
RAMHard DriveHard DriveCooling
Team Dark DDR4 8GB 2400 @2933 OCZ/Toshiba SSD 240 GB Seagate Barracuda 2TB Wraith Cooler 
OSMonitorPowerCase
Windows 10 Home x64 Qnix 27'" 2K Rosewill Glacier 850 Watts Rosewill Nighthawk  
MouseMouse Pad
Cliptec Blue Gaming Mouse The X-Files 
  hide details  
Reply
Lazarus
(14 items)
 
  
CPUMotherboardGraphicsGraphics
Ryzen 7 1700 AsRock Killer SLI/ac X370 AM4 XFX RX580 8GB PowerColor RX480 4GB 
RAMHard DriveHard DriveCooling
Team Dark DDR4 8GB 2400 @2933 OCZ/Toshiba SSD 240 GB Seagate Barracuda 2TB Wraith Cooler 
OSMonitorPowerCase
Windows 10 Home x64 Qnix 27'" 2K Rosewill Glacier 850 Watts Rosewill Nighthawk  
MouseMouse Pad
Cliptec Blue Gaming Mouse The X-Files 
  hide details  
Reply
post #59 of 103
Nvm, Server Patch has been released. Link below.
Edited by MakubeX - 8/6/09 at 5:48am
post #60 of 103
Thread Starter 
Guess I won't dl 1.3 yet then.
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
Optimus Prime
(16 items)
 
Server
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel E8200 ASUS 650i EVGA 8800 GTS 512MB 8GB Corsair 
Hard DriveOptical DriveCoolingOS
Assorted HDDs None Stock Server 2008 R2 
MonitorPowerCase
Dell 19" corsair 400w Old OEM case 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Sanders54's ArmA 2 optimization, how to force SLi/Crossfire and other FPS tweaks