Overclock.net › Forums › Graphics Cards › Graphics Cards - General › How To: Unbrick Your Bricked Graphics Card/Fix a Failed BIOS Flash
New Posts  All Forums:Forum Nav:

How To: Unbrick Your Bricked Graphics Card/Fix a Failed BIOS Flash - Page 11

post #101 of 255
Quote:
Originally Posted by Core2uu;15589640 
Let's start with the obvious questions first:
1) Did you plug your 6950's cable into the correct DVI port (after flashing)?
2) Was the flash successful when you used ATiFlash to do it in the Win98 command prompt?
3) Are you using YOUR card's original BIOS (after flashing)?

Hi,

1) I have 2 DVI port and i tried both of them .
2) My flash was successful in the win98 command prompt, it shown me that my old bios was replaced with the new.(I tried to flash again but nothing happened because the new bios was already there)
3) I used my original bios (i made a backup of it) and then i tried another one that i downloaded there : http://www.techpowerup.com/vgabios/92791/Sapphire.HD6950.1024.110105.html

My windows 7 detect that an ati card is plugged

There is some pictures to illustrate what i want to say :

1)My bricked card on second slot :
http://img694.imageshack.us/img694/8785/sam0002i.jpg

2)Both cards plugged :
http://img339.imageshack.us/img339/1358/sam0003q.jpg

3)Cable to GeForce :
http://img43.imageshack.us/img43/8667/sam0004q.jpg

4) Win98 :
http://img11.imageshack.us/img11/6480/sam0006me.jpg
http://img259.imageshack.us/img259/6985/sam0007l.jpg

5)Cable to ATI :
http://img683.imageshack.us/img683/3421/sam0010qx.jpg

6)I tried to plug ATI card in the main slot :
http://img809.imageshack.us/img809/3151/sam0012.jpg
Edited by Seryx - 11/6/11 at 6:59am
post #102 of 255
Thread Starter 
Quote:
Originally Posted by Seryx;15590421 
Hi,

1) I have 2 DVI port and i tried both of them .
2) My flash was successful in the win98 command prompt, it shown me that my old bios was replaced with the new.(I tried to flash again but nothing happened because the new bios was already there)
3) I used my original bios (i made a backup of it) and then i tried another one that i downloaded there : http://www.techpowerup.com/vgabios/92791/Sapphire.HD6950.1024.110105.html

My windows 7 detect that an ati card is plugged

There is some pictures to illustrate what i want to say :

1)My bricked card on second slot :
http://img694.imageshack.us/img694/8785/sam0002i.jpg

2)Both cards plugged :
http://img339.imageshack.us/img339/1358/sam0003q.jpg

3)Cable to GeForce :
http://img43.imageshack.us/img43/8667/sam0004q.jpg

4) Win98 :
http://img11.imageshack.us/img11/6480/sam0006me.jpg
http://img259.imageshack.us/img259/6985/sam0007l.jpg

5)Cable to ATI :
http://img683.imageshack.us/img683/3421/sam0010qx.jpg

6)I tried to plug ATI card in the main slot :
http://img809.imageshack.us/img809/3151/sam0012.jpg

So what happens when you boot up with your 6950? Do you get past POST? Does Windows load? Do you see a display on your monitor at any point?
myTX Prodigy
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-3570 ASUS P8H77-I XFX Radeon HD 7870 Double D GSKILL 8GB DDR3-1600 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 840 250GB Crucial m4 128GB Seagate Barracuda 500GB Western Digital Black 1TB 
Optical DriveOSMonitorKeyboard
ASUS CD/DVD RW 24X Windows 8 Pro x64 ASUS VE247 24" Microsoft Sidewinder X4 
PowerCaseMouseMouse Pad
Corsair TX550M Bitfenix Prodigy Steelseries Kinzu Gigabyte Ghost 
  hide details  
Reply
myTX Prodigy
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-3570 ASUS P8H77-I XFX Radeon HD 7870 Double D GSKILL 8GB DDR3-1600 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 840 250GB Crucial m4 128GB Seagate Barracuda 500GB Western Digital Black 1TB 
Optical DriveOSMonitorKeyboard
ASUS CD/DVD RW 24X Windows 8 Pro x64 ASUS VE247 24" Microsoft Sidewinder X4 
PowerCaseMouseMouse Pad
Corsair TX550M Bitfenix Prodigy Steelseries Kinzu Gigabyte Ghost 
  hide details  
Reply
post #103 of 255
Hi, i fixed the problem by putting my card in another (main) PC. I don't know why but the ATI card doesn't work on my second PC. But whatever, it work properly now !!

Thx a lot for this guide !
post #104 of 255
Hello Core2uu ,

I have a bricked VTX3d HD radeon 6950 2gb , stupidly i overwritten both the bios switches on the card , (which i thought wasn't possible since one of them is supposedly read-only ) . Now , when the 6950 is primary , it doesn't POST .
I tried to follow your steps to the word , i made my onboard graphics card the primary and tried booting with the 6950 as secondary . it shows signs of booting and after i enter my login password , after a few seconds of trying to get into windows , everything turns black and the monitor power button starts blinking like there is no input coming in to it (i connected the monitor to the onboard graphics slot . So , in short , on primary ongoing card with secondary 6950 , it boots till it tries to enter windows 7 .

Anyway , what i'm gonna try next is to just make the bootable USB and try and flash it . Hopefully it will work
any advice would be helpful .
post #105 of 255
Hey , Thanks a lot for the guide . Got it to work , though I haven't tested by playing a game , but the card is detected and POST's as primary . Such a relief . I think I'd just be happier by crossfire than fiddling with the 6970 patch . I was planning to make it 6950 crossfire before , but got greedy with the thought of 6970 crossfire tongue.gif
anyway , thanks again , great guide smile.gif
post #106 of 255
Hi, my english isn't that good, cause i'm from germany, so don't mess up with me too much biggrin.gif

I bricked my XFX HD 6870. I did my own Bios with RBE and flashed it with ATIFLASH. My PC doesn't boot anymore with the HD 6870, so ive used my older Geforce GTS 250 to boot. Both Graphicscard are plugged on a PCIe, but Atiflash did not recognize the HD 6870 ones. It always says "Adapter not found".
post #107 of 255
YES! Thank you so much. I spent hours figuring out how to recover a bricked 6950. When I finally fixed it, it was overwhelmingly nice to know that it worked out in the end.

I sincerely thank you. Really. This should be on the top of google results, but it isn't.

It was such a relief. I didn't know if there was an end solution or not, and I thought there wasn't because I had exhausted some alternatives to the fix. Extremely nice. thumb.gif
Edited by Dottedline - 1/8/12 at 8:47pm
post #108 of 255
i have a sapphire 6950 2GB (dirt 3 edition)
tried to change the bios (from the bios switch) and now windows can't recognize my card
tried ATIflash but it says "adapter not found" using ATIflash 3.89 flashing stock and 6970.
do i need to use earlier version ? like the 3.85 ? but can't find it anywhere ;(

i don't know if this been covered before but been searching the net for the past 4 hours.


Sorry for posting multiple posts, but i really need this fixed ASAP =(


Thanks !
xdragoon
(14 items)
 
  
Reply
xdragoon
(14 items)
 
  
Reply
post #109 of 255

Flip the BIOS switch to #2

 

  1. Boot up computer with BIOS #2.
  2. Switch to BIOS #1 when Win 7 splash screen shows up.
  3. Use RBE to force flash BIOS #2 into BIOS #1.
  4. Reset computer and put BIOS #1.
  5. BIOS #1 is back to original stock.


 

To attemp unlocking shaders;

 

  1. Copy the BIOS #2 ROM.
  2. Use RBE to modify copy of BIOS #2 ROM > unlock to 6970 shaders > save it as "6970.rom".
  3. Flash the modified copied BIOS 2 "6970.rom" to BIOS #1 using "atiflash".
  4. Boot up with switch on BIOS #1.
  5. Check using GPU-Z if the card has extra sharders unlocked.
  6. Done.
     
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #110 of 255
thanks for the reply

i just tried but windows is not detecting my card
xdragoon
(14 items)
 
  
Reply
xdragoon
(14 items)
 
  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Graphics Cards - General
Overclock.net › Forums › Graphics Cards › Graphics Cards - General › How To: Unbrick Your Bricked Graphics Card/Fix a Failed BIOS Flash