Overclock.net › Forums › Components › Sound Cards and Computer Audio › REALLY loud static from AD700's
New Posts  All Forums:Forum Nav:

REALLY loud static from AD700's

post #1 of 17
Thread Starter 
I had my cans plugged into my XtremeGamer sound card. I was installing the drivers and I heard an extremely loud static coming from the headphones from across the room! I hope this didn't blow my headphones. What in the heck caused this? Should I RMA the headphones?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
post #2 of 17
You need to test them with a different source first and see if they work.
Balder
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770k @ 4.4ghz Gigabyte Sniper 3 (z77) EVGA 980ti SC+ ACX 2.0 16GB (2x8) Corsair Vengeance - 1600mhz 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 (512MB) 4 x WD black 1TB LG Blueray Burner Corsair H100 
OSMonitorKeyboardPower
Windows 10 x64 Pro NEC Multisync 3090wqxi (2560x1600) Corsair k90 Corsair AX1200i 
CaseMouseAudioAudio
Corsair 600t white Naos 8200 Sennheiser HD 650 Zero DAC / Onkyo 875 
  hide details  
Reply
Balder
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770k @ 4.4ghz Gigabyte Sniper 3 (z77) EVGA 980ti SC+ ACX 2.0 16GB (2x8) Corsair Vengeance - 1600mhz 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 (512MB) 4 x WD black 1TB LG Blueray Burner Corsair H100 
OSMonitorKeyboardPower
Windows 10 x64 Pro NEC Multisync 3090wqxi (2560x1600) Corsair k90 Corsair AX1200i 
CaseMouseAudioAudio
Corsair 600t white Naos 8200 Sennheiser HD 650 Zero DAC / Onkyo 875 
  hide details  
Reply
post #3 of 17
Thread Starter 
Quote:
Originally Posted by Varjo View Post
You need to test them with a different source first and see if they work.
I am listening to them on my laptop. They work, but I hope they aren't damaged. What do you think?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
post #4 of 17
I think you should uninstall and reinstall all of your audio related drivers. Then test your sound card's headphone port with another set of headphones (any cheap mp3 ones will do).

Headphone or speaker damage doesn't usually cause static quite like you describe.
Balder
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770k @ 4.4ghz Gigabyte Sniper 3 (z77) EVGA 980ti SC+ ACX 2.0 16GB (2x8) Corsair Vengeance - 1600mhz 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 (512MB) 4 x WD black 1TB LG Blueray Burner Corsair H100 
OSMonitorKeyboardPower
Windows 10 x64 Pro NEC Multisync 3090wqxi (2560x1600) Corsair k90 Corsair AX1200i 
CaseMouseAudioAudio
Corsair 600t white Naos 8200 Sennheiser HD 650 Zero DAC / Onkyo 875 
  hide details  
Reply
Balder
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770k @ 4.4ghz Gigabyte Sniper 3 (z77) EVGA 980ti SC+ ACX 2.0 16GB (2x8) Corsair Vengeance - 1600mhz 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 (512MB) 4 x WD black 1TB LG Blueray Burner Corsair H100 
OSMonitorKeyboardPower
Windows 10 x64 Pro NEC Multisync 3090wqxi (2560x1600) Corsair k90 Corsair AX1200i 
CaseMouseAudioAudio
Corsair 600t white Naos 8200 Sennheiser HD 650 Zero DAC / Onkyo 875 
  hide details  
Reply
post #5 of 17
Thread Starter 
Quote:
Originally Posted by Varjo View Post
I think you should uninstall and reinstall all of your audio related drivers. Then test your sound card's headphone port with another set of headphones (any cheap mp3 ones will do).

Headphone or speaker damage doesn't usually cause static quite like you describe.
Good idea. But I'm asking if the static caused damage to my headphones. It was extremely loud. I heard it from across the room!
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
post #6 of 17
I've had some loud sounds shoot out of my A700 due to user error (just like you, sounded like I left my speakers on). So far they have held up amazingly well. That sort of thing blew out my Razer Barracuda's the second day I had them. These headphones never seem to amaze me.

Like others have said, if you can't hear any damage, you're probably fine.
Gunmetal Tower
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600K ASUS P8Z68-V GEN3 Asus GTX 580 CORSAIR Vengeance 16GB 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 256GB Western Digital Caviar Black 640GB LG DVD Corsair H80 
OSMonitorMonitorKeyboard
Microsoft Windows 8.1 Professional 64 Bit Asus PB278Q Dell 1907FPc  Ducky 9008-G2 Browns and Reds 
PowerCaseMouseMouse Pad
ABS SL1050 1050W Antec P280 Logitech G700 Mionix Propus 380 
AudioAudioAudioAudio
HT | OMEGA Claro Halo Audio Technica ATH-A900X Audio Technica ATH-AD900 M-Audio AV 40 
OtherOtherOther
Logitech USB Desktop Microphone APC Back-UPS XS 1500 Wacom Intuos4 
  hide details  
Reply
Gunmetal Tower
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600K ASUS P8Z68-V GEN3 Asus GTX 580 CORSAIR Vengeance 16GB 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 256GB Western Digital Caviar Black 640GB LG DVD Corsair H80 
OSMonitorMonitorKeyboard
Microsoft Windows 8.1 Professional 64 Bit Asus PB278Q Dell 1907FPc  Ducky 9008-G2 Browns and Reds 
PowerCaseMouseMouse Pad
ABS SL1050 1050W Antec P280 Logitech G700 Mionix Propus 380 
AudioAudioAudioAudio
HT | OMEGA Claro Halo Audio Technica ATH-A900X Audio Technica ATH-AD900 M-Audio AV 40 
OtherOtherOther
Logitech USB Desktop Microphone APC Back-UPS XS 1500 Wacom Intuos4 
  hide details  
Reply
post #7 of 17
Thread Starter 
Quote:
Originally Posted by IEATFISH View Post
I've had some loud sounds shoot out of my A700 due to user error (just like you, sounded like I left my speakers on). So far they have held up amazingly well. That sort of thing blew out my Razer Barracuda's the second day I had them. These headphones never seem to amaze me.

Like others have said, if you can't hear any damage, you're probably fine.

Okay, thank you. I have a three year warranty on them anyway.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
post #8 of 17
As for what caused this, I think when installing Creative drivers for their soundcards, it occasionally makes sounds like that. It happened to me before, but it was on my speakers, so it was reallllyyyyyy loud :O

For your headphones, if it still sounds good to you, then it's probably fine
Yuki
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k @ 4.2 Ghz Asus P8P67-M Pro Gigabyte R9 290 16 GB DDR3 1600 Mhz 
Hard DriveHard DriveHard DriveCooling
Samsung 840 EVO Western Digital Blue Hitachi Green Thermalright Venomous X Black 
OSKeyboardPowerCase
Windows 7 Professional 64 bit Novatouch Seasonic X-850 Gold Silverstone ft03 
MouseMouse PadAudio
Razer Deathadder Steelseries 5C Aune T1 
  hide details  
Reply
Yuki
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k @ 4.2 Ghz Asus P8P67-M Pro Gigabyte R9 290 16 GB DDR3 1600 Mhz 
Hard DriveHard DriveHard DriveCooling
Samsung 840 EVO Western Digital Blue Hitachi Green Thermalright Venomous X Black 
OSKeyboardPowerCase
Windows 7 Professional 64 bit Novatouch Seasonic X-850 Gold Silverstone ft03 
MouseMouse PadAudio
Razer Deathadder Steelseries 5C Aune T1 
  hide details  
Reply
post #9 of 17
Static electricity don't damage headphones anyway. They damage computer parts, they damage solid-state amps but not headphones. But of course, I still don't recommend putting in on a carpeted floor etc...
post #10 of 17
Thread Starter 
Every time I plug in the headphones to my sound card I get a ridiculously loud static noise. Can anyone assist me in solving this problem?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i3 530 @ 4.2ghz MSI GD65-P55 Radeon 4890 @ 950/1075 w/ ageia physx card 4GB Gskill DDR3 
Hard DriveMonitorPowerCase
Hitachi Deskstar 1TB Lacie Electron Blue 19" CRT Xion 1000W Coolermaster Storm scout 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › REALLY loud static from AD700's