Overclock.net › Forums › Components › Sound Cards and Computer Audio › Optical out problems with creative x-fi titanium
New Posts  All Forums:Forum Nav:

Optical out problems with creative x-fi titanium

post #1 of 11
Thread Starter 
Hey guys,
I just got my new creative x-fi titanium pcie sound card and I love the sound. The only problem is that I can't get the optical out to work. I have a 5.1 surround sound system and it worked perfectly on my other sound card but I can't hear anything with this one. I am updating my drivers now but I don't think thats the problem since I can hear things perfectly fine through my sennheiser pc151 headphones.

Has anyone else had this problem and if so is there a quick easy solution? Thanks!
Ryzen Build
(14 items)
 
Fiance's Rig
(12 items)
 
 
CPUMotherboardGraphicsRAM
AMD Ryzen 5 1600 @ 3.8ghz ASUS ROG Strix B350-F ASUS ROG Strix RX 580 8GB @ 1480mhz Team T-Force Night Hawk RGB 2x8GB (coming soon) 
Hard DriveHard DriveCoolingOS
SanDisk X400 512GB (custom enclosure) WD Blue 1TB | Raid 1 Deepcool Captain 240 RGB Windows 10 Pro 
MonitorKeyboardPowerCase
ViewSonic XG2701 Turbot Mechanical Keyboard EVGA SuperNova P2 650w NZXT S340 Elite 
MouseMouse Pad
Razer Deathadder Chroma Glorious PC Gaming Race Pad 
CPUMotherboardGraphicsRAM
Intel Core i5 2500K @ 4.6ghz ASRock Z68 Extreme3 Gen3 MSI HD 7850 2GB @ 1ghz Mushkin Ridgeline Series @ 1600mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series Western Digital Caviar Black Cryorig H7 Quad Lumi W/ Xigmatek Purple LED Windows 10 Pro 
MonitorPowerCaseAudio
ViewSonic VX2370SMH-LED Rosewill Capstone 550w BitFenix Neos Window Asus Xonar DG 
  hide details  
Reply
Ryzen Build
(14 items)
 
Fiance's Rig
(12 items)
 
 
CPUMotherboardGraphicsRAM
AMD Ryzen 5 1600 @ 3.8ghz ASUS ROG Strix B350-F ASUS ROG Strix RX 580 8GB @ 1480mhz Team T-Force Night Hawk RGB 2x8GB (coming soon) 
Hard DriveHard DriveCoolingOS
SanDisk X400 512GB (custom enclosure) WD Blue 1TB | Raid 1 Deepcool Captain 240 RGB Windows 10 Pro 
MonitorKeyboardPowerCase
ViewSonic XG2701 Turbot Mechanical Keyboard EVGA SuperNova P2 650w NZXT S340 Elite 
MouseMouse Pad
Razer Deathadder Chroma Glorious PC Gaming Race Pad 
CPUMotherboardGraphicsRAM
Intel Core i5 2500K @ 4.6ghz ASRock Z68 Extreme3 Gen3 MSI HD 7850 2GB @ 1ghz Mushkin Ridgeline Series @ 1600mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series Western Digital Caviar Black Cryorig H7 Quad Lumi W/ Xigmatek Purple LED Windows 10 Pro 
MonitorPowerCaseAudio
ViewSonic VX2370SMH-LED Rosewill Capstone 550w BitFenix Neos Window Asus Xonar DG 
  hide details  
Reply
post #2 of 11
Did you make sure it's not muted in the windows sound control panel?

Ж Prometheus Ж
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7 7700K ROG Maximus IX Hero  EVGA GTX 1080 Ti FE G.Skill TridentZ RGB 
Hard DriveOSMonitorKeyboard
Samsung M2 960 Pro 512, Samsung 840 Pro, 4GB WD... Windows 10 Pro Acer XB271HU Vengeance K95 RGB-MX Red 
PowerCaseMouseMouse Pad
Seasonic SS1000XP Obsidian 800D modified Razer Deathadder Chroma Razer Sphex 
  hide details  
Reply
Ж Prometheus Ж
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7 7700K ROG Maximus IX Hero  EVGA GTX 1080 Ti FE G.Skill TridentZ RGB 
Hard DriveOSMonitorKeyboard
Samsung M2 960 Pro 512, Samsung 840 Pro, 4GB WD... Windows 10 Pro Acer XB271HU Vengeance K95 RGB-MX Red 
PowerCaseMouseMouse Pad
Seasonic SS1000XP Obsidian 800D modified Razer Deathadder Chroma Razer Sphex 
  hide details  
Reply
post #3 of 11
Optical Out supports stereo SPDIF out, multichannel out via Dolby Digital Live, and pass through of multichannel DVD sound
in the window control panel, goto sound and then play back. select your digital output. then properties. under supperted formats make sure dolby digital is checked along with 48 and 96 sample rates. then goto advance, switch the default format to dolby digital live. save and exit. then set up you creative software.
LL
LL
Edited by noobdown - 12/20/09 at 2:47pm
post #4 of 11
On my card (just set up optical a couple days ago) I had to right click the volume icon and go to playback devices and set the SPDIF out as the default device.
Gunmetal Tower
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600K ASUS P8Z68-V GEN3 Asus GTX 580 CORSAIR Vengeance 16GB 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 256GB Western Digital Caviar Black 640GB LG DVD Corsair H80 
OSMonitorMonitorKeyboard
Microsoft Windows 8.1 Professional 64 Bit Asus PB278Q Dell 1907FPc  Ducky 9008-G2 Browns and Reds 
PowerCaseMouseMouse Pad
ABS SL1050 1050W Antec P280 Logitech G700 Mionix Propus 380 
AudioAudioAudioAudio
HT | OMEGA Claro Halo Audio Technica ATH-A900X Audio Technica ATH-AD900 M-Audio AV 40 
OtherOtherOther
Logitech USB Desktop Microphone APC Back-UPS XS 1500 Wacom Intuos4 
  hide details  
Reply
Gunmetal Tower
(23 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600K ASUS P8Z68-V GEN3 Asus GTX 580 CORSAIR Vengeance 16GB 1600 
Hard DriveHard DriveOptical DriveCooling
Samsung 830 256GB Western Digital Caviar Black 640GB LG DVD Corsair H80 
OSMonitorMonitorKeyboard
Microsoft Windows 8.1 Professional 64 Bit Asus PB278Q Dell 1907FPc  Ducky 9008-G2 Browns and Reds 
PowerCaseMouseMouse Pad
ABS SL1050 1050W Antec P280 Logitech G700 Mionix Propus 380 
AudioAudioAudioAudio
HT | OMEGA Claro Halo Audio Technica ATH-A900X Audio Technica ATH-AD900 M-Audio AV 40 
OtherOtherOther
Logitech USB Desktop Microphone APC Back-UPS XS 1500 Wacom Intuos4 
  hide details  
Reply
post #5 of 11
any update?
post #6 of 11
Thread Starter 
Quote:
Originally Posted by noobdown View Post
any update?
This is basically what it says and when I try to turn it on, nothing happens. I tried what you said noobdown, but when I tried to change it to dolby digital, only 2 channels of audio were available.
LL
Ryzen Build
(14 items)
 
Fiance's Rig
(12 items)
 
 
CPUMotherboardGraphicsRAM
AMD Ryzen 5 1600 @ 3.8ghz ASUS ROG Strix B350-F ASUS ROG Strix RX 580 8GB @ 1480mhz Team T-Force Night Hawk RGB 2x8GB (coming soon) 
Hard DriveHard DriveCoolingOS
SanDisk X400 512GB (custom enclosure) WD Blue 1TB | Raid 1 Deepcool Captain 240 RGB Windows 10 Pro 
MonitorKeyboardPowerCase
ViewSonic XG2701 Turbot Mechanical Keyboard EVGA SuperNova P2 650w NZXT S340 Elite 
MouseMouse Pad
Razer Deathadder Chroma Glorious PC Gaming Race Pad 
CPUMotherboardGraphicsRAM
Intel Core i5 2500K @ 4.6ghz ASRock Z68 Extreme3 Gen3 MSI HD 7850 2GB @ 1ghz Mushkin Ridgeline Series @ 1600mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series Western Digital Caviar Black Cryorig H7 Quad Lumi W/ Xigmatek Purple LED Windows 10 Pro 
MonitorPowerCaseAudio
ViewSonic VX2370SMH-LED Rosewill Capstone 550w BitFenix Neos Window Asus Xonar DG 
  hide details  
Reply
Ryzen Build
(14 items)
 
Fiance's Rig
(12 items)
 
 
CPUMotherboardGraphicsRAM
AMD Ryzen 5 1600 @ 3.8ghz ASUS ROG Strix B350-F ASUS ROG Strix RX 580 8GB @ 1480mhz Team T-Force Night Hawk RGB 2x8GB (coming soon) 
Hard DriveHard DriveCoolingOS
SanDisk X400 512GB (custom enclosure) WD Blue 1TB | Raid 1 Deepcool Captain 240 RGB Windows 10 Pro 
MonitorKeyboardPowerCase
ViewSonic XG2701 Turbot Mechanical Keyboard EVGA SuperNova P2 650w NZXT S340 Elite 
MouseMouse Pad
Razer Deathadder Chroma Glorious PC Gaming Race Pad 
CPUMotherboardGraphicsRAM
Intel Core i5 2500K @ 4.6ghz ASRock Z68 Extreme3 Gen3 MSI HD 7850 2GB @ 1ghz Mushkin Ridgeline Series @ 1600mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series Western Digital Caviar Black Cryorig H7 Quad Lumi W/ Xigmatek Purple LED Windows 10 Pro 
MonitorPowerCaseAudio
ViewSonic VX2370SMH-LED Rosewill Capstone 550w BitFenix Neos Window Asus Xonar DG 
  hide details  
Reply
post #7 of 11
Dear Behemoth:

I haunt the Creative Labs forums and somebody there had a problem just like yours. go to start, and run......and there type: services.msc


This will bring up a list of services on your system, and how they run. Automatic, manual or disabled. Go to Creative audio Service, and check its properties and then changed it from manual to automatic, and make sure to start the service. Try your sound again and see if this works for you.....

Cant wait to hear your answer.

jmacguire
post #8 of 11
Thread Starter 
Quote:
Originally Posted by IEATFISH View Post
On my card (just set up optical a couple days ago) I had to right click the volume icon and go to playback devices and set the SPDIF out as the default device.
I just tried that and it worked! Thanks for your all your help guys!
Ryzen Build
(14 items)
 
Fiance's Rig
(12 items)
 
 
CPUMotherboardGraphicsRAM
AMD Ryzen 5 1600 @ 3.8ghz ASUS ROG Strix B350-F ASUS ROG Strix RX 580 8GB @ 1480mhz Team T-Force Night Hawk RGB 2x8GB (coming soon) 
Hard DriveHard DriveCoolingOS
SanDisk X400 512GB (custom enclosure) WD Blue 1TB | Raid 1 Deepcool Captain 240 RGB Windows 10 Pro 
MonitorKeyboardPowerCase
ViewSonic XG2701 Turbot Mechanical Keyboard EVGA SuperNova P2 650w NZXT S340 Elite 
MouseMouse Pad
Razer Deathadder Chroma Glorious PC Gaming Race Pad 
CPUMotherboardGraphicsRAM
Intel Core i5 2500K @ 4.6ghz ASRock Z68 Extreme3 Gen3 MSI HD 7850 2GB @ 1ghz Mushkin Ridgeline Series @ 1600mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series Western Digital Caviar Black Cryorig H7 Quad Lumi W/ Xigmatek Purple LED Windows 10 Pro 
MonitorPowerCaseAudio
ViewSonic VX2370SMH-LED Rosewill Capstone 550w BitFenix Neos Window Asus Xonar DG 
  hide details  
Reply
Ryzen Build
(14 items)
 
Fiance's Rig
(12 items)
 
 
CPUMotherboardGraphicsRAM
AMD Ryzen 5 1600 @ 3.8ghz ASUS ROG Strix B350-F ASUS ROG Strix RX 580 8GB @ 1480mhz Team T-Force Night Hawk RGB 2x8GB (coming soon) 
Hard DriveHard DriveCoolingOS
SanDisk X400 512GB (custom enclosure) WD Blue 1TB | Raid 1 Deepcool Captain 240 RGB Windows 10 Pro 
MonitorKeyboardPowerCase
ViewSonic XG2701 Turbot Mechanical Keyboard EVGA SuperNova P2 650w NZXT S340 Elite 
MouseMouse Pad
Razer Deathadder Chroma Glorious PC Gaming Race Pad 
CPUMotherboardGraphicsRAM
Intel Core i5 2500K @ 4.6ghz ASRock Z68 Extreme3 Gen3 MSI HD 7850 2GB @ 1ghz Mushkin Ridgeline Series @ 1600mhz 
Hard DriveHard DriveCoolingOS
Intel 520 Series Western Digital Caviar Black Cryorig H7 Quad Lumi W/ Xigmatek Purple LED Windows 10 Pro 
MonitorPowerCaseAudio
ViewSonic VX2370SMH-LED Rosewill Capstone 550w BitFenix Neos Window Asus Xonar DG 
  hide details  
Reply
post #9 of 11
i tried the same with services.msc and it was already set up to to automatic and i am still not able to see dolby digital live under default format also just to let you know that i am trying to get dolby digital input from stb via toslink . please help

i hav the following OS- win7 64bit
post #10 of 11
I am now suffering from this same ****.
All was ok before i bought this nvidia 9800GX2 card to watch movies output via HDMI. Now I can still see the red light from the optical cable but no sound output on my digital sound external decoder like it used to
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Optical out problems with creative x-fi titanium