Overclock.net › Forums › Video Games › PC Gaming › Weird BF2 Problem [Game stuck on 15fps]
New Posts  All Forums:Forum Nav:

Weird BF2 Problem [Game stuck on 15fps]

post #1 of 14
Thread Starter 
Ok so I got back into playing BF2....I was playing today for an hour and everything was fine getting like 40-50 fps on the High setting...

Then after that hour the FPS just dropped to 15 and wouldn't go up...I closed the game and re-entered but everything was still lagging...My ping was fine in the server browser...

Restarting fixed the issue, but it arose again in a game I just played.

Anyone know what's wrong?
Hackintosh
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2600k Gigabyte GA-Z68X-UD3H-B3 Gigabyte 770 4gb 16gb Corsair Vengeance 
Hard DriveCoolingOSMonitor
Samsung 840 256gb SSD Hyper 212 x Noctua  Mac OSX 10.8.4 LG Flatron IPS231 x Dell UH2311 
KeyboardPowerCaseMouse
Logitech K750 Mac Corsair TX 650 Enthusiast Fractal Design Define R4 Logitech G700 
Audio
Schiit Modi x KRK RP6G2 x Dayton SUB-1200 
  hide details  
Reply
Hackintosh
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2600k Gigabyte GA-Z68X-UD3H-B3 Gigabyte 770 4gb 16gb Corsair Vengeance 
Hard DriveCoolingOSMonitor
Samsung 840 256gb SSD Hyper 212 x Noctua  Mac OSX 10.8.4 LG Flatron IPS231 x Dell UH2311 
KeyboardPowerCaseMouse
Logitech K750 Mac Corsair TX 650 Enthusiast Fractal Design Define R4 Logitech G700 
Audio
Schiit Modi x KRK RP6G2 x Dayton SUB-1200 
  hide details  
Reply
post #2 of 14
are you using xfire at all?
post #3 of 14
.....sorry double post...stupid internet lagging out on me...i knew i shouldn't have clicked the button twice, lol
post #4 of 14
Thread Starter 
Nope...not running anything but battlefield...
Hackintosh
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2600k Gigabyte GA-Z68X-UD3H-B3 Gigabyte 770 4gb 16gb Corsair Vengeance 
Hard DriveCoolingOSMonitor
Samsung 840 256gb SSD Hyper 212 x Noctua  Mac OSX 10.8.4 LG Flatron IPS231 x Dell UH2311 
KeyboardPowerCaseMouse
Logitech K750 Mac Corsair TX 650 Enthusiast Fractal Design Define R4 Logitech G700 
Audio
Schiit Modi x KRK RP6G2 x Dayton SUB-1200 
  hide details  
Reply
Hackintosh
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2600k Gigabyte GA-Z68X-UD3H-B3 Gigabyte 770 4gb 16gb Corsair Vengeance 
Hard DriveCoolingOSMonitor
Samsung 840 256gb SSD Hyper 212 x Noctua  Mac OSX 10.8.4 LG Flatron IPS231 x Dell UH2311 
KeyboardPowerCaseMouse
Logitech K750 Mac Corsair TX 650 Enthusiast Fractal Design Define R4 Logitech G700 
Audio
Schiit Modi x KRK RP6G2 x Dayton SUB-1200 
  hide details  
Reply
post #5 of 14
hm...nevermind then. the only time i've heard of that issue (and i used to have it) was with early versions of BF2 and the version of Xfire at that time. something about in game messaging would lock the frame rate.

but, since that's not you, i dunno what to tell ya. does it happen no matter what graphics settings you have on BF2? also, do you have the latest drivers from nVidia?
post #6 of 14
Is your video card overheating and slowing itself down? That would be why you had to restart to reset it? Have you recently adjusted you video card settings (oc it or something)?
My System
(13 items)
 
System 2
(12 items)
 
 
CPUMotherboardGraphicsRAM
X2 4400 ASUS A8NE XFX 7900GT Extreme OCZ DDR 500 
Hard DriveOSMonitorKeyboard
300GB + 2, 160GB drives XP Pro HP LCD Z-Board 
PowerCaseMouseMouse Pad
SilverStone ST75ZF (750 watt) Aspire X-plorer MS Laser 6000 Aqua 3 
CPUMotherboardGraphicsRAM
C2D 6400 ASUS P5B Gigabyte Radeon HD 6770 OCZ Value DDR2 PC 4200 
OSMonitorPowerCase
Win 7 17" CRT SilverStone ST75ZF (750 watt) Aspire X-plorer 
Mouse
MS 
  hide details  
Reply
My System
(13 items)
 
System 2
(12 items)
 
 
CPUMotherboardGraphicsRAM
X2 4400 ASUS A8NE XFX 7900GT Extreme OCZ DDR 500 
Hard DriveOSMonitorKeyboard
300GB + 2, 160GB drives XP Pro HP LCD Z-Board 
PowerCaseMouseMouse Pad
SilverStone ST75ZF (750 watt) Aspire X-plorer MS Laser 6000 Aqua 3 
CPUMotherboardGraphicsRAM
C2D 6400 ASUS P5B Gigabyte Radeon HD 6770 OCZ Value DDR2 PC 4200 
OSMonitorPowerCase
Win 7 17" CRT SilverStone ST75ZF (750 watt) Aspire X-plorer 
Mouse
MS 
  hide details  
Reply
post #7 of 14
Thread Starter 
Quote:
Originally Posted by sleepy127
Is your video card overheating and slowing itself down? That would be why you had to restart to reset it? Have you recently adjusted you video card settings (oc it or something)?
There's no overclock to my graphics card and I doubt its over heating (my three tornados are keeping everything really cold)

Also, after the framerate locks, I've run CSS video stress test and Aquamark3 and they've run fine...(Actually AM3 gave me what I believe is a low score, 44400+)...

Any other ideas?
Hackintosh
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2600k Gigabyte GA-Z68X-UD3H-B3 Gigabyte 770 4gb 16gb Corsair Vengeance 
Hard DriveCoolingOSMonitor
Samsung 840 256gb SSD Hyper 212 x Noctua  Mac OSX 10.8.4 LG Flatron IPS231 x Dell UH2311 
KeyboardPowerCaseMouse
Logitech K750 Mac Corsair TX 650 Enthusiast Fractal Design Define R4 Logitech G700 
Audio
Schiit Modi x KRK RP6G2 x Dayton SUB-1200 
  hide details  
Reply
Hackintosh
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2600k Gigabyte GA-Z68X-UD3H-B3 Gigabyte 770 4gb 16gb Corsair Vengeance 
Hard DriveCoolingOSMonitor
Samsung 840 256gb SSD Hyper 212 x Noctua  Mac OSX 10.8.4 LG Flatron IPS231 x Dell UH2311 
KeyboardPowerCaseMouse
Logitech K750 Mac Corsair TX 650 Enthusiast Fractal Design Define R4 Logitech G700 
Audio
Schiit Modi x KRK RP6G2 x Dayton SUB-1200 
  hide details  
Reply
post #8 of 14
Ok, I used to have this exact problem. I had high fps and then the patch had come out and wham! No matter what settings, I would max out at 15fps. I found a bunch of other people online who had the same exact problem and we posted together on EA's forums. Of course, one of us came up with an answer before them. Mcafee was the problem. Strange, but true. I uninstalled Mcafee and the stupid game worked. I still think that was an idiotic mistake to have an error with Mcafee when it's a major program that a lot of people use. Uninstalled and everything worked fine along with about 30 other people. GG EA..

If you don't have Mcafee, let me know, but that sounds like the exact problem I had.
2nd Personal PC
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 2.4ghz abit IP35 Pro 8800GTS 512mb 8gb G.Skill DDR2 800 
Hard DriveOSMonitorKeyboard
2x150gb Raptor X's Vista x64 24" Samsung LCD Logitech Elite Keyboard 
PowerCaseMouseMouse Pad
700W OCZ GameXStream Thermaltake Armor Logitech G9 Laser Func Pad 
  hide details  
Reply
2nd Personal PC
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 2.4ghz abit IP35 Pro 8800GTS 512mb 8gb G.Skill DDR2 800 
Hard DriveOSMonitorKeyboard
2x150gb Raptor X's Vista x64 24" Samsung LCD Logitech Elite Keyboard 
PowerCaseMouseMouse Pad
700W OCZ GameXStream Thermaltake Armor Logitech G9 Laser Func Pad 
  hide details  
Reply
post #9 of 14
Thread Starter 
Quote:
Originally Posted by JoMaMaz
Ok, I used to have this exact problem. I had high fps and then the patch had come out and wham! No matter what settings, I would max out at 15fps. I found a bunch of other people online who had the same exact problem and we posted together on EA's forums. Of course, one of us came up with an answer before them. Mcafee was the problem. Strange, but true. I uninstalled Mcafee and the stupid game worked. I still think that was an idiotic mistake to have an error with Mcafee when it's a major program that a lot of people use. Uninstalled and everything worked fine along with about 30 other people. GG EA..

If you don't have Mcafee, let me know, but that sounds like the exact problem I had.
No McAfee, I got Zone Alarm....could it still be that?
Hackintosh
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2600k Gigabyte GA-Z68X-UD3H-B3 Gigabyte 770 4gb 16gb Corsair Vengeance 
Hard DriveCoolingOSMonitor
Samsung 840 256gb SSD Hyper 212 x Noctua  Mac OSX 10.8.4 LG Flatron IPS231 x Dell UH2311 
KeyboardPowerCaseMouse
Logitech K750 Mac Corsair TX 650 Enthusiast Fractal Design Define R4 Logitech G700 
Audio
Schiit Modi x KRK RP6G2 x Dayton SUB-1200 
  hide details  
Reply
Hackintosh
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2600k Gigabyte GA-Z68X-UD3H-B3 Gigabyte 770 4gb 16gb Corsair Vengeance 
Hard DriveCoolingOSMonitor
Samsung 840 256gb SSD Hyper 212 x Noctua  Mac OSX 10.8.4 LG Flatron IPS231 x Dell UH2311 
KeyboardPowerCaseMouse
Logitech K750 Mac Corsair TX 650 Enthusiast Fractal Design Define R4 Logitech G700 
Audio
Schiit Modi x KRK RP6G2 x Dayton SUB-1200 
  hide details  
Reply
post #10 of 14
I wouldn't think so. Have you tried posting at the EA forums?
2nd Personal PC
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 2.4ghz abit IP35 Pro 8800GTS 512mb 8gb G.Skill DDR2 800 
Hard DriveOSMonitorKeyboard
2x150gb Raptor X's Vista x64 24" Samsung LCD Logitech Elite Keyboard 
PowerCaseMouseMouse Pad
700W OCZ GameXStream Thermaltake Armor Logitech G9 Laser Func Pad 
  hide details  
Reply
2nd Personal PC
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 2.4ghz abit IP35 Pro 8800GTS 512mb 8gb G.Skill DDR2 800 
Hard DriveOSMonitorKeyboard
2x150gb Raptor X's Vista x64 24" Samsung LCD Logitech Elite Keyboard 
PowerCaseMouseMouse Pad
700W OCZ GameXStream Thermaltake Armor Logitech G9 Laser Func Pad 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Weird BF2 Problem [Game stuck on 15fps]