Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Cannot connect two Ubuntu computers to eachother, but can connect to windows
New Posts  All Forums:Forum Nav:

Cannot connect two Ubuntu computers to eachother, but can connect to windows

post #1 of 33
Thread Starter 
Here's the problem, my home network consists of multiple computers, and operating systems. The majority of which is Windows (I'm the only one who gets Linux). I have two servers on my network, one running Windows Home Server for backups, the other is a home build. The home built server consists of 1ghz processor, 160gb ide storage, 20gb ide os, 384mb of ram, and is running Ubuntu 8.04.1 Desktop edition. (Old i know, but it gets the job done). It is a general media server consisting of mp3's and few videos. I have samba set up on it, so that way i can share the folders, and map them as network drives on each of my Windows computers. I do this by connecting through the servers ip address of [192.168.1.103]. As long as i don't have a power failure or surge, the server stays on 24/7, and gets connected to by a remote computer on average 15 times a day, but nobody is ever actually connected to the machine it self.

So here's the problem, i recently got my old Dell Dimension 2350 (spec linked to my account), and decided to make a media server out of it, so i installed Ubuntu 8.04.1 (9.10 wasn't stable enough), and i will install the Myth TV application into the os next weekend, when i get my tuner card in. Well, anyways, i tried to connect my media "server" to it, via ssh in terminal (command: ssh zaccaglin@192.168.1.103), with no luck, the server keeps denying me access, i followed this How to, with the same problem, what is it I'm doing wrong? After installing ssh, should have i restarted? (I'm going to try a restart after updates finish). Is there another way to connect to the server? Thanks for the help.
post #2 of 33
Did you edit /etc/hosts.allow and add this to it? (using vi, nano, whatever)
sshd: 192.168.1.

You don't have to restart your server after installing, but you need to start the daemon and the daemon will need to start on boot.

If sshd is running then you should just need to add the sshd to hosts.allow and try to connect again.
Edited by binormalkilla - 1/31/10 at 8:59pm
PWNzershreck
(15 items)
 
  
CPUMotherboardGraphicsRAM
4930K @ 4.6 GHz ASUS Rampage IV Black Edition Trifire 290X 16 GB Corsair Vengeance 1600C9 
Hard DriveOptical DriveCoolingOS
2x Samsung 840 Pro  ASUS DVD-RW SATA Koolance 380i & 2x HW Labs 480GTX Arch Linux x86_64, Windows 7 x64 
MonitorKeyboardPowerCase
3x ASUS VS278Q Eyefinity Ducky Corsair AX1200i Caselabs STH10 
MouseMouse PadAudio
Logitech G500 Func 1030 ASUS Xonar Essence STX 
  hide details  
Reply
PWNzershreck
(15 items)
 
  
CPUMotherboardGraphicsRAM
4930K @ 4.6 GHz ASUS Rampage IV Black Edition Trifire 290X 16 GB Corsair Vengeance 1600C9 
Hard DriveOptical DriveCoolingOS
2x Samsung 840 Pro  ASUS DVD-RW SATA Koolance 380i & 2x HW Labs 480GTX Arch Linux x86_64, Windows 7 x64 
MonitorKeyboardPowerCase
3x ASUS VS278Q Eyefinity Ducky Corsair AX1200i Caselabs STH10 
MouseMouse PadAudio
Logitech G500 Func 1030 ASUS Xonar Essence STX 
  hide details  
Reply
post #3 of 33
Make sure iptables (firewall) is not interfering with the connection.
    
CPUMotherboardGraphicsGraphics
Intel Core i5-3450 ASRock Z77E-ITX Intel HD Graphics 2500 Powercolor Radeon 7870 GHz Edition 
RAMHard DriveOptical DriveOS
Crucial Ballistix Sport 2x4GB DDR3-1600 Crucial m4 256GB LG GH22NS90 Windows 7 Ultimate 64-bit SP1 
MonitorMonitorKeyboardPower
Samsung 2494SW HP Pavilion 27xi Das Model S Professional Silent Silverstone SST-ST45SF 
CaseMouseAudio
Silverstone SG06 Logitech MX518 Realtek ALC898 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i5-3450 ASRock Z77E-ITX Intel HD Graphics 2500 Powercolor Radeon 7870 GHz Edition 
RAMHard DriveOptical DriveOS
Crucial Ballistix Sport 2x4GB DDR3-1600 Crucial m4 256GB LG GH22NS90 Windows 7 Ultimate 64-bit SP1 
MonitorMonitorKeyboardPower
Samsung 2494SW HP Pavilion 27xi Das Model S Professional Silent Silverstone SST-ST45SF 
CaseMouseAudio
Silverstone SG06 Logitech MX518 Realtek ALC898 
  hide details  
Reply
post #4 of 33
Thread Starter 
Quote:
Originally Posted by binormalkilla View Post
Did you edit /etc/hosts.allow and add this to it? (using vi, nano, whatever)
sshd: 192.168.1.

You don't have to restart your server after installing, but you need to start the daemon and the daemon will need to start on boot.

If sshd is running then you should just need to add the sshd to hosts.allow and try to connect again.
Can you elaborate some more on this?
post #5 of 33
Well in order for clients to connect to your server via ssh you need to add your local subnet (in your case everyone on 192.168.1.) to your /etc/hosts.allow.
THis line:
sshd: 192.168.1.
will allow anyone on:
192.168.1.1-255
to connect to the server, provided they can authenticate with a user/password.

Provided you have sshd running (the daemon part of openssh, clients don't need the daemon running) then you should be able to connect.

You're getting a 'connection refused' message right, not a 'no route to host' message, right?

As far as where Ubuntu needs you to add sshd to auto-start on boot I'm not sure on that.......probably something like /etc/rc.local. I'm not very familiar with Ubuntu.

Looks like this might be it in Ubuntu...it probably adds it to .bashrc or something:
Quote:
I would not recommend putting things into /etc/init.d unless they are required for system-wide usage. If it's just your preference to have something run, such as an export command, you should first try running it as a "startup program" for your session. Off the main menu: System > Preferences > Sessions. Click Startup Programs, Add, type your line, and click OK.
From Ubuntu Forums
Edited by binormalkilla - 1/31/10 at 10:01pm
PWNzershreck
(15 items)
 
  
CPUMotherboardGraphicsRAM
4930K @ 4.6 GHz ASUS Rampage IV Black Edition Trifire 290X 16 GB Corsair Vengeance 1600C9 
Hard DriveOptical DriveCoolingOS
2x Samsung 840 Pro  ASUS DVD-RW SATA Koolance 380i & 2x HW Labs 480GTX Arch Linux x86_64, Windows 7 x64 
MonitorKeyboardPowerCase
3x ASUS VS278Q Eyefinity Ducky Corsair AX1200i Caselabs STH10 
MouseMouse PadAudio
Logitech G500 Func 1030 ASUS Xonar Essence STX 
  hide details  
Reply
PWNzershreck
(15 items)
 
  
CPUMotherboardGraphicsRAM
4930K @ 4.6 GHz ASUS Rampage IV Black Edition Trifire 290X 16 GB Corsair Vengeance 1600C9 
Hard DriveOptical DriveCoolingOS
2x Samsung 840 Pro  ASUS DVD-RW SATA Koolance 380i & 2x HW Labs 480GTX Arch Linux x86_64, Windows 7 x64 
MonitorKeyboardPowerCase
3x ASUS VS278Q Eyefinity Ducky Corsair AX1200i Caselabs STH10 
MouseMouse PadAudio
Logitech G500 Func 1030 ASUS Xonar Essence STX 
  hide details  
Reply
post #6 of 33
Thread Starter 
Also, can anyone give me step by step directions on how to give the ubuntu server a static ip address, so that every time the server gets kicked off the network, i don't have to redo all my network drives on the windows computers? This pc does not need to connect to the internet at all, i just need to be able to access it from other computers via its ip address. Do i need a router to do this?
post #7 of 33
Thread Starter 
Quote:
Originally Posted by binormalkilla View Post
Well in order for clients to connect to your server via ssh you need to add your local subnet (in your case everyone on 192.168.1.) to your /etc/hosts.allow.
THis line:
sshd: 192.168.1.
will allow anyone on:
192.168.1.1-255
to connect to the server, provided they can authenticate with a user/password.

Provided you have sshd running (the daemon part of openssh, clients don't need the daemon running) then you should be able to connect.

You're getting a 'connection refused' message right, not a 'no route to host' message, right?

As far as where Ubuntu needs you to add sshd to auto-start on boot I'm not sure on that.......probably something like /etc/rc.local. I'm not very familiar with Ubuntu.
yes, im getting Connection refused.
post #8 of 33
Quote:
Originally Posted by zaccaglin View Post
yes, im getting Connection refused.
I'm putting my money on that line being missing from /etc/hosts.allow. Do this:

open terminal
cat /etc/hosts.allow
post the output here


As far as the static IP...... Ubuntu uses network manager, and you should be able to enter the settings in the network manager tray icon. You should be able to select 'static IP' instead of DHCP client and set it to:
IP: 192.168.1.whatever
Subnet: 255.255.255.0
Gateway: 192.168.0.1
Plus whatever DNS server you use.

Here is a guide using system config files in the terminal.
http://www.ubuntugeek.com/change-ubu...p-address.html
PWNzershreck
(15 items)
 
  
CPUMotherboardGraphicsRAM
4930K @ 4.6 GHz ASUS Rampage IV Black Edition Trifire 290X 16 GB Corsair Vengeance 1600C9 
Hard DriveOptical DriveCoolingOS
2x Samsung 840 Pro  ASUS DVD-RW SATA Koolance 380i & 2x HW Labs 480GTX Arch Linux x86_64, Windows 7 x64 
MonitorKeyboardPowerCase
3x ASUS VS278Q Eyefinity Ducky Corsair AX1200i Caselabs STH10 
MouseMouse PadAudio
Logitech G500 Func 1030 ASUS Xonar Essence STX 
  hide details  
Reply
PWNzershreck
(15 items)
 
  
CPUMotherboardGraphicsRAM
4930K @ 4.6 GHz ASUS Rampage IV Black Edition Trifire 290X 16 GB Corsair Vengeance 1600C9 
Hard DriveOptical DriveCoolingOS
2x Samsung 840 Pro  ASUS DVD-RW SATA Koolance 380i & 2x HW Labs 480GTX Arch Linux x86_64, Windows 7 x64 
MonitorKeyboardPowerCase
3x ASUS VS278Q Eyefinity Ducky Corsair AX1200i Caselabs STH10 
MouseMouse PadAudio
Logitech G500 Func 1030 ASUS Xonar Essence STX 
  hide details  
Reply
post #9 of 33
Thread Starter 
Quote:
Originally Posted by binormalkilla View Post
I'm putting my money on that line being missing from /etc/hosts.allow. Do this:

open terminal
cat /etc/hosts.allow
post the output here


As far as the static IP...... Ubuntu uses network manager, and you should be able to enter the settings in the network manager tray icon. You should be able to select 'static IP' instead of DHCP client and set it to:
IP: 192.168.1.whatever
Subnet: 255.255.255.0
Gateway: 192.168.0.1
Plus whatever DNS server you use.

Here is a guide using system config files in the terminal.
http://www.ubuntugeek.com/change-ubu...p-address.html


File attached
post #10 of 33
Thread Starter 
Quote:
Originally Posted by binormalkilla View Post
I'm putting my money on that line being missing from /etc/hosts.allow. Do this:

open terminal
cat /etc/hosts.allow
post the output here


As far as the static IP...... Ubuntu uses network manager, and you should be able to enter the settings in the network manager tray icon. You should be able to select 'static IP' instead of DHCP client and set it to:
IP: 192.168.1.whatever
Subnet: 255.255.255.0
Gateway: 192.168.0.1
Plus whatever DNS server you use.

Here is a guide using system config files in the terminal.
http://www.ubuntugeek.com/change-ubu...p-address.html
I don't think I'm using a dns server, how can i check?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Cannot connect two Ubuntu computers to eachother, but can connect to windows