Overclock.net › Forums › Overclockers Care › Overclock.net Folding@Home Team › Some 4870x2 folding questions
New Posts  All Forums:Forum Nav:

Some 4870x2 folding questions

post #1 of 18
Thread Starter 
So I'm trying to get my 4870x2 folding correctly.

First question: is it normal for a GPU client to take a CPU too? I'm running two GPU clients atm, both GPU cores are under full load, but both fahcore_11.exe processes are taking 25% full CPU load, i.e. taking a full core each.

Second question: When folding starts on both cores, one ramps up to 790/970/1.250v as it's supposed to whereas the first GPU seems to sit at 2D mode (507/503/1.062v).

Any suggestions?

I've used the flags "-gpu 0" and "-gpu 1" for the clients and the machine IDs are set to 2 & 3 respectively.

Thanks for any advice you can offer
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
post #2 of 18
It should not use the CPU that much. Last time i folded with my 4870s it was about 10-15% CPU usage.
Ishimura
(21 items)
 
Silent Knight
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.6GHz ASRock Z77E-ITX eVGA GTX 1080 Ti Hybrid AVEXIR Blitz 1.1 16GB DDR3-2400MHz CL10 
Hard DriveHard DriveCoolingCooling
SanDisk Ultra II 960GB Toshiba X300 5TB Corsair H100i GTX eVGA Hybrid Water Cooler  
CoolingOSMonitorKeyboard
4x GentleTyphoon AP-15 Windows 10 Pro 64-Bit LG OLED55C7P  Razer BlackWidow Chroma  
PowerCaseMouseMouse Pad
eVGA SuperNOVA 750 G3 Define Nano S Logitech G502 Proteus Core PECHAM Gaming Mouse Pad XX-Large 
AudioAudioAudioAudio
Audioengine D1 DAC Mackie CR Series CR3 Audio-Technica ATH-M50 Sennheiser HD 598 
Audio
Sony XB950BT 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 @ 4.2GHz ASUS M4A79XTD EVO AMD Radeon HD 7970 3GB @ 1200/1500 2x 4GB G.SKILL Ripjaws X DDR3-1600 
Hard DriveHard DriveHard DriveCooling
OCZ Agility 3 60GB WD Caviar Green 1.5TB 2 x Seagate Barracuda 2TB XSPC Raystorm 
CoolingCoolingOSPower
EK-FC7970 XSPC RS360 Windows 10 Pro 64-Bit Corsair TX750 
Case
NZXT Switch 810  
  hide details  
Reply
Ishimura
(21 items)
 
Silent Knight
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.6GHz ASRock Z77E-ITX eVGA GTX 1080 Ti Hybrid AVEXIR Blitz 1.1 16GB DDR3-2400MHz CL10 
Hard DriveHard DriveCoolingCooling
SanDisk Ultra II 960GB Toshiba X300 5TB Corsair H100i GTX eVGA Hybrid Water Cooler  
CoolingOSMonitorKeyboard
4x GentleTyphoon AP-15 Windows 10 Pro 64-Bit LG OLED55C7P  Razer BlackWidow Chroma  
PowerCaseMouseMouse Pad
eVGA SuperNOVA 750 G3 Define Nano S Logitech G502 Proteus Core PECHAM Gaming Mouse Pad XX-Large 
AudioAudioAudioAudio
Audioengine D1 DAC Mackie CR Series CR3 Audio-Technica ATH-M50 Sennheiser HD 598 
Audio
Sony XB950BT 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 @ 4.2GHz ASUS M4A79XTD EVO AMD Radeon HD 7970 3GB @ 1200/1500 2x 4GB G.SKILL Ripjaws X DDR3-1600 
Hard DriveHard DriveHard DriveCooling
OCZ Agility 3 60GB WD Caviar Green 1.5TB 2 x Seagate Barracuda 2TB XSPC Raystorm 
CoolingCoolingOSPower
EK-FC7970 XSPC RS360 Windows 10 Pro 64-Bit Corsair TX750 
Case
NZXT Switch 810  
  hide details  
Reply
post #3 of 18
 
Sharpie
(18 items)
 
CPUMotherboardGraphicsRAM
i7 950 4GHz 1.28v ASUS Rampage III Formula ASUS 5870 2GB Eyefinity 6 G.Skill RipJaws 6GB (3x2GB) 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series GT 240GB SSD 300GB VelociRaptor Western Digital 640GB AAKS Samsung F3 1TB 
Optical DriveOSMonitorMonitor
2x Sony Optiarc - 24X DVD Windows 7 Ultimate x64 Samsung 24" P2450 Samsung 24" P2450 
MonitorKeyboardPowerCase
Dell 1905 - 19" Das Keyboard Pro Model M Corsair 1000HX HAF X 
MouseMouse Pad
Logitech G5 X TRAC Pads Ripper XXL 
  hide details  
Reply
 
Sharpie
(18 items)
 
CPUMotherboardGraphicsRAM
i7 950 4GHz 1.28v ASUS Rampage III Formula ASUS 5870 2GB Eyefinity 6 G.Skill RipJaws 6GB (3x2GB) 
Hard DriveHard DriveHard DriveHard Drive
Corsair Force Series GT 240GB SSD 300GB VelociRaptor Western Digital 640GB AAKS Samsung F3 1TB 
Optical DriveOSMonitorMonitor
2x Sony Optiarc - 24X DVD Windows 7 Ultimate x64 Samsung 24" P2450 Samsung 24" P2450 
MonitorKeyboardPowerCase
Dell 1905 - 19" Das Keyboard Pro Model M Corsair 1000HX HAF X 
MouseMouse Pad
Logitech G5 X TRAC Pads Ripper XXL 
  hide details  
Reply
post #4 of 18
Environment variables, must have tweaks for ATI folders.

^^ HAHA never knew Jeevus had that thread.
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
Mighty-iTX
(12 items)
 
One foot in..
(17 items)
 
mATX
(12 items)
 
CPUMotherboardGraphicsRAM
i7-4770K M7-Impact Strix GTX980 Samsung 
Hard DriveCoolingOSMonitor
Crucial M4 256 Glacer 240L W8.1 K272HUL 
KeyboardPowerCaseMouse
Saitek Seasonic X-650 Prodigy MX518 
CPUMotherboardGraphicsGraphics
4770K/45/43 Maximus VI Extreme R290X R290X 
RAMHard DriveHard DriveOptical Drive
Samsung Crucial M4 64GB RAIDR LSSWM 
CoolingOSMonitorKeyboard
Cooler Master Glacer 7 Ultimate 64 SyncMaster Eclipse 
PowerCaseMouseMouse Pad
XFX 1050 BE 600T Silver MX518 Desk 
CPUMotherboardGraphicsRAM
i5-4330 Z87 Gryphon GTX690 G.Skill RipJawsX 
Hard DriveCoolingOSMonitor
WD Blacks Hyper 212 W8.1 ACER 
KeyboardPowerCaseMouse
Logitech Ultra X3 1000w Corsair 230T Orange Razer 
  hide details  
Reply
post #5 of 18
Thread Starter 
Thanks guys, I'll check that out now.

Also any ideas on how to force GPU0 to 3D mode? For some reason it's sitting at 2D (confirmed with GPU-Z & Afterburner)
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
post #6 of 18
Thread Starter 
The environment variable changes worked a treat, thanks.

Still stuck on my previous problem though.

Currently the two shortcuts I have setup are as follows:

Code:
"C:\\Program Files (x86)\\Folding@home\\Folding@home-gpu\\Folding@home.exe" -gpu 0
Code:
"C:\\Program Files (x86)\\Folding@home 2\\Folding@home-gpu\\Folding@home.exe" -gpu 1 -forcegpu ati_r700
I added the "-forcegpu ati_r700" flag after reading the other 4870x2 thread going atm, but the problem remained unchanged.

First client is set to machine ID 2, second is set to ID 3.

For the sake of clarity let's assume my cores are GPU1 & GPU2

When I launch client one, GPU1 ramps up to 3D and starts working as expected.
When I launch client two, GPU2 sits at 2D mode and hits full loads as it should.

This is where things get trickier:
If I just launch client two on its own, GPU1 ramps up tp 3D with no load, but GPU2 starts working in 2D mode still.

I've tried duplicating the folder in AppData\\Roaming, but I'm not sure what to name it so it actually gets used by the second client. I've had it named "Folding@home-gpu 2" so far.

Help would be greatly appreciated
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
post #7 of 18
Quote:
Originally Posted by Threefeet View Post
The environment variable changes worked a treat, thanks.

Still stuck on my previous problem though.

Currently the two shortcuts I have setup are as follows:

Code:
"C:\\Program Files (x86)\\Folding@home\\Folding@home-gpu\\Folding@home.exe" -gpu 0
Code:
"C:\\Program Files (x86)\\Folding@home 2\\Folding@home-gpu\\Folding@home.exe" -gpu 1 -forcegpu ati_r700
I added the "-forcegpu ati_r700" flag after reading the other 4870x2 thread going atm, but the problem remained unchanged.

First client is set to machine ID 2, second is set to ID 3.

For the sake of clarity let's assume my cores are GPU1 & GPU2

When I launch client one, GPU1 ramps up to 3D and starts working as expected.
When I launch client two, GPU2 sits at 2D mode and hits full loads as it should.

This is where things get trickier:
If I just launch client two on its own, GPU1 ramps up tp 3D with no load, but GPU2 starts working in 2D mode still.

I've tried duplicating the folder in AppData\\Roaming, but I'm not sure what to name it so it actually gets used by the second client. I've had it named "Folding@home-gpu 2" so far.

Help would be greatly appreciated
The name in AppData> Roaming should be the same as the install location name, so that's fine.

It could be a driver issue; I know the newer nVidia drivers cause cards to downclock at times, until you change the option to Maximum Performance. Is there an option like that in CCC?

If not, I'd say a driver reinstall, followed by clients reinstall if that doesn't work.
Megadoomer
(14 items)
 
Family Computer
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T @ 4.0Ghz ASUS M4A89GTD PRO Sparkle GTS 450 2x4GB G-Skill Sniper 
Hard DriveCoolingOSMonitor
Samsung F1 1TB CM Hyper 212+ Windows 7 Professional x64 Samsung T220 
KeyboardPowerCaseMouse
Logitech MX3000 Laser CM 1000M HAF 922 Logitech VX Revolution 
CPUMotherboardGraphicsRAM
Q6600 Asus PN5-D 750i Evga GTS 250 2x2GB Crucial Ballistix 
Hard DriveOptical DriveOSMonitor
750GB Hitachi Samsung Super Writemaster Windows 7 Professional x64 19" Dell 
PowerCase
Corsair 450VX Antec 900 
  hide details  
Reply
Megadoomer
(14 items)
 
Family Computer
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T @ 4.0Ghz ASUS M4A89GTD PRO Sparkle GTS 450 2x4GB G-Skill Sniper 
Hard DriveCoolingOSMonitor
Samsung F1 1TB CM Hyper 212+ Windows 7 Professional x64 Samsung T220 
KeyboardPowerCaseMouse
Logitech MX3000 Laser CM 1000M HAF 922 Logitech VX Revolution 
CPUMotherboardGraphicsRAM
Q6600 Asus PN5-D 750i Evga GTS 250 2x2GB Crucial Ballistix 
Hard DriveOptical DriveOSMonitor
750GB Hitachi Samsung Super Writemaster Windows 7 Professional x64 19" Dell 
PowerCase
Corsair 450VX Antec 900 
  hide details  
Reply
post #8 of 18
Thread Starter 
Quote:
Originally Posted by zodac View Post
It could be a driver issue; I know the newer nVidia drivers cause cards to downclock at times, until you change the option to Maximum Performance. Is there an option like that in CCC?
No option like that in CCC that I'm aware of.

Quote:
Originally Posted by zodac View Post
If not, I'd say a driver reinstall, followed by clients reinstall if that doesn't work.
I cleanly removed my 10.2 drivers & F@H (including both Program Files folders & the Appdata\\Roaming folders). I've been using MSI Afterburner for custom fan settings and overclocking so just in case there was a clash somewhere I cleanly removed it too.

After re-installing my drivers and F@H the issue remains the same. I set it up again exactly as I detailed above.

I don't have any more time to spend on this tonight so I'll just leave it as is.

I'm going to re-install Afterburner as I won't be able to relax in the pub tonight with GPU0 sitting at 85c lol.

Thanks for the help, let's hope we can get to the bottom of this soon

+rep
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
post #9 of 18
The Environmental Variables work great for folding and keeping cpu usage down but have a negative impact on gaming, at least for me. I noticed terrible stuttering while playing Crysis and BC2 after adding the variables(I shut down all folding when gaming, so it is not that). I pinpointed it to the "FLUSH_INTERVAL" variable specifically. I remove the variable and the stuttering goes away, add it back and it returns...completely reproduceable.

I tried a variety of different settings for the Flush Interval but could never get one that had no impact on the stuttering while keeping folding cpu usage down, so I just removed it. I encourage others to test this as well, like to know if it is only me or a widespread thing.
post #10 of 18
Thread Starter 
Hmm thanks for the heads-up, I'll run a few tests tomorrow if I'm not too hungover

I wonder is it possible to add/remove the FLUSH_INTERVAL variable via registry or something similar?

More to look into tomorrow I guess
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
Eos
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3570k Asus Maximus V Gene MSI GTX 680 16GB Corsair Vengeance LP 1600MHz 
Hard DriveOptical DriveCoolingOS
RAID 0 1TB DVD-R Corsair H100i Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
30" 2560*1600 Corsair K60 Corsair TX850 Silverstone Temjin TJ08-E 
Mouse
Logitech G5 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Overclock.net Folding@Home Team
Overclock.net › Forums › Overclockers Care › Overclock.net Folding@Home Team › Some 4870x2 folding questions