Overclock.net › Forums › Components › Memory › As if I haven't already had enough problems w/ Corsair!
New Posts  All Forums:Forum Nav:

As if I haven't already had enough problems w/ Corsair!

post #1 of 8
Thread Starter 
OK, so as some of you know I haven't had the greatest of all experiences with Corsair in the past, but I thought everything was past me... but oh no! I was dead wrong.

Just a bit of history for those who don't know my story.

I bought some Corsair XMS 3200C2PT when I build my rig in May. The first pair I got would not run a 1T command rate to save their lives. Being it was my first build and I was learning as I went I did not catch this in time to send them back to newegg so I had to RMA them to Corsair a few months later.

Corsair screwed up and shipped my RAM back to me via ground instead of 3 day like they promised... which while annoying and frustrating, I can live w/ it. But then when I got the new RAM... it ran a 1T command rate as it was supposed to, but it died less than 24 hours after I got it. It just literally stopped working. When I turned my rig on the fans would spin, but that's all. There would be no POST or error codes. I finally figured out it was the RAM when I drove an hour to a friends house and put my RAM in his computer and his in mine... mine booted right up and his had the same symptoms as mine.

So I contacted Corsair again and told them what happened... they apologized and paid shipping both ways for the 2nd RMA. At this point I was fed up and ordered my OCZ Platinum rev. 2.

I got the 3rd pair back and they worked just like they were supposed to. I ran them in my rig for a couple weeks just to make sure... then I gave them to my bro to put in his rig. They've been running in his rig for about 3 weeks.

But Corsair gave me a newer revision and I wanted to know what IC's Corsair used in the new RAM so I posted on Corsair's forum. The RAM Guy refused to answer my post and had Corsair's lab rat delete all my posts... Yeah, that really made me mad. This was a few months ago now and I have yet to find out what IC's Corsair used... their customer service is absolute crap, and the words I want to use for the RAM Guy... just aren't really appropriate for anyone...

But then last night when I built this new rig I took my old RAM back to stick in my new rig. It's the same mobo that this RAM worked in earlier.
here is the system I put them in:
Asus A8N-SLI Deluxe
3200+ venice
MSI 6600GT
seagate 160gb SATA II hd
SB LIVE!
DVD-RW
FSP 450w psu.

So when I got the rig all together and went to boot it up, the fans spun but that's it... I'm like oh no! what'd I do? so I reseated the RAM and made sure all the power connections were good... that didn't work, I tried 1 stick of RAM and that didn't work. then I dug out a stick of 512mb Corsair value RAM I had laying around stuck it in and the system booted right up!

So, now this set of RAM is doing the same thing the last pair did! I'm about to go crazy. Like, I just don't want anything to do w/ Corsair, but I'm going to have to RMA this pair too... so that's what 3 RMA's? this is rediculous!
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
post #2 of 8
Thread Starter 
well I posed on the RAM Guy forums... used the same tread as before when I had to RMA this RAM 2x before...

At this point I don't want another pair... I wonder if Corsair will give me a refund... that'd be nice!

The RAM Guy just tried to blame my psu or my cpu for damaging my RAM! the nerve!
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
post #3 of 8
Thread Starter 
well I'm really at a loss now... I put the RAM in my DFI board and it booted up so I memtested it (just default settings of 3-3-3-8 2T) and it passed... so I put it back in my Asus board, it booted and I set the timings to 2-3-3-6 1T and the RAM passed memtest once more.

I'm confused... why just last night would the RAM not work at all? It wouldn't even allow the computer to post... even w/ only 1 stick. This is the most finicky RAM I've ever experienced!
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
post #4 of 8
I had Corsair value ram, aaaaah i wish i never bought them and wasted my money on it. I ended selling them for like less than a half of their price, they r crap . OCZ treats me betta lol.
yeah yeah...
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8400 GIGABYTE GA-EP45-UD3P Gigabyte 4890 Mushkin XP2-8000 Xtreme Performance Redline DDR2 S 
Hard DriveOSMonitorKeyboard
500 GB Western Digital Cavier black. Windows 7 x64 SAMSUNG HDTV LCD 46" lycosa 
PowerCaseMouse
Corsair TX750w Cooler Master CM690 Val Gear 
  hide details  
Reply
yeah yeah...
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8400 GIGABYTE GA-EP45-UD3P Gigabyte 4890 Mushkin XP2-8000 Xtreme Performance Redline DDR2 S 
Hard DriveOSMonitorKeyboard
500 GB Western Digital Cavier black. Windows 7 x64 SAMSUNG HDTV LCD 46" lycosa 
PowerCaseMouse
Corsair TX750w Cooler Master CM690 Val Gear 
  hide details  
Reply
post #5 of 8
My Corsair Value RAM works pretty well....But I think its the cause of me not being able to OC much more. Which I understand considering how cheap it was.
Black Beast
(13 items)
 
  
CPUMotherboardGraphicsRAM
SB 2500k @ 4.2ghz MSI P67A-GD65 EVGA GTX580 1.5GB 8 GB G.Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
Vertex 2 SSD DVD-RW Windows 7 X64 Dell U2410 & Apple Cinema 23" 
KeyboardPowerCaseMouse
Razer Lycosa Corsair TX750 Antec 902 Razer Deathadder 
Mouse Pad
Xtrac XL 
  hide details  
Reply
Black Beast
(13 items)
 
  
CPUMotherboardGraphicsRAM
SB 2500k @ 4.2ghz MSI P67A-GD65 EVGA GTX580 1.5GB 8 GB G.Skill Ripjaws 
Hard DriveOptical DriveOSMonitor
Vertex 2 SSD DVD-RW Windows 7 X64 Dell U2410 & Apple Cinema 23" 
KeyboardPowerCaseMouse
Razer Lycosa Corsair TX750 Antec 902 Razer Deathadder 
Mouse Pad
Xtrac XL 
  hide details  
Reply
post #6 of 8
Been using Corsair for a while now in two different rigs. A pair of XL's that were in this machine went bad after about 6 months just as I started to overclock it. Go figure. The others had no problems.

RMA'ed the pair, since then no problems. I actually got pretty good C-Service. I'm sure there is a horror story for every product out there.
Microwave Mojo
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 4690K @ 4.5ghz Gigabyte Z97X-UD3H Sapphire R9 280 Dual X 8GB DDR3 Kingston @ 1866 
Hard DriveOSMonitorPower
256GB Crucial SSD Windows 8.1 x64 24" Corsair TX650W 
  hide details  
Reply
Microwave Mojo
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 4690K @ 4.5ghz Gigabyte Z97X-UD3H Sapphire R9 280 Dual X 8GB DDR3 Kingston @ 1866 
Hard DriveOSMonitorPower
256GB Crucial SSD Windows 8.1 x64 24" Corsair TX650W 
  hide details  
Reply
post #7 of 8
Sad story indeed...
I've never tried what I feel is an over priced product for there high end stuff!
BTW... I believe they are leaving the high end segment and probaly don't put the time and effort into the high end stuff anymore.
    
CPUMotherboardGraphicsRAM
X4 965 ASUS M4A79 Deluxe 9800GTx2 2x2G OCZ Reapers 
Hard DriveOptical DriveOSMonitor
500G WD Black LiteOn CD/DVD R/W Win7 64 22'' ws Acer AL2223W 
KeyboardPowerMouse
MS KU462 Natural SS DA750 MS 5 button 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
X4 965 ASUS M4A79 Deluxe 9800GTx2 2x2G OCZ Reapers 
Hard DriveOptical DriveOSMonitor
500G WD Black LiteOn CD/DVD R/W Win7 64 22'' ws Acer AL2223W 
KeyboardPowerMouse
MS KU462 Natural SS DA750 MS 5 button 
  hide details  
Reply
post #8 of 8
Thread Starter 
yeah, I heard they are getting out of the high end business too. I just don't understand what's going wrong w/ this RAM. I thought memory was supposed to basically either work or not work... or at least that's what Corsair keeps telling me.

But why would RAM just stop working, give me the symptoms that it does... and give the same symptoms in other computers... and it is only this model number. Corsair XMS 3200C2. I've never had problems w/ other RAM. And Corsair tries to tell me that it's the processor, psu or the bios settings?
well it's not the psu... each time it has happened I have been using different psus.
it's not the cpu... I sent it in to AMD and they tested it... passed w/ flying colors
it's not the bios settings... when I've had problems they have been both w/ the spd timings of 3-3-3-8 2T and the specified timings of 2-3-3-6 1T with both voltage on auto or 2.75 which is exactly what it is supposed to be.
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Memory
Overclock.net › Forums › Components › Memory › As if I haven't already had enough problems w/ Corsair!