post #11 of 11
Quote:
Originally Posted by hometoast View Post

zero'ing the entire drive fixed it. So it was just a matter of zeroing the right part. I tried the logical places before. beginnging and end of disk and partition -- I wonder if I got the skip/seek arguments wrong on it.

Hometoast - just a quick post to thank you for this. I had exactly the same problem, arising from almost (but not quite) following the Ubuntu-published instructions to install Ubuntu Server 11.10 (Oneiric Ocelot) to a software RAID1 array. Exactly as you described, I had a phantom partition that would not go away, no matter what I did in fdisk or anything.

I booted into recovery mode from a memory stick, then ran:
Code:
dd if=/dev/zero of=dev/sda bs=1M
dd if=/dev/zero of=dev/sdb bs=1M

And lo! The partition was gone! Currently installing Ubuntu Server on the drives in a nice tidy RAID mirror.

(time passes)

Aaaand this time the installer correctly installed GRUB to /dev/sda /dev/sdb (instead of last time, when it went to /dev/md0 and failed miserably). Working perfectly, huzzah!!

Thanks again, hope this post helps others in the future.