Overclock.net › Forums › Components › Sound Cards and Computer Audio › X-fi Titanium W7 Installation driver issue, help!
New Posts  All Forums:Forum Nav:

X-fi Titanium W7 Installation driver issue, help!

post #1 of 15
Thread Starter 
"Setup has found a newer version of Audio Drivers on your system"

That is the message I get AFTER I uninstalled my x-fi gamer,restarted PC, run driver cleaner pro, restart. I downloaded from Creative website and get the message. I uninstalled and repeat what I did above and installed Daniel_K drivers with the same issue.

How can I install my drivers? Yes I know creative has sucky drivers but Daniel_K fixed my gamer but this just doesn't work!

Note: All the app. software with Daniel_k or from Creative website sad unable to find the card. I put it in the PCI-X1 slot on my mobo. I can still listen to music.

Audio driver keeps saying Microsoft but what it should say is X-fi, just posting as I find new info.
Edited by Nick911 - 5/3/10 at 8:25pm
Níðhöggr
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920(C0) 3.8 (HT)(1.25Volts) GIGABYTE GA-X58A-UD3R gtx670 G.Skill PIE 
Hard DriveOSMonitorKeyboard
Hitachi deskstar 1TB with Corsair force gt 124GB Windows 7 x64 Yamakasi Catleap g15 
PowerCaseMouseMouse Pad
Kingwin STR-500 Hexacosio (custom made case) g5 Cyber Snipa 
Audio
Onkyo TX-SR805 
  hide details  
Reply
Níðhöggr
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920(C0) 3.8 (HT)(1.25Volts) GIGABYTE GA-X58A-UD3R gtx670 G.Skill PIE 
Hard DriveOSMonitorKeyboard
Hitachi deskstar 1TB with Corsair force gt 124GB Windows 7 x64 Yamakasi Catleap g15 
PowerCaseMouseMouse Pad
Kingwin STR-500 Hexacosio (custom made case) g5 Cyber Snipa 
Audio
Onkyo TX-SR805 
  hide details  
Reply
post #2 of 15
Quote:
Originally Posted by Nick911 View Post
"Setup has found a newer version of Audio Drivers on your system"

That is the message I get AFTER I uninstalled my x-fi gamer,restarted PC, run driver cleaner pro, restart. I downloaded from Creative website and get the message. I uninstalled and repeat what I did above and installed Daniel_K drivers with the same issue.

How can I install my drivers? Yes I know creative has sucky drivers but Daniel_K fixed my gamer but this just doesn't work!

Note: All the app. software with Daniel_k or from Creative website sad unable to find the card. I put it in the PCI-X1 slot on my mobo. I can still listen to music.

Audio driver keeps saying Microsoft but what it should say is X-fi, just posting as I find new info.
I am a bit forgetful, so I have a question: when it says that a newer version is found, does it still provide the option to install anyway?

Either way, here's what I recommend doing (none of the following means that I didn't read your post):
  1. Install Driver Sweeper
  2. Uninstall everything related to Creative using the Programs and Features control panel
  3. Reboot into Safe Mode (hold F8 right before Windows usually begins loading)
  4. Open Driver Sweeper (it is in the Phyxion.net Start Menu programs folder)
  5. Select "Creative - Sound"
  6. Click "Clean"
  7. Repeat
  8. Close Driver Sweeper
  9. Reboot normally (so, go back to what I guess can be called "Normal Mode" in Windows)
  10. Install Daniel_K's X-Fi Support Pack 2.0
  11. If it says a newer version was found, then ignore it and make sure you install everything in Daniel_K's pack anyway (that is, if you are given the option to install everything anyway)
  12. Reboot after everything is installed (do not reboot until the entire Support Pack is installed)
  13. Check to see if the driver now says that it was provided by Creative as opposed to Microsoft
  14. If not, then we will keep troubleshooting.
If you follow this absolutely verbatim (follow it perfectly without straying from it one bit) and if it doesn't work, then I think that not all is lost since you're in good hands here on Overclock.net.
Edited by TwoCables - 5/3/10 at 10:40pm
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #3 of 15
Download latest driver, extract the package using 7-zip or WinRAR, navigate to Drivers\\SBXF

Here you have to run setup.exe and select Uninstall and Delete all shared files below. After you're done, restart and after that use Driver Sweeper to clean anything left behind.
Install desired drivers again.

Much simpler, nothing else to install,
Cheers,
Jerry Macguire
post #4 of 15
Thread Starter 
thanks people but after 3 hours( you posted a bit later) I got it to work. I had creative sound bank folder left in my creative witch caused the issue to not recognize the card even though it was there.

Remember all who look at this for creative drivers. REMOVE EVERY LIVING SCRAP of Creative! All registry's all folder! Run Ccleaner and reboot, install, good to go!

Thanks again Cables, your post is exact for what you need to do but me, I can't wait and force myself to spend 3 hours straight to fix it ^_^
Níðhöggr
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920(C0) 3.8 (HT)(1.25Volts) GIGABYTE GA-X58A-UD3R gtx670 G.Skill PIE 
Hard DriveOSMonitorKeyboard
Hitachi deskstar 1TB with Corsair force gt 124GB Windows 7 x64 Yamakasi Catleap g15 
PowerCaseMouseMouse Pad
Kingwin STR-500 Hexacosio (custom made case) g5 Cyber Snipa 
Audio
Onkyo TX-SR805 
  hide details  
Reply
Níðhöggr
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920(C0) 3.8 (HT)(1.25Volts) GIGABYTE GA-X58A-UD3R gtx670 G.Skill PIE 
Hard DriveOSMonitorKeyboard
Hitachi deskstar 1TB with Corsair force gt 124GB Windows 7 x64 Yamakasi Catleap g15 
PowerCaseMouseMouse Pad
Kingwin STR-500 Hexacosio (custom made case) g5 Cyber Snipa 
Audio
Onkyo TX-SR805 
  hide details  
Reply
post #5 of 15
Quote:
Originally Posted by Nick911 View Post
thanks people but after 3 hours( you posted a bit later) I got it to work. I had creative sound bank folder left in my creative witch caused the issue to not recognize the card even though it was there.

Remember all who look at this for creative drivers. REMOVE EVERY LIVING SCRAP of Creative! All registry's all folder! Run Ccleaner and reboot, install, good to go!

Thanks again Cables, your post is exact for what you need to do but me, I can't wait and force myself to spend 3 hours straight to fix it ^_^
The instructions I posted would only take 5-15 minutes to complete, depending on the person. At the extreme most, maybe a half an hour; but that's at the extreme most!
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #6 of 15
Thread Starter 
Yes I did this without your help or anyone. I solved it on my own and took that long. New what I was doing, take me under 5 minutes.
Níðhöggr
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920(C0) 3.8 (HT)(1.25Volts) GIGABYTE GA-X58A-UD3R gtx670 G.Skill PIE 
Hard DriveOSMonitorKeyboard
Hitachi deskstar 1TB with Corsair force gt 124GB Windows 7 x64 Yamakasi Catleap g15 
PowerCaseMouseMouse Pad
Kingwin STR-500 Hexacosio (custom made case) g5 Cyber Snipa 
Audio
Onkyo TX-SR805 
  hide details  
Reply
Níðhöggr
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920(C0) 3.8 (HT)(1.25Volts) GIGABYTE GA-X58A-UD3R gtx670 G.Skill PIE 
Hard DriveOSMonitorKeyboard
Hitachi deskstar 1TB with Corsair force gt 124GB Windows 7 x64 Yamakasi Catleap g15 
PowerCaseMouseMouse Pad
Kingwin STR-500 Hexacosio (custom made case) g5 Cyber Snipa 
Audio
Onkyo TX-SR805 
  hide details  
Reply
post #7 of 15
Quote:
Originally Posted by Nick911 View Post
Yes I did this without your help or anyone. I solved it on my own and took that long. New what I was doing, take me under 5 minutes.
When you said, "but me, I can't wait and force myself to spend 3 hours straight to fix it ^_^", I thought you were saying that what I recommended would probably take like 3 hours.
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #8 of 15
Thread Starter 
sorry about my English and your right, that didn't say what I wanted it to say. Yes I spent 3 hours fixing my card to finally realize your solution was posted shortly after I fixed it and your info was spot on.
Níðhöggr
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920(C0) 3.8 (HT)(1.25Volts) GIGABYTE GA-X58A-UD3R gtx670 G.Skill PIE 
Hard DriveOSMonitorKeyboard
Hitachi deskstar 1TB with Corsair force gt 124GB Windows 7 x64 Yamakasi Catleap g15 
PowerCaseMouseMouse Pad
Kingwin STR-500 Hexacosio (custom made case) g5 Cyber Snipa 
Audio
Onkyo TX-SR805 
  hide details  
Reply
Níðhöggr
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920(C0) 3.8 (HT)(1.25Volts) GIGABYTE GA-X58A-UD3R gtx670 G.Skill PIE 
Hard DriveOSMonitorKeyboard
Hitachi deskstar 1TB with Corsair force gt 124GB Windows 7 x64 Yamakasi Catleap g15 
PowerCaseMouseMouse Pad
Kingwin STR-500 Hexacosio (custom made case) g5 Cyber Snipa 
Audio
Onkyo TX-SR805 
  hide details  
Reply
post #9 of 15
Quote:
Originally Posted by Nick911 View Post
sorry about my English and your right, that didn't say what I wanted it to say. Yes I spent 3 hours fixing my card to finally realize your solution was posted shortly after I fixed it and your info was spot on.
Doh! I've had that happen to me so many times. But I'm glad that it's fixed!
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #10 of 15
Here's the deal, Windows 7 has this issue when you have Creative Labs Audio and ATI video cards.
ATI video, and Creative cards cannot seem to exist peacefully in Windows 7. I have found this out on several machines. Thus why I have a Xonar DX.

I discovered I had to reinstall my Creative X-Fi drivers everytime my ATI video drivers got updated, because after an ATI update my sound would disappear, and it would only show that my S/PDIF connection was enabled.

I saw many different posts on the interwebs that had similar issues.

You may have it fixed for now, but when the new ATI drivers come out, I hope your sound stays on.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › X-fi Titanium W7 Installation driver issue, help!