Overclock.net › Forums › General Hardware › General Processor Discussions › Increasing my data I/O performance...
New Posts  All Forums:Forum Nav:

Increasing my data I/O performance...

post #1 of 4
Thread Starter 
well, the title says it all...i currently have a single WD caviar blue 500 GB drive...and i have noticed that when it comes to reading and writing a lot of data my computer starts to freak out!

what do you suggest?
    
CPUMotherboardGraphicsRAM
|Intel Core i7 860 at 4.0GHz HT on 1.31V| |Asus P7P55D Pro| |GTX 260 OC, GTS 250 OC (Folding 24/7)| |4GB Corsair xms3 at 1458 MHz, 8-8-8-20| 
Hard DriveOSMonitorPower
|WD 500GB Blue SATA, WD 500GB Black SATA| |Windows 7 Premium (64-bit)| |Asus 24" at 1920x1080, HP 19" at 1440x900| |Corsiar TX850W| 
CaseMouseMouse Pad
|Cooler Master 690 II Advanced| |Razer Naga| |Razer Goliathus Standard| 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
|Intel Core i7 860 at 4.0GHz HT on 1.31V| |Asus P7P55D Pro| |GTX 260 OC, GTS 250 OC (Folding 24/7)| |4GB Corsair xms3 at 1458 MHz, 8-8-8-20| 
Hard DriveOSMonitorPower
|WD 500GB Blue SATA, WD 500GB Black SATA| |Windows 7 Premium (64-bit)| |Asus 24" at 1920x1080, HP 19" at 1440x900| |Corsiar TX850W| 
CaseMouseMouse Pad
|Cooler Master 690 II Advanced| |Razer Naga| |Razer Goliathus Standard| 
  hide details  
Reply
post #2 of 4
I would try some of these steps for better performance:

-Disabling power saving features like Speedstep/C1E in BIOS. These seem to effect the SATA controller as well.

-Make sure your SATA controller is set to AHCI in BIOS. Although if it wasnt, you may Bluescreen on the next reboot. Set it back and perform this fix first: http://support.microsoft.com/kb/922976.

-Disable Windows File indexing on that drive. (Right Click C:, Properties,
General)

-Disable Scheduled Defrag. Remove the possibility that windows is defragging the drive at poorly chosen times. Just remember to manually defrag periodicly.

-'Turn Off Windows Write Cache Buffer Flushing'. This one has a small amount of risk of data loss associated with it, do some research. The setting is in Device Manager, Hard Drive Properties, Policies.
Spit in God's Eye
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-5960x @ 4.26 ghz core / 3.53 ghz uncore - 1.... AsRock X99 Extreme3 EVGA GTX980 Ti 16gb (4x4gb) Crucial DDR4 2133 CL15  
Hard DriveHard DriveHard DriveOptical Drive
A-Data SP600 256gb SSD (C:) Samsung 840 EVO 1TB SSD (D:) Seagate 2TB Hybrid Drive (E:) LITE-ON 24x DVDRW 
CoolingOSMonitorKeyboard
Corsair H110 Win 10 x64 HP 2511x ( 25" 1080p ) AZIO L70 
PowerCaseMouseAudio
Corsair TX750 Antec 300 (Modded) Logitech M100 Onboard 
  hide details  
Reply
Spit in God's Eye
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-5960x @ 4.26 ghz core / 3.53 ghz uncore - 1.... AsRock X99 Extreme3 EVGA GTX980 Ti 16gb (4x4gb) Crucial DDR4 2133 CL15  
Hard DriveHard DriveHard DriveOptical Drive
A-Data SP600 256gb SSD (C:) Samsung 840 EVO 1TB SSD (D:) Seagate 2TB Hybrid Drive (E:) LITE-ON 24x DVDRW 
CoolingOSMonitorKeyboard
Corsair H110 Win 10 x64 HP 2511x ( 25" 1080p ) AZIO L70 
PowerCaseMouseAudio
Corsair TX750 Antec 300 (Modded) Logitech M100 Onboard 
  hide details  
Reply
post #3 of 4
Thread Starter 
Quote:
Originally Posted by BinaryDemon View Post
I would try some of these steps for better performance:

-Disabling power saving features like Speedstep/C1E in BIOS. These seem to effect the SATA controller as well.

-Make sure your SATA controller is set to AHCI in BIOS. Although if it wasnt, you may Bluescreen on the next reboot. Set it back and perform this fix first: http://support.microsoft.com/kb/922976.

-Disable Windows File indexing on that drive. (Right Click C:, Properties,
General)

-Disable Scheduled Defrag. Remove the possibility that windows is defragging the drive at poorly chosen times. Just remember to manually defrag periodicly.

-'Turn Off Windows Write Cache Buffer Flushing'. This one has a small amount of risk of data loss associated with it, do some research. The setting is in Device Manager, Hard Drive Properties, Policies.
Thanks! I was expecting to be told to buy another hard drive for my os and such then another for storage...haha
    
CPUMotherboardGraphicsRAM
|Intel Core i7 860 at 4.0GHz HT on 1.31V| |Asus P7P55D Pro| |GTX 260 OC, GTS 250 OC (Folding 24/7)| |4GB Corsair xms3 at 1458 MHz, 8-8-8-20| 
Hard DriveOSMonitorPower
|WD 500GB Blue SATA, WD 500GB Black SATA| |Windows 7 Premium (64-bit)| |Asus 24" at 1920x1080, HP 19" at 1440x900| |Corsiar TX850W| 
CaseMouseMouse Pad
|Cooler Master 690 II Advanced| |Razer Naga| |Razer Goliathus Standard| 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
|Intel Core i7 860 at 4.0GHz HT on 1.31V| |Asus P7P55D Pro| |GTX 260 OC, GTS 250 OC (Folding 24/7)| |4GB Corsair xms3 at 1458 MHz, 8-8-8-20| 
Hard DriveOSMonitorPower
|WD 500GB Blue SATA, WD 500GB Black SATA| |Windows 7 Premium (64-bit)| |Asus 24" at 1920x1080, HP 19" at 1440x900| |Corsiar TX850W| 
CaseMouseMouse Pad
|Cooler Master 690 II Advanced| |Razer Naga| |Razer Goliathus Standard| 
  hide details  
Reply
post #4 of 4
One of the most overlooked things are the programs running in the background and system tray. Java and Adobe are really nasty when it comes with downloading and installing updates/bloatware in the background. Try disabling the auto updates in Java and ditch the Adobe bloatware and use an alternative like Foxit. Hope that helps.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: General Processor Discussions
Overclock.net › Forums › General Hardware › General Processor Discussions › Increasing my data I/O performance...