Overclock.net › Forums › Graphics Cards › AMD/ATI › XFX 5970 Black Edition crashes win 7 all the time
New Posts  All Forums:Forum Nav:

XFX 5970 Black Edition crashes win 7 all the time

post #1 of 78
Thread Starter 
First I had those drivers installed(10.5 on the top): http://game.amd.com/us-en/drivers_ca...indows-7-64bit

The screen froze every 1-2 seconds for about 5 seconds, so I tried to deinstall them, but it was impossible, so I deleted the files from my disk.

Now I have older drivers, which came with my 5970, installed.

I tried running 3DMark06-->screen goes black, nothing happens-->reset

I tried watching a DVD with divX player-->screen goes black PC makes a continous "burping"-sound-->reset.

The system even crashes sometimes, when I watch videos on youtube.

Is my 5970 broken or what could it be?
Burger with Fries
(14 items)
 
  
CPUMotherboardGraphicsRAM
1090T @4.1GHz ASUS M4A89TD Pro/USB3 XFX 5970 Black Edition 4 x 2 GB DDR3 1600Mhz G.Skill 
Hard DriveOptical DriveCoolingOS
1x X25-M 80GB 2X SpinPoint F3 1TB Philips CD/DVD writer noctua NH-D14 Windows 7 64 Bit Professional & Win XP 32 Bit Pro 
MonitorPowerCase
Hanns-G HZ281HPB 1920x1200 27.5" Corsair HX 850W HAF 932 
  hide details  
Reply
Burger with Fries
(14 items)
 
  
CPUMotherboardGraphicsRAM
1090T @4.1GHz ASUS M4A89TD Pro/USB3 XFX 5970 Black Edition 4 x 2 GB DDR3 1600Mhz G.Skill 
Hard DriveOptical DriveCoolingOS
1x X25-M 80GB 2X SpinPoint F3 1TB Philips CD/DVD writer noctua NH-D14 Windows 7 64 Bit Professional & Win XP 32 Bit Pro 
MonitorPowerCase
Hanns-G HZ281HPB 1920x1200 27.5" Corsair HX 850W HAF 932 
  hide details  
Reply
post #2 of 78
Fill out your system specs so we can see what's what.

And welcome to our slightly* disfunctional family.
post #3 of 78
Any overclocking of anything going on?
    
CPUMotherboardGraphicsRAM
2600k Gigabyte Z68 MSI N480GTX 16 GB Patriot 1600 
Hard DriveOptical DriveOSMonitor
1.5TB Hitachi - 120GB Crucial C300 SSD LG Win7Ultimate a couple 
KeyboardPowerCaseMouse
Saitek Eclipse II Thermaltake 750 Thermaltake A60 Armor microsoft 3000 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
2600k Gigabyte Z68 MSI N480GTX 16 GB Patriot 1600 
Hard DriveOptical DriveOSMonitor
1.5TB Hitachi - 120GB Crucial C300 SSD LG Win7Ultimate a couple 
KeyboardPowerCaseMouse
Saitek Eclipse II Thermaltake 750 Thermaltake A60 Armor microsoft 3000 
  hide details  
Reply
post #4 of 78
Thread Starter 
Quote:
Originally Posted by Suprcynic View Post
Any overclocking of anything going on?
Nothing overclocked.

But is it normal that I can't touch the backplate of the 5970 because it's too hot?
Burger with Fries
(14 items)
 
  
CPUMotherboardGraphicsRAM
1090T @4.1GHz ASUS M4A89TD Pro/USB3 XFX 5970 Black Edition 4 x 2 GB DDR3 1600Mhz G.Skill 
Hard DriveOptical DriveCoolingOS
1x X25-M 80GB 2X SpinPoint F3 1TB Philips CD/DVD writer noctua NH-D14 Windows 7 64 Bit Professional & Win XP 32 Bit Pro 
MonitorPowerCase
Hanns-G HZ281HPB 1920x1200 27.5" Corsair HX 850W HAF 932 
  hide details  
Reply
Burger with Fries
(14 items)
 
  
CPUMotherboardGraphicsRAM
1090T @4.1GHz ASUS M4A89TD Pro/USB3 XFX 5970 Black Edition 4 x 2 GB DDR3 1600Mhz G.Skill 
Hard DriveOptical DriveCoolingOS
1x X25-M 80GB 2X SpinPoint F3 1TB Philips CD/DVD writer noctua NH-D14 Windows 7 64 Bit Professional & Win XP 32 Bit Pro 
MonitorPowerCase
Hanns-G HZ281HPB 1920x1200 27.5" Corsair HX 850W HAF 932 
  hide details  
Reply
post #5 of 78
It could be that you deleted files needed by your 5970. NEVER delete files off your hard drive to uninstall something if it wont uninstall normally. It also sounds like you installed older drivers over the ones you partially erased? Try this:
  • Download Driver Sweeper and install it
  • Click start and right click "Computer"
  • Pick manage from the list and go to Device manager
  • Expand Display Adapters, right click the 5970, and uninstall
  • Make sure you Check the "Delete Driver Software for this device"
  • Restart your computer and boot into safe mode by tapping F8 while your computer boots
  • In safe mode Start up Driver Sweeper click on ATI Display and pick Clean on the bottom right
  • Restart your computer and boot normally, let windows install w/e drivers it wants
  • Go to C:\\ATI\\Support\\10-5_vista64_win7_64_dd_ccc_enu\\Setup.exe
  • Run it and Select "Uninstall" to Remove Catalyst Control Center (ignore these last two stops if the C:\\ATI folder isn't there)
  • Restart the computer and Reinstall the new drivers (10.5) you link to in your OP

After a clean install of the new 10.5 drivers check and see if it continues to give you problems. If it does, the next step would be to reformat.
post #6 of 78
Could be your ram or your gpu might be overheating or defective.

Make sure you are using 64bit drivers.
post #7 of 78
Thread Starter 
Quote:
Originally Posted by xBISHOPx View Post
It could be that you deleted files needed by your 5970. NEVER delete files off your hard drive to uninstall something if it wont uninstall normally. It also sounds like you installed older drivers over the ones you partially erased? Try this:
  • Download Driver Sweeper and install it
  • Click start and right click "Computer"
  • Pick manage from the list and go to Device manager
  • Expand Display Adapters, right click the 5970, and uninstall
  • Make sure you Check the "Delete Driver Software for this device"
  • Restart your computer and boot into safe mode by tapping F8 while your computer boots
  • In safe mode Start up Driver Sweeper click on ATI Display and pick Clean on the bottom right
  • Restart your computer and boot normally, let windows install w/e drivers it wants
  • Go to C:\\ATI\\Support\\10-5_vista64_win7_64_dd_ccc_enu\\Setup.exe
  • Run it and Select "Uninstall" to Remove Catalyst Control Center (ignore these last two stops if the C:\\ATI folder isn't there)
  • Restart the computer and Reinstall the new drivers (10.5) you link to in your OP

After a clean install of the new 10.5 drivers check and see if it continues to give you problems. If it does, the next step would be to reformat.
I've tried everything, formatting and reinstallation of win 7 too. Nothing works. As soon as I install any driver for the 5970(the old ones from my driver CD or the new 10.5) the screen freezes and goes black all the time.

Is there anything else I could do? I really hope the gfx card isn't broken.
Burger with Fries
(14 items)
 
  
CPUMotherboardGraphicsRAM
1090T @4.1GHz ASUS M4A89TD Pro/USB3 XFX 5970 Black Edition 4 x 2 GB DDR3 1600Mhz G.Skill 
Hard DriveOptical DriveCoolingOS
1x X25-M 80GB 2X SpinPoint F3 1TB Philips CD/DVD writer noctua NH-D14 Windows 7 64 Bit Professional & Win XP 32 Bit Pro 
MonitorPowerCase
Hanns-G HZ281HPB 1920x1200 27.5" Corsair HX 850W HAF 932 
  hide details  
Reply
Burger with Fries
(14 items)
 
  
CPUMotherboardGraphicsRAM
1090T @4.1GHz ASUS M4A89TD Pro/USB3 XFX 5970 Black Edition 4 x 2 GB DDR3 1600Mhz G.Skill 
Hard DriveOptical DriveCoolingOS
1x X25-M 80GB 2X SpinPoint F3 1TB Philips CD/DVD writer noctua NH-D14 Windows 7 64 Bit Professional & Win XP 32 Bit Pro 
MonitorPowerCase
Hanns-G HZ281HPB 1920x1200 27.5" Corsair HX 850W HAF 932 
  hide details  
Reply
post #8 of 78
Any high overclocks on the card? Is it a new card or was there a previous owner? Any other graphics cards you can put in the machine atm? Could be the slot
post #9 of 78
Thread Starter 
Quote:
Originally Posted by Roxxas049 View Post
Any high overclocks on the card? Is it a new card or was there a previous owner? Any other graphics cards you can put in the machine atm? Could be the slot
It's brand new, I'm the first owner. I haven't overclocked the card at all.

I could test the PCIe-Slot with my old x1600 gfx card.
Burger with Fries
(14 items)
 
  
CPUMotherboardGraphicsRAM
1090T @4.1GHz ASUS M4A89TD Pro/USB3 XFX 5970 Black Edition 4 x 2 GB DDR3 1600Mhz G.Skill 
Hard DriveOptical DriveCoolingOS
1x X25-M 80GB 2X SpinPoint F3 1TB Philips CD/DVD writer noctua NH-D14 Windows 7 64 Bit Professional & Win XP 32 Bit Pro 
MonitorPowerCase
Hanns-G HZ281HPB 1920x1200 27.5" Corsair HX 850W HAF 932 
  hide details  
Reply
Burger with Fries
(14 items)
 
  
CPUMotherboardGraphicsRAM
1090T @4.1GHz ASUS M4A89TD Pro/USB3 XFX 5970 Black Edition 4 x 2 GB DDR3 1600Mhz G.Skill 
Hard DriveOptical DriveCoolingOS
1x X25-M 80GB 2X SpinPoint F3 1TB Philips CD/DVD writer noctua NH-D14 Windows 7 64 Bit Professional & Win XP 32 Bit Pro 
MonitorPowerCase
Hanns-G HZ281HPB 1920x1200 27.5" Corsair HX 850W HAF 932 
  hide details  
Reply
post #10 of 78
what about trying 10.3 or 10.4 drivers
Edited by driftingforlife - 6/11/10 at 2:20am
Main Rig
(15 items)
 
Work Rig
(9 items)
 
 
CPUMotherboardGraphicsRAM
5820k Asus X99 Deluxe MSI GTX980 Ti Gaming/EK GPU Block Corsair 16GB 
Hard DriveCoolingOSMonitor
M4 128GB,C300 128GB, F3 1TB  480mm RAD, 655/top, 250mm RES, EK LX CPU Block windows 7 PRO 64bit Asus PB278Q 
PowerCase
Enermax Platimax 1500W Cosmos S 
CPUMotherboardGraphicsRAM
Core i7 2600k ASUS P8Z77-V MSI GT 610 1GB Corsair 1333mhz 16GB 
Hard DriveCoolingOSPower
Intel 330 60GB Cooler Master Hyper 212 EVO W7 Corsair CX500M 
Case
Cooler Master Elite 334U 
  hide details  
Reply
Main Rig
(15 items)
 
Work Rig
(9 items)
 
 
CPUMotherboardGraphicsRAM
5820k Asus X99 Deluxe MSI GTX980 Ti Gaming/EK GPU Block Corsair 16GB 
Hard DriveCoolingOSMonitor
M4 128GB,C300 128GB, F3 1TB  480mm RAD, 655/top, 250mm RES, EK LX CPU Block windows 7 PRO 64bit Asus PB278Q 
PowerCase
Enermax Platimax 1500W Cosmos S 
CPUMotherboardGraphicsRAM
Core i7 2600k ASUS P8Z77-V MSI GT 610 1GB Corsair 1333mhz 16GB 
Hard DriveCoolingOSPower
Intel 330 60GB Cooler Master Hyper 212 EVO W7 Corsair CX500M 
Case
Cooler Master Elite 334U 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › XFX 5970 Black Edition crashes win 7 all the time