Overclock.net › Forums › Graphics Cards › AMD/ATI › 1900xt Acting Funny
New Posts  All Forums:Forum Nav:

1900xt Acting Funny

post #1 of 9
Thread Starter 
I have been using the RIG in my sig for about 3 weeks and for 2 of them there were no problems, then the new 6.3 drivers came out and I thought hey why dont I try them out. So after downloading and installing them (Yes I used driver cleaner to uninstall the exisisting), I noticed that when every playing CS:S or running bench marks I would get really odd graphical glitches, they werent artifacts but they were really wierd looking. So I went ahead and rolled back the drivers and the game started working no problem but I couldnt overclock it as high as I could before I mean its a huge difference.

So my being the impaitent person I am I decided to return the card and get a new one. I get the new card and I still cant OC as high as I could go before, also both the OC utility that ATI uses and ATItool crash my card or give me last known working config at levels that I cant get the card to run at.

I am debating on just returning it for a 7900GTX since it seems that they are about the same card, also I have had better luck with Nvidia, but I am not sure. Has anyone else had problems with this card?
post #2 of 9
I have had no issues with my X1900xtx and the cat 6.3's. I think your PSU might be contributing to your oc'ing and glitchy problems. The X1900XT uses a lot of power, and my sli certified psu can barely keep up, especially when overclocked.
C2D
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500K Sabertooth P67 GTX 580 2x 4GB Corsair XMS 
Hard DriveOptical DriveOSMonitor
2x Intel X-25M Raid 0 cd/dvd combo drive Windows 7 Dell U3011 
KeyboardPowerCaseMouse
Razer Black Widow Corsair HX750 TJ07 Modded Razer Copperhead 
  hide details  
Reply
C2D
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500K Sabertooth P67 GTX 580 2x 4GB Corsair XMS 
Hard DriveOptical DriveOSMonitor
2x Intel X-25M Raid 0 cd/dvd combo drive Windows 7 Dell U3011 
KeyboardPowerCaseMouse
Razer Black Widow Corsair HX750 TJ07 Modded Razer Copperhead 
  hide details  
Reply
post #3 of 9
Have either of you tried these? This is what I'd run if I had a 1900xt or xtx.
http://downloads.guru3d.com/download.php?det=1328
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2500k Asus P8P67 Galaxy GTX580 8GB G Skill Ripjaws 
Hard DriveOSMonitorKeyboard
Intel 80 gb SSD, Raptor 150 Windows 7 Home Premium 24" Samsung LCD Saitek Eclipse 
PowerCaseMouse
PCP&C 750W Antec P180 Logitech MX-510 blue 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2500k Asus P8P67 Galaxy GTX580 8GB G Skill Ripjaws 
Hard DriveOSMonitorKeyboard
Intel 80 gb SSD, Raptor 150 Windows 7 Home Premium 24" Samsung LCD Saitek Eclipse 
PowerCaseMouse
PCP&C 750W Antec P180 Logitech MX-510 blue 
  hide details  
Reply
post #4 of 9
Thread Starter 
Quote:
Originally Posted by metalman2785
I have had no issues with my X1900xtx and the cat 6.3's. I think your PSU might be contributing to your oc'ing and glitchy problems. The X1900XT uses a lot of power, and my sli certified psu can barely keep up, especially when overclocked.

Well whats wierd is that even with the card underclocked and the 6.3 drivers things were messed up. My Psu has 30A over the 12V, I am not using a dongle the PSU has the PCIexpress plug for it, I had it running for 3 weeks no problems at all now its just like it got lazy.
post #5 of 9
it says on ati's site that recomended is atleast 550 W for runnning a Crossfire System , considering youronly running single card its still a huge power consumer, and btw you didnt under or overclock it did u ?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon 3700+ @ 2.6Ghz MSI nf4 Sapphire X1950PRO 1 GB DDR 
Hard DriveOSMonitorKeyboard
500 GB WD Windows 7 64bit Sharp 32'' LCD Logitech G15 
PowerCaseMouse
Ennermax 460W Thermaltake ATX Logitech G5 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon 3700+ @ 2.6Ghz MSI nf4 Sapphire X1950PRO 1 GB DDR 
Hard DriveOSMonitorKeyboard
500 GB WD Windows 7 64bit Sharp 32'' LCD Logitech G15 
PowerCaseMouse
Ennermax 460W Thermaltake ATX Logitech G5 
  hide details  
Reply
post #6 of 9
One x1900XTX uses as much power as 2x 7900GTX's in SLI, so I still think the PSU is an issue, especially when overclocked.

http://www.hwupgrade.it/


So your PSU has 30Amps, really
C2D
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500K Sabertooth P67 GTX 580 2x 4GB Corsair XMS 
Hard DriveOptical DriveOSMonitor
2x Intel X-25M Raid 0 cd/dvd combo drive Windows 7 Dell U3011 
KeyboardPowerCaseMouse
Razer Black Widow Corsair HX750 TJ07 Modded Razer Copperhead 
  hide details  
Reply
C2D
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500K Sabertooth P67 GTX 580 2x 4GB Corsair XMS 
Hard DriveOptical DriveOSMonitor
2x Intel X-25M Raid 0 cd/dvd combo drive Windows 7 Dell U3011 
KeyboardPowerCaseMouse
Razer Black Widow Corsair HX750 TJ07 Modded Razer Copperhead 
  hide details  
Reply
post #7 of 9
Quote:
Originally Posted by sccr64472
Have either of you tried these? This is what I'd run if I had a 1900xt or xtx.
http://downloads.guru3d.com/download.php?det=1328
Word of caution when using the Omega Drivers.

I loaded up those kind of drivers with my 9800Pro and it complete messed up my system. Even after cleaning out the drivers it wouldn't read my card. I had to clear out every driver and get the standard ATi ones after a good 2 hours of dicking around with it

Just be careful about loading up "optimized drivers". I think they release Catalysts Drivers for a reason, but the worse case scenario is you reformat your PC and try it again and last possibility is getting a 7900GTX.
Asus G1
(13 items)
 
  
CPUMotherboardGraphicsRAM
2.0Ghz C2D T7200 Asus GeForce Go 7700 512MB 2GB (2x1GB) DDR2 667 
Hard DriveOSMonitorCase
160GB MCE 2005 -> Vista 15.4" Wide SXGA Black Honeycomb 
Mouse
Wireless Controller 
  hide details  
Reply
Asus G1
(13 items)
 
  
CPUMotherboardGraphicsRAM
2.0Ghz C2D T7200 Asus GeForce Go 7700 512MB 2GB (2x1GB) DDR2 667 
Hard DriveOSMonitorCase
160GB MCE 2005 -> Vista 15.4" Wide SXGA Black Honeycomb 
Mouse
Wireless Controller 
  hide details  
Reply
post #8 of 9
Stick with the card. Reinstall the windows and check ur bios if u changed any settings. Your psu is fine, I'm running a x850xt on 300W so even if the x1900xt uses 100 more watts then a x850xt, it should run on your 500.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i3 530 @ 4.3 H55M-S2H gtx465 4gb g.skill 
Hard DrivePowerCase
400GB Samsung TPN-550 cm690 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i3 530 @ 4.3 H55M-S2H gtx465 4gb g.skill 
Hard DrivePowerCase
400GB Samsung TPN-550 cm690 
  hide details  
Reply
post #9 of 9
Quote:
Originally Posted by GatorLCA
Word of caution when using the Omega Drivers.

I loaded up those kind of drivers with my 9800Pro and it complete messed up my system. Even after cleaning out the drivers it wouldn't read my card. I had to clear out every driver and get the standard ATi ones after a good 2 hours of dicking around with it

Just be careful about loading up "optimized drivers". I think they release Catalysts Drivers for a reason, but the worse case scenario is you reformat your PC and try it again and last possibility is getting a 7900GTX.
I ONLY use modified drivers on all my Nvidia and Ati cards. I have much better performance with them, so I wonder if you had a bad install or file. I'm slightly more sold on NGO out of all of them.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2500k Asus P8P67 Galaxy GTX580 8GB G Skill Ripjaws 
Hard DriveOSMonitorKeyboard
Intel 80 gb SSD, Raptor 150 Windows 7 Home Premium 24" Samsung LCD Saitek Eclipse 
PowerCaseMouse
PCP&C 750W Antec P180 Logitech MX-510 blue 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2500k Asus P8P67 Galaxy GTX580 8GB G Skill Ripjaws 
Hard DriveOSMonitorKeyboard
Intel 80 gb SSD, Raptor 150 Windows 7 Home Premium 24" Samsung LCD Saitek Eclipse 
PowerCaseMouse
PCP&C 750W Antec P180 Logitech MX-510 blue 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › 1900xt Acting Funny