Overclock.net › Forums › Components › Power Supplies › Dead Fortron PSU?!?!
New Posts  All Forums:Forum Nav:

Dead Fortron PSU?!?!

post #1 of 6
Thread Starter 
Okay, so I came home at lunch and I used my computer, everything was 100% normal. I come home after work and it's dead. Like, it's off, it won't turn on, I plug in the power supply and it has a lighted switch that indicates when it recieves power and even that does not come on. So at least my power supply must be dead...

But I don't get it... the weather was sunny so I assume there was no power surge, and even if there was, my LCD, printer, sound card, etc all still work and they are plugged into the same strip. So my PSU just crapped out? It's a Fortron... and it's worked 100% reliably for the last 1.5 years. What the hell? Damn it. Anyone else had something like this happen before?
Hedy
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 750 @ 3.5(175x20) & 4.2(175x24) dynamic OC MSI GD65 P55 MSI HD 5750 1GB G.SKILL Ripjaw 4GB DDR3 1600 
Hard DriveOSMonitorKeyboard
400GB WD SATA + 1.5TB WD SATA external Win 7 Ultimate Viewsonic 17" & NEC 19" Saitek Eclipse II 
PowerCaseMouse
Fortron Source 530W Blue Storm Antec 300 Microsoft "Laser" 
  hide details  
Reply
Hedy
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 750 @ 3.5(175x20) & 4.2(175x24) dynamic OC MSI GD65 P55 MSI HD 5750 1GB G.SKILL Ripjaw 4GB DDR3 1600 
Hard DriveOSMonitorKeyboard
400GB WD SATA + 1.5TB WD SATA external Win 7 Ultimate Viewsonic 17" & NEC 19" Saitek Eclipse II 
PowerCaseMouse
Fortron Source 530W Blue Storm Antec 300 Microsoft "Laser" 
  hide details  
Reply
post #2 of 6
I had a psu go on me that way. Just came home and it was off. No light or anything came on after that.
My System
(13 items)
 
System 2
(12 items)
 
 
CPUMotherboardGraphicsRAM
X2 4400 ASUS A8NE XFX 7900GT Extreme OCZ DDR 500 
Hard DriveOSMonitorKeyboard
300GB + 2, 160GB drives XP Pro HP LCD Z-Board 
PowerCaseMouseMouse Pad
SilverStone ST75ZF (750 watt) Aspire X-plorer MS Laser 6000 Aqua 3 
CPUMotherboardGraphicsRAM
C2D 6400 ASUS P5B Gigabyte Radeon HD 6770 OCZ Value DDR2 PC 4200 
OSMonitorPowerCase
Win 7 17" CRT SilverStone ST75ZF (750 watt) Aspire X-plorer 
Mouse
MS 
  hide details  
Reply
My System
(13 items)
 
System 2
(12 items)
 
 
CPUMotherboardGraphicsRAM
X2 4400 ASUS A8NE XFX 7900GT Extreme OCZ DDR 500 
Hard DriveOSMonitorKeyboard
300GB + 2, 160GB drives XP Pro HP LCD Z-Board 
PowerCaseMouseMouse Pad
SilverStone ST75ZF (750 watt) Aspire X-plorer MS Laser 6000 Aqua 3 
CPUMotherboardGraphicsRAM
C2D 6400 ASUS P5B Gigabyte Radeon HD 6770 OCZ Value DDR2 PC 4200 
OSMonitorPowerCase
Win 7 17" CRT SilverStone ST75ZF (750 watt) Aspire X-plorer 
Mouse
MS 
  hide details  
Reply
post #3 of 6
Thread Starter 
well I guess I'm not the only one... how annoying though. Any recommendations for a new one? ~500W or +

Also, I tried searching the FAQs but I couldn't find it... which pins do you jump on the motherboard connector if you want to turn on the PSU without it being connected to the motherboard... I'm going to try to test it at lunch today... not that I think it will work but I want to be sure before I drop another $100 on a new one. Grrrrrrrr.
Hedy
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 750 @ 3.5(175x20) & 4.2(175x24) dynamic OC MSI GD65 P55 MSI HD 5750 1GB G.SKILL Ripjaw 4GB DDR3 1600 
Hard DriveOSMonitorKeyboard
400GB WD SATA + 1.5TB WD SATA external Win 7 Ultimate Viewsonic 17" & NEC 19" Saitek Eclipse II 
PowerCaseMouse
Fortron Source 530W Blue Storm Antec 300 Microsoft "Laser" 
  hide details  
Reply
Hedy
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 750 @ 3.5(175x20) & 4.2(175x24) dynamic OC MSI GD65 P55 MSI HD 5750 1GB G.SKILL Ripjaw 4GB DDR3 1600 
Hard DriveOSMonitorKeyboard
400GB WD SATA + 1.5TB WD SATA external Win 7 Ultimate Viewsonic 17" & NEC 19" Saitek Eclipse II 
PowerCaseMouse
Fortron Source 530W Blue Storm Antec 300 Microsoft "Laser" 
  hide details  
Reply
post #4 of 6
FSP makes some good psus. look at their epsilon series.

or look at the nuuo or seasonic s12 series
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
Darkness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 G0 Gigabye GA-EP45-UD3P EVGA GTX660 8GB G.Skill PK 
Hard DriveOptical DriveOSMonitor
WD 640GB & Samsung F1 750Gb LG BD & HD Windows 8 Pro x64 HP w2207 
KeyboardPowerCaseMouse
FILCO FKBN87M/NPEK Enermax Modu82+ 525w CM 690 Logitech G9x 
Mouse PadAudio
Razor Destructor ODAC 
  hide details  
Reply
post #5 of 6
Theres a green wire. You jump that to one of the black neutral wires. PLEASE PLEASE check this before trying. Im pretty sure im right, but im not 100% on this and i dont want you to blow up your PSU, your house, or yourself.

EDIT: thinking about this, it couldnt be danagerous, coz you could jump anything to a neutral wire, and it'd do nothing. meh, still best to ask for a second opinion.
2011 ~ Current
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600K Asus P8P67 Pro B3 EVGA GTX970 FTW+ G.Skill 8GB RipJaws 
Hard DriveHard DriveOptical DriveCooling
2x 500GB WD Black RAID 0 1TB WD Black Samsung WriteMaster Prolima Tech Megahalems 
OSMonitorKeyboardPower
Windows 7 Home Premium ViewSonic 22" VX2260wm Saitek Eclipse II Seasonic X-660 
CaseMouseMouse PadAudio
ThermalTake Armor Silver Logitech G5 Sharkoon Asus Xonar D1 
  hide details  
Reply
2011 ~ Current
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600K Asus P8P67 Pro B3 EVGA GTX970 FTW+ G.Skill 8GB RipJaws 
Hard DriveHard DriveOptical DriveCooling
2x 500GB WD Black RAID 0 1TB WD Black Samsung WriteMaster Prolima Tech Megahalems 
OSMonitorKeyboardPower
Windows 7 Home Premium ViewSonic 22" VX2260wm Saitek Eclipse II Seasonic X-660 
CaseMouseMouse PadAudio
ThermalTake Armor Silver Logitech G5 Sharkoon Asus Xonar D1 
  hide details  
Reply
post #6 of 6
Quote:
and it has a lighted switch that indicates when it recieves power and even that does not come on. So at least my power supply must be dead...
Not so sure, tried an other cable?

Switches with lights have a small 120v bulb in them, so your PSU is not even receiving current.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Dead Fortron PSU?!?!