Overclock.net › Forums › Video Games › PC Gaming › Civ 5 Framerate Lag
New Posts  All Forums:Forum Nav:

Civ 5 Framerate Lag

post #1 of 9
Thread Starter 
Hi, like many of you I've just purchased and played through my first game of Civ 5. However, I noticed that on Max settings, the framerate had a particularly difficult time staying at 59-60 FPS, and briefly dropped to about 45 each time I moved the camera to the far side of a map (fully populated, everything revealed and game about to end).

Is this the kind of performance I should expect out of my rig for this? Or is there some way to make it run better without sacrificing the Max settings?

Rig:

Samsung SyncMaster P2250 @ 1920x1080 60hz refresh
i7 930 Stock @ 2.80 GHz (yea I know...no OC experience)
EVGA GTX 480 SC
6gb Corsair Dominator DDR3
ASUS P6T Mobo
Win7 x64

etc...not gonna mention the stuff that doesnt make a performance difference, no extra cooling or anything.

I'm thinking the system is bottlenecking at the CPU, and that I should be learning to overclock some time soon...

One note, I do have the EPU-6 engine included with the ASUS Mobo running at Turbo settings. Does this whole EPU-6 thing have any adverse effects on my system?

Thanks for your time
Edited by globogim - 9/21/10 at 10:29pm
First Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 D0 @ 4.05GHz (HT On) Asus P6T EVGA GTX 480 SC 6gb Corsair Dominator DDR3 1600MHz 
Hard DriveMonitorPowerCase
1.5TB Seagate 7200.11 Samsung SyncMaster P2250 @ 1920x1080 Corsair TX-750W HAF 932 
Mouse
Razer Deathadder 
  hide details  
Reply
First Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 D0 @ 4.05GHz (HT On) Asus P6T EVGA GTX 480 SC 6gb Corsair Dominator DDR3 1600MHz 
Hard DriveMonitorPowerCase
1.5TB Seagate 7200.11 Samsung SyncMaster P2250 @ 1920x1080 Corsair TX-750W HAF 932 
Mouse
Razer Deathadder 
  hide details  
Reply
post #2 of 9
Not really sure why you would get any lag on that system of yours. Try turning off all that software overclocking stuff and see if it helps. A 2.8ghz quad shouldnt be bottlenecking a single gtx 480.

BTW: welcome to the forum. please go to the profiles settings and click add or edit system and fill out your specs.

enjoy your stay
post #3 of 9
you would be surprised at how that i7 clock speed effects the 480. if you take a look around on the forums, specifically in the intel processor/mobo section there are plenty of quick and dirty guides to get you overclocking an i7. it is fairly simple. even at 3.3ghz you would notice a difference. I cant remember off the top of my head the article that demonstrates it but im sure a quick google search would be more than sufficient for any info you need.
post #4 of 9
Thread Starter 
To be completely honest, I have no idea how to disable the EPU-6 engine, whatever it is. Billed as some sort of energy saving process, but it certainly tends to affect my performance in games by about 10FPS. I think I might have to disable it in the BIOS or something, its part of the Asus AI Suite. Anyway, is it safe to assume that my system should be able to run the game Maxed without lag as it currently stands stock? Or is it still too taxing of a game to do so?
Edited by globogim - 9/21/10 at 10:49pm
First Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 D0 @ 4.05GHz (HT On) Asus P6T EVGA GTX 480 SC 6gb Corsair Dominator DDR3 1600MHz 
Hard DriveMonitorPowerCase
1.5TB Seagate 7200.11 Samsung SyncMaster P2250 @ 1920x1080 Corsair TX-750W HAF 932 
Mouse
Razer Deathadder 
  hide details  
Reply
First Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 D0 @ 4.05GHz (HT On) Asus P6T EVGA GTX 480 SC 6gb Corsair Dominator DDR3 1600MHz 
Hard DriveMonitorPowerCase
1.5TB Seagate 7200.11 Samsung SyncMaster P2250 @ 1920x1080 Corsair TX-750W HAF 932 
Mouse
Razer Deathadder 
  hide details  
Reply
post #5 of 9
I would think so my sig rig is having no issues with everything maxed and I have only a GTX285.
    
CPUMotherboardGraphicsRAM
i7 920 @ 4.0 Ghz GIGABYTE GA-EX58-UD3R BFG GTX285 OC2 691/1566/2592 OCZ Obsidian 6GB 
OSMonitorKeyboardPower
Win7 Pro 64 245BW G15 BFG 800 
CaseMouse
CoolerMaster CM690 G5 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 920 @ 4.0 Ghz GIGABYTE GA-EX58-UD3R BFG GTX285 OC2 691/1566/2592 OCZ Obsidian 6GB 
OSMonitorKeyboardPower
Win7 Pro 64 245BW G15 BFG 800 
CaseMouse
CoolerMaster CM690 G5 
  hide details  
Reply
post #6 of 9
Thread Starter 
Okay well now I'm a bit disheartened. I have absolutely no idea what the issue could be then. You certainly have a good 1.2GHz more processing to work with, but is it really that thats causing the lag? To be honest I have no idea how to approach this problem, I could start uninstalling programs from the drive but what good would that do? I'm not virus'd up or anything like that, and I can maintain 60fps on Max Dirt 2. Are there any ideas why I'm not getting what I should out of my system? It hasn't just been this game necessarily, I figure that with everything the way it is I should be getting much more out of all of the games I have.
First Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 D0 @ 4.05GHz (HT On) Asus P6T EVGA GTX 480 SC 6gb Corsair Dominator DDR3 1600MHz 
Hard DriveMonitorPowerCase
1.5TB Seagate 7200.11 Samsung SyncMaster P2250 @ 1920x1080 Corsair TX-750W HAF 932 
Mouse
Razer Deathadder 
  hide details  
Reply
First Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 D0 @ 4.05GHz (HT On) Asus P6T EVGA GTX 480 SC 6gb Corsair Dominator DDR3 1600MHz 
Hard DriveMonitorPowerCase
1.5TB Seagate 7200.11 Samsung SyncMaster P2250 @ 1920x1080 Corsair TX-750W HAF 932 
Mouse
Razer Deathadder 
  hide details  
Reply
post #7 of 9
Thread Starter 
So even after completely ridding the computer of AI suite, EPU-6, and all the default stuff the mobo came with, I still experience the same sort of lag. I dont understand why I'm not getting better performance out of what I have, it seems as if my specs are supposed to be able to run the game Maxed easy and without a hint of framerate drop. I'm not even sure that its the game, but possibly the system overall. I have many games installed on it but they can't be doing it any harm surely. No viruses, nothing like that.

Sorry, I just feel like I'm coming up with nothing, and that my rig as it is should be able to do much more than it is. With enough people I'll lag past about 50 FPS, (9-10 dropped) in TF2 even, and I assume that's not supposed to happen regardless of whether or not there are 32 people onscreen simultaneously. The actual hardware is all installed correctly, but the thing has been performing like that from day one, so Im completely stumped.
First Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 D0 @ 4.05GHz (HT On) Asus P6T EVGA GTX 480 SC 6gb Corsair Dominator DDR3 1600MHz 
Hard DriveMonitorPowerCase
1.5TB Seagate 7200.11 Samsung SyncMaster P2250 @ 1920x1080 Corsair TX-750W HAF 932 
Mouse
Razer Deathadder 
  hide details  
Reply
First Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 D0 @ 4.05GHz (HT On) Asus P6T EVGA GTX 480 SC 6gb Corsair Dominator DDR3 1600MHz 
Hard DriveMonitorPowerCase
1.5TB Seagate 7200.11 Samsung SyncMaster P2250 @ 1920x1080 Corsair TX-750W HAF 932 
Mouse
Razer Deathadder 
  hide details  
Reply
post #8 of 9
I am having this same issue. Havent found a fix yet, but have been grinding my gears to yet figure it out. I am almost 98% certain it is the graphics card. When I went to using my onboard it ran smoothe.
i5 2400@ 3.1 Ghz 16 gig ram. Nvidia GeForce 9500GT.
post #9 of 9
So I've finally got it. You video card must support dx 10.1 I got a new video card (where as the old one was dx10) the new one is 10.1 dx compatible. So unfrotunately to fix this issue you will have to purchase a card with 10.1 or better.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Civ 5 Framerate Lag