Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI drivers won't install on Windows Server 2008 R2
New Posts  All Forums:Forum Nav:

ATI drivers won't install on Windows Server 2008 R2

post #1 of 6
Thread Starter 
I realize ATI drivers are not officially supported on a Windows Server OS, but has anyone managed to install the 10.9 ATI drivers for an 4870 [X2] card under Windows Server 2008 R2? I tried and at most it'll install the ATI package manager, it won't install the drivers nor CCC software. If I try drivers 10.1, they will install with the exception of the ATI encoder software, but obviously I want the latest drivers available. Thanks.
Workstation
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3930K @ 4.6 GHz ASUS Rampage IV Gene mATX EVGA GeForce GTX 690 4 x Corsair Platinum 2133 MHz 8GB 
Hard DriveOptical DriveCoolingOS
4 x Samsung 840 Pro 256GB Samsung USB Bluray burner Corsair H100i Windows 7 Professional x64 
MonitorKeyboardPowerCase
Eizo Nanao S2100 21" Steelseries 6GV2 Seasonic Platinum SS-860XP2 Corsair Obsidian 350D mATX 
MouseAudioOther
Razer Deathadder Creative X-Fi Titanium HD LSI MegaRAID 9271-8i 6Gbp/s 
  hide details  
Reply
Workstation
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3930K @ 4.6 GHz ASUS Rampage IV Gene mATX EVGA GeForce GTX 690 4 x Corsair Platinum 2133 MHz 8GB 
Hard DriveOptical DriveCoolingOS
4 x Samsung 840 Pro 256GB Samsung USB Bluray burner Corsair H100i Windows 7 Professional x64 
MonitorKeyboardPowerCase
Eizo Nanao S2100 21" Steelseries 6GV2 Seasonic Platinum SS-860XP2 Corsair Obsidian 350D mATX 
MouseAudioOther
Razer Deathadder Creative X-Fi Titanium HD LSI MegaRAID 9271-8i 6Gbp/s 
  hide details  
Reply
post #2 of 6
Have you tried running windows update to see what it downloads for you?
Atlas
(20 items)
 
M17x R4
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7 3740qm @ 3.9Ghz M17x R4 7970m @ 1Ghz Corsair 1600mhz DDR3 4x4GB 
Hard DriveHard DriveOptical DriveOS
480gb seagate 600 SSD 500GB Seagate 2.5 Liton Slot-Load Blu-Ray Windows 10 x64 Tech Preview 
  hide details  
Reply
Atlas
(20 items)
 
M17x R4
(8 items)
 
 
CPUMotherboardGraphicsRAM
i7 3740qm @ 3.9Ghz M17x R4 7970m @ 1Ghz Corsair 1600mhz DDR3 4x4GB 
Hard DriveHard DriveOptical DriveOS
480gb seagate 600 SSD 500GB Seagate 2.5 Liton Slot-Load Blu-Ray Windows 10 x64 Tech Preview 
  hide details  
Reply
post #3 of 6
Thread Starter 
Quote:
Originally Posted by FallenFaux View Post
Have you tried running windows update to see what it downloads for you?
I haven't got a network connection on this server as yet, even if I did, I don't think Windows Update would have the latest driver from ATI, and I wouldn't get the Catalyst software. Thanks.
Workstation
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3930K @ 4.6 GHz ASUS Rampage IV Gene mATX EVGA GeForce GTX 690 4 x Corsair Platinum 2133 MHz 8GB 
Hard DriveOptical DriveCoolingOS
4 x Samsung 840 Pro 256GB Samsung USB Bluray burner Corsair H100i Windows 7 Professional x64 
MonitorKeyboardPowerCase
Eizo Nanao S2100 21" Steelseries 6GV2 Seasonic Platinum SS-860XP2 Corsair Obsidian 350D mATX 
MouseAudioOther
Razer Deathadder Creative X-Fi Titanium HD LSI MegaRAID 9271-8i 6Gbp/s 
  hide details  
Reply
Workstation
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3930K @ 4.6 GHz ASUS Rampage IV Gene mATX EVGA GeForce GTX 690 4 x Corsair Platinum 2133 MHz 8GB 
Hard DriveOptical DriveCoolingOS
4 x Samsung 840 Pro 256GB Samsung USB Bluray burner Corsair H100i Windows 7 Professional x64 
MonitorKeyboardPowerCase
Eizo Nanao S2100 21" Steelseries 6GV2 Seasonic Platinum SS-860XP2 Corsair Obsidian 350D mATX 
MouseAudioOther
Razer Deathadder Creative X-Fi Titanium HD LSI MegaRAID 9271-8i 6Gbp/s 
  hide details  
Reply
post #4 of 6
I am having the same problem. I just reformatted. Last time I installed the ATI drivers it worked flawlessly. Now when I install them it is like I have not installed anything.
post #5 of 6
Thread Starter 
I found out how to do it. You need to run the installer to unpack the files, then exit the install manager. Then...

Driver
You need to manually point Device Manager (DEVMGMT.MSC from a Start->Run prompt) to the driver which is located in <ATI folder>\\Packages\\Drivers\\Display\\W76A_INF

Catalyst application
Run the application located in <ATI folder>\\Packages\\Apps\\CCC\\Core-Static\\ccc-core-static.msi

...this procedure works fine. ATI has obviously cripped the detection of the graphics card for Server OSs with their installation, which results in it not installing any of the components.
Workstation
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3930K @ 4.6 GHz ASUS Rampage IV Gene mATX EVGA GeForce GTX 690 4 x Corsair Platinum 2133 MHz 8GB 
Hard DriveOptical DriveCoolingOS
4 x Samsung 840 Pro 256GB Samsung USB Bluray burner Corsair H100i Windows 7 Professional x64 
MonitorKeyboardPowerCase
Eizo Nanao S2100 21" Steelseries 6GV2 Seasonic Platinum SS-860XP2 Corsair Obsidian 350D mATX 
MouseAudioOther
Razer Deathadder Creative X-Fi Titanium HD LSI MegaRAID 9271-8i 6Gbp/s 
  hide details  
Reply
Workstation
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3930K @ 4.6 GHz ASUS Rampage IV Gene mATX EVGA GeForce GTX 690 4 x Corsair Platinum 2133 MHz 8GB 
Hard DriveOptical DriveCoolingOS
4 x Samsung 840 Pro 256GB Samsung USB Bluray burner Corsair H100i Windows 7 Professional x64 
MonitorKeyboardPowerCase
Eizo Nanao S2100 21" Steelseries 6GV2 Seasonic Platinum SS-860XP2 Corsair Obsidian 350D mATX 
MouseAudioOther
Razer Deathadder Creative X-Fi Titanium HD LSI MegaRAID 9271-8i 6Gbp/s 
  hide details  
Reply
post #6 of 6
Quote:
Originally Posted by aln688 View Post

I found out how to do it. You need to run the installer to unpack the files, then exit the install manager. Then...

Driver

You need to manually point Device Manager (DEVMGMT.MSC from a Start->Run prompt) to the driver which is located in \\Packages\\Drivers\\Display\\W76A_INF

Catalyst application

Run the application located in \\Packages\\Apps\\CCC\\Core-Static\\ccc-core-static.msi


...this procedure works fine. ATI has obviously cripped the detection of the graphics card for Server OSs with their installation, which results in it not installing any of the components.


It seams you is not reasonable in practice , otherwise I would see an error code 52 after installing drivers. No digital signature.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI drivers won't install on Windows Server 2008 R2