Overclock.net › Forums › Video Games › PC Gaming › Steam Bioshock problems
New Posts  All Forums:Forum Nav:

Steam Bioshock problems

post #1 of 3
Thread Starter 
Hey guys

I jumped at the chance of the steam offer on Bioshock yestarday,

but the problem is it wont even start, the first little box pops up then nothing

alt+crtl+del out and it says it has a error

ive tried it in -dx9 which works okay, doesnt remember any of my PC settings tho...

anyone got any ideas?!

thanks in advance!
    
CPUMotherboardGraphicsRAM
i7 930 @ 4ghz w/1.25 Vcore Asus P6X58D-E Asus GTX480 6Gb Corsair Dominators 1600mhz Tri Chan 
Hard DriveHard DriveCoolingCooling
120gb Corsair force GT 1Tb Samsung F3 Noctua NH-D14 Zalman VF3000F 
OSMonitorKeyboardCase
Windows 7 27" iiyama G2773HS 120hz Steelseries Stealth Merc Coolermaster Storm Scout 
MouseMouse Pad
Razer Naga Razer Goliathus 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 930 @ 4ghz w/1.25 Vcore Asus P6X58D-E Asus GTX480 6Gb Corsair Dominators 1600mhz Tri Chan 
Hard DriveHard DriveCoolingCooling
120gb Corsair force GT 1Tb Samsung F3 Noctua NH-D14 Zalman VF3000F 
OSMonitorKeyboardCase
Windows 7 27" iiyama G2773HS 120hz Steelseries Stealth Merc Coolermaster Storm Scout 
MouseMouse Pad
Razer Naga Razer Goliathus 
  hide details  
Reply
post #2 of 3
you have to change the compatability settings to windows vista SP2

E:\\Steam\\steamapps\\common\\bioshock\\Builds\\Re lease\\

then on the 'Release folder' Right click on bioshock.exe > properties > tick 'Run this program in compatability mode for > and choose windows vista sp2



worked for me ^_^


had ht same problem like you last week when i bought bioshock from steam,

hope this helps you as well ^_^

if windows vista sp2 doesnt work, try windows xp sp3 and start the game on the folder itself instead of doing it inside the steam window
Ren - First Born
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Maximus IV GENE-Z NVIDIA GeForce Matrix GTX 580 Platinum G-Skill RipJawX 8GB 1600MHz  
Hard DriveHard DriveCoolingOS
2x 1TB Samsung F3 in Raid 0 60GB OCZ Vertex 2 Corsair H80 Windows 7 64-bit 
MonitorKeyboardPowerCase
Hanns.G 27" 1920 x 1200 Apple Aluminum Keyboard Thermaltake ToughPower XT 775w Silverstone TJ08-E 
Mouse
Razer Deathadder 
  hide details  
Reply
Ren - First Born
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Maximus IV GENE-Z NVIDIA GeForce Matrix GTX 580 Platinum G-Skill RipJawX 8GB 1600MHz  
Hard DriveHard DriveCoolingOS
2x 1TB Samsung F3 in Raid 0 60GB OCZ Vertex 2 Corsair H80 Windows 7 64-bit 
MonitorKeyboardPowerCase
Hanns.G 27" 1920 x 1200 Apple Aluminum Keyboard Thermaltake ToughPower XT 775w Silverstone TJ08-E 
Mouse
Razer Deathadder 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
I had this problem. I solved it today though.

(Before I begin this long post, please make sure your DirectX is up to date)

After scouring the internet for a day, I found out that many people had experienced difficulties with the game. I will try to help you out as best I can. Try:

Validating game files. It you get a 100% positive, try to launch the game. Are you still getting an error?

If yes, then right click on BioShock in My games, then click Properties. Click Set launch options..., then type "-nosound" (without the quotation marks).

Try to launch the game. A number of things could happen here, either your game hangs at a black screen, or you get into the game but from the plane crash onwards you have absolutely no in-game sound.

------------------------------------------------------------------------------

If you get a black screen (or any kind of immediate crash) - browse to your Default.ini file (.../BioShock/Builds/Release) and do the following (I suggest you make a backup of this file before you change anything):

Edit your default.ini. Put a semi-colon in front of AudioDevice=FMODAudio.FMODAudioSubsystem, and add the following line right after it:
AudioDevice=D3DDrv.D3DAudioDevice

After edits, that part of the config file should look like this:

;AudioDevice=FMODAudio.FMODAudioSubsystem
AudioDevice=D3DDrv.D3DAudioDevice

------------------------------------------------------------------------------

Try to relaunch the game. You should no longer be getting startup crashes. If you are, try clean installing steam - http://developer.valvesoftware.com/w...stalling_Steam -, and try again. If you still experience a crash, delete BioShock's local content and try a re-install.

------------------------------------------------------------------------------

By this point you should be able to access the game. However, it is incredibly likely that you will have no sound when you actually play.

I will make this note clear now: If you can hear a piano key noise when you press any option in the main menu (such as "Continue", "Options", etc) then the in-game sound will work. If you can't then be prepared for more tweaking.

------------------------------------------------------------------------------

Now, if you are using a Realtek soundcard, then read this (taken from 2K forums): Again, ensure the drivers are up to date.

In some cases you may encounter stuttering sound or no sound at all when playing Bioshock with a combination of Windows Vista/7 and Realtek onboard sound. To ensure the best possible sound performance from your system when playing Bioshock, please follow the steps below:

- Ensure you are running the latest Realtek drivers, these can be downloaded from Realtek directly via Realtek. Alternatively your motherboard manufacturer will also be able to provide up to date drivers.

Note: If you are encountering any other issues with your sound or if you are in doubt as to what software you need then please contact your motherboard manufacturer prior to installing any driver software.

- Enable Stereo mixing, to do this browse to Start > Control Panel > Sound (in classic view). Once done switch to the Recording tab which will show the currently active inputs on your system (e.g. Line in, Microphone). Right click in the clear space below these devices and select the option for Show disabled devices. This should show an additional device called Stereo mixing, right click on this device and select Enable.
Im trying this at the moment will post if it works!
    
CPUMotherboardGraphicsRAM
i7 930 @ 4ghz w/1.25 Vcore Asus P6X58D-E Asus GTX480 6Gb Corsair Dominators 1600mhz Tri Chan 
Hard DriveHard DriveCoolingCooling
120gb Corsair force GT 1Tb Samsung F3 Noctua NH-D14 Zalman VF3000F 
OSMonitorKeyboardCase
Windows 7 27" iiyama G2773HS 120hz Steelseries Stealth Merc Coolermaster Storm Scout 
MouseMouse Pad
Razer Naga Razer Goliathus 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 930 @ 4ghz w/1.25 Vcore Asus P6X58D-E Asus GTX480 6Gb Corsair Dominators 1600mhz Tri Chan 
Hard DriveHard DriveCoolingCooling
120gb Corsair force GT 1Tb Samsung F3 Noctua NH-D14 Zalman VF3000F 
OSMonitorKeyboardCase
Windows 7 27" iiyama G2773HS 120hz Steelseries Stealth Merc Coolermaster Storm Scout 
MouseMouse Pad
Razer Naga Razer Goliathus 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Steam Bioshock problems