Overclock.net › Forums › Intel › Intel Motherboards › USB 3.0 Ports Don't Work.
New Posts  All Forums:Forum Nav:

USB 3.0 Ports Don't Work.

post #1 of 40
Thread Starter 
My USB 3.0 Ports on my Rampage 3 Extreme don't seem to work for some reason. The USB 2.0 ones work fine, I have the latest drivers installed yet when I plug my USB 3 external hard drive into the USB 3 ports, it doesn't work. It works great with the USB 2 ports though. Anyone have any ideas please, this problem is annoying.
Epic Build! 0.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
{Intel i7 930 @ 4.2 GHz w/ HT} {Asus Rampage III Extreme} {Zotac AMP! + EVGA GTX 480 SLI @ 800/1600/1900} {G.SKILL Ripjaws 6GB DDR3 1605Mhz @ 7-8-7-20-1N} 
Hard DriveOptical DriveOSMonitor
{OCZ Agility 2 120GB, WD Black 1TB, F4 2TB RAID1} {Asus DVD+/- RW} {Windows 7 Ultimate 64 bit} {Asus VH242H 23.6" 1080p} 
KeyboardPowerCaseMouse
{Logitech G15} {Corsair HX 1000W} {CoolerMaster HAF-X} {Logitech G700} 
Mouse Pad
{Razer Goliathus - Speed} 
  hide details  
Reply
Epic Build! 0.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
{Intel i7 930 @ 4.2 GHz w/ HT} {Asus Rampage III Extreme} {Zotac AMP! + EVGA GTX 480 SLI @ 800/1600/1900} {G.SKILL Ripjaws 6GB DDR3 1605Mhz @ 7-8-7-20-1N} 
Hard DriveOptical DriveOSMonitor
{OCZ Agility 2 120GB, WD Black 1TB, F4 2TB RAID1} {Asus DVD+/- RW} {Windows 7 Ultimate 64 bit} {Asus VH242H 23.6" 1080p} 
KeyboardPowerCaseMouse
{Logitech G15} {Corsair HX 1000W} {CoolerMaster HAF-X} {Logitech G700} 
Mouse Pad
{Razer Goliathus - Speed} 
  hide details  
Reply
post #2 of 40
The latest USB3.0 drivers specific to your controller?
Once again...
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 [4.28GHz, HT] Asus P6T + Broadcom NetXtreme II VisionTek HD5850 [900/1200] + Galaxy GT240 2x4GB G.Skill Ripjaw X [1632 MHz] 
Hard DriveOSMonitorKeyboard
Intel X25-M 160GB + 3xRAID0 500GB 7200.12 Window 7 Pro 64 Acer H243H + Samsung 226BW XARMOR-U9BL  
PowerCaseMouseMouse Pad
Antec Truepower New 750W Li Lian PC-V2100 [10x120mm fans] Logitech G9 X-Trac Pro 
  hide details  
Reply
Once again...
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 [4.28GHz, HT] Asus P6T + Broadcom NetXtreme II VisionTek HD5850 [900/1200] + Galaxy GT240 2x4GB G.Skill Ripjaw X [1632 MHz] 
Hard DriveOSMonitorKeyboard
Intel X25-M 160GB + 3xRAID0 500GB 7200.12 Window 7 Pro 64 Acer H243H + Samsung 226BW XARMOR-U9BL  
PowerCaseMouseMouse Pad
Antec Truepower New 750W Li Lian PC-V2100 [10x120mm fans] Logitech G9 X-Trac Pro 
  hide details  
Reply
post #3 of 40
Thread Starter 
I got : NEC Electronics Corporation USB3.0 Controller Driver V1.0.19.0 for Windows 32/64bit XP & 32/64bit Vista & 32/64bit Windows 7.(WHQL)

off Asus driver download page. Is this right?
Epic Build! 0.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
{Intel i7 930 @ 4.2 GHz w/ HT} {Asus Rampage III Extreme} {Zotac AMP! + EVGA GTX 480 SLI @ 800/1600/1900} {G.SKILL Ripjaws 6GB DDR3 1605Mhz @ 7-8-7-20-1N} 
Hard DriveOptical DriveOSMonitor
{OCZ Agility 2 120GB, WD Black 1TB, F4 2TB RAID1} {Asus DVD+/- RW} {Windows 7 Ultimate 64 bit} {Asus VH242H 23.6" 1080p} 
KeyboardPowerCaseMouse
{Logitech G15} {Corsair HX 1000W} {CoolerMaster HAF-X} {Logitech G700} 
Mouse Pad
{Razer Goliathus - Speed} 
  hide details  
Reply
Epic Build! 0.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
{Intel i7 930 @ 4.2 GHz w/ HT} {Asus Rampage III Extreme} {Zotac AMP! + EVGA GTX 480 SLI @ 800/1600/1900} {G.SKILL Ripjaws 6GB DDR3 1605Mhz @ 7-8-7-20-1N} 
Hard DriveOptical DriveOSMonitor
{OCZ Agility 2 120GB, WD Black 1TB, F4 2TB RAID1} {Asus DVD+/- RW} {Windows 7 Ultimate 64 bit} {Asus VH242H 23.6" 1080p} 
KeyboardPowerCaseMouse
{Logitech G15} {Corsair HX 1000W} {CoolerMaster HAF-X} {Logitech G700} 
Mouse Pad
{Razer Goliathus - Speed} 
  hide details  
Reply
post #4 of 40
I think you need these.

Nm.
post #5 of 40
Thread Starter 
So what could the problem be?
Epic Build! 0.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
{Intel i7 930 @ 4.2 GHz w/ HT} {Asus Rampage III Extreme} {Zotac AMP! + EVGA GTX 480 SLI @ 800/1600/1900} {G.SKILL Ripjaws 6GB DDR3 1605Mhz @ 7-8-7-20-1N} 
Hard DriveOptical DriveOSMonitor
{OCZ Agility 2 120GB, WD Black 1TB, F4 2TB RAID1} {Asus DVD+/- RW} {Windows 7 Ultimate 64 bit} {Asus VH242H 23.6" 1080p} 
KeyboardPowerCaseMouse
{Logitech G15} {Corsair HX 1000W} {CoolerMaster HAF-X} {Logitech G700} 
Mouse Pad
{Razer Goliathus - Speed} 
  hide details  
Reply
Epic Build! 0.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
{Intel i7 930 @ 4.2 GHz w/ HT} {Asus Rampage III Extreme} {Zotac AMP! + EVGA GTX 480 SLI @ 800/1600/1900} {G.SKILL Ripjaws 6GB DDR3 1605Mhz @ 7-8-7-20-1N} 
Hard DriveOptical DriveOSMonitor
{OCZ Agility 2 120GB, WD Black 1TB, F4 2TB RAID1} {Asus DVD+/- RW} {Windows 7 Ultimate 64 bit} {Asus VH242H 23.6" 1080p} 
KeyboardPowerCaseMouse
{Logitech G15} {Corsair HX 1000W} {CoolerMaster HAF-X} {Logitech G700} 
Mouse Pad
{Razer Goliathus - Speed} 
  hide details  
Reply
post #6 of 40
make sure the ports are enabled in the bios.
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz Always Changing VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz Always Changing VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
post #7 of 40
Thread Starter 
They are enabled, still don't know why it won't work.
Epic Build! 0.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
{Intel i7 930 @ 4.2 GHz w/ HT} {Asus Rampage III Extreme} {Zotac AMP! + EVGA GTX 480 SLI @ 800/1600/1900} {G.SKILL Ripjaws 6GB DDR3 1605Mhz @ 7-8-7-20-1N} 
Hard DriveOptical DriveOSMonitor
{OCZ Agility 2 120GB, WD Black 1TB, F4 2TB RAID1} {Asus DVD+/- RW} {Windows 7 Ultimate 64 bit} {Asus VH242H 23.6" 1080p} 
KeyboardPowerCaseMouse
{Logitech G15} {Corsair HX 1000W} {CoolerMaster HAF-X} {Logitech G700} 
Mouse Pad
{Razer Goliathus - Speed} 
  hide details  
Reply
Epic Build! 0.0
(13 items)
 
  
CPUMotherboardGraphicsRAM
{Intel i7 930 @ 4.2 GHz w/ HT} {Asus Rampage III Extreme} {Zotac AMP! + EVGA GTX 480 SLI @ 800/1600/1900} {G.SKILL Ripjaws 6GB DDR3 1605Mhz @ 7-8-7-20-1N} 
Hard DriveOptical DriveOSMonitor
{OCZ Agility 2 120GB, WD Black 1TB, F4 2TB RAID1} {Asus DVD+/- RW} {Windows 7 Ultimate 64 bit} {Asus VH242H 23.6" 1080p} 
KeyboardPowerCaseMouse
{Logitech G15} {Corsair HX 1000W} {CoolerMaster HAF-X} {Logitech G700} 
Mouse Pad
{Razer Goliathus - Speed} 
  hide details  
Reply
post #8 of 40
Quote:
yet when I plug my USB 3 external hard drive,
Link?

PSSSS....I'm in the Canton/Perry area...are you close?
Edited by Old Hippie - 11/20/10 at 6:45am
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 920 Asus P6T + LSI 9240-4i SATA6GB/s card Nvidia 8800GTS Patroit Viper 6GB of D3-1600 
Hard DriveOptical DriveOSMonitor
Crucial C300 256GB Benq 1655 W7 Ultimate x64 NEC MultiSync LCD2470WNX 
KeyboardPowerCaseMouse
Logitech diNovo cordless Corsair 650HX Lian Li A10-B Logitech MX Revolution 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 920 Asus P6T + LSI 9240-4i SATA6GB/s card Nvidia 8800GTS Patroit Viper 6GB of D3-1600 
Hard DriveOptical DriveOSMonitor
Crucial C300 256GB Benq 1655 W7 Ultimate x64 NEC MultiSync LCD2470WNX 
KeyboardPowerCaseMouse
Logitech diNovo cordless Corsair 650HX Lian Li A10-B Logitech MX Revolution 
  hide details  
Reply
post #9 of 40
Quote:
Originally Posted by Old Hippie View Post
Link?
how is he supposed to have a link of him plugging in a hard drive?
post #10 of 40
Quote:
Originally Posted by kiwiasian View Post
how is he supposed to have a link of him plugging in a hard drive?


OK smartie-pants!

OP, how 'bout a link to the external USB3 unit you are trying to use?


Better?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 920 Asus P6T + LSI 9240-4i SATA6GB/s card Nvidia 8800GTS Patroit Viper 6GB of D3-1600 
Hard DriveOptical DriveOSMonitor
Crucial C300 256GB Benq 1655 W7 Ultimate x64 NEC MultiSync LCD2470WNX 
KeyboardPowerCaseMouse
Logitech diNovo cordless Corsair 650HX Lian Li A10-B Logitech MX Revolution 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 920 Asus P6T + LSI 9240-4i SATA6GB/s card Nvidia 8800GTS Patroit Viper 6GB of D3-1600 
Hard DriveOptical DriveOSMonitor
Crucial C300 256GB Benq 1655 W7 Ultimate x64 NEC MultiSync LCD2470WNX 
KeyboardPowerCaseMouse
Logitech diNovo cordless Corsair 650HX Lian Li A10-B Logitech MX Revolution 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › USB 3.0 Ports Don't Work.