Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Amd ahci driver/gigabyte ahci driver
New Posts  All Forums:Forum Nav:

Amd ahci driver/gigabyte ahci driver

post #1 of 15
Thread Starter 
Ok so I think I figured out why I'm not getting expected speeds on my SSD. I found these drivers on my MOBO's website. They are:

AMD SATA AHCI Driver (Preinstall driver, press F6 during Windows* setup to read from floppy)
&
GIGABYTE SATA2 Preinstall driver (For AHCI / RAID Mode)
Note: Press F6 during Windows* setup to read from floppy.

Couple of questions. Which should I use for Best performance, should I use GIGABYTE SATA2 ports or AMD's SATA ports? And Is there a way to install these drivers without having to reformat and install a clean OS (Just installed clean copy of windows7 last night). Lastly, whenever it says to use a floppy, I can use a flash drive correct? This is all on windows 7 64BIT. Thanks everyone!

EDIT: Do I need to install AMD Chipset Driver (include chipset\\sata raid driver) as well??
Edited by reyesjr - 11/24/10 at 1:39pm
Noob Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T 4GHZ 1.47v NB 2.8GHZ 1.3v Gigabyte MA790FXT-UD5P 9600GT 4GB Corsair DHX 1600MHZ 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Win7 22" 120HZ Samsung Syncmaster 2233RZ Microsoft Digital 3000 
PowerCaseMouseMouse Pad
750W Cooler Master GX NZXT Apollo MX518SE Steelseries QCK Heavy 
  hide details  
Reply
Noob Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T 4GHZ 1.47v NB 2.8GHZ 1.3v Gigabyte MA790FXT-UD5P 9600GT 4GB Corsair DHX 1600MHZ 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Win7 22" 120HZ Samsung Syncmaster 2233RZ Microsoft Digital 3000 
PowerCaseMouseMouse Pad
750W Cooler Master GX NZXT Apollo MX518SE Steelseries QCK Heavy 
  hide details  
Reply
post #2 of 15
Use neither drivers if you want TRIM.

Definitely use the AMD SATA ports.
Once again...
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 [4.28GHz, HT] Asus P6T + Broadcom NetXtreme II VisionTek HD5850 [900/1200] + Galaxy GT240 2x4GB G.Skill Ripjaw X [1632 MHz] 
Hard DriveOSMonitorKeyboard
Intel X25-M 160GB + 3xRAID0 500GB 7200.12 Window 7 Pro 64 Acer H243H + Samsung 226BW XARMOR-U9BL  
PowerCaseMouseMouse Pad
Antec Truepower New 750W Li Lian PC-V2100 [10x120mm fans] Logitech G9 X-Trac Pro 
  hide details  
Reply
Once again...
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 [4.28GHz, HT] Asus P6T + Broadcom NetXtreme II VisionTek HD5850 [900/1200] + Galaxy GT240 2x4GB G.Skill Ripjaw X [1632 MHz] 
Hard DriveOSMonitorKeyboard
Intel X25-M 160GB + 3xRAID0 500GB 7200.12 Window 7 Pro 64 Acer H243H + Samsung 226BW XARMOR-U9BL  
PowerCaseMouseMouse Pad
Antec Truepower New 750W Li Lian PC-V2100 [10x120mm fans] Logitech G9 X-Trac Pro 
  hide details  
Reply
post #3 of 15
The newest AMD drivers "support trim", although they may (and probably aren't updated on the manu site) or may not work properly.
I'd really like it if any of the non bias/corporate SSD guru's could be as kind as to evaluate the "rumor" of the newest amd driver secretly having trim!

But for the time being, Duckie is completely correct.
Synthkart
(13 items)
 
  
CPUMotherboardGraphicsRAM
1055T Asus Onboard x4200 2x2GB GeIL DDR 1333 (9-9-9) 
Hard DriveOptical DriveOSMonitor
Seagate 320GB Sata3.0 Liteon iHAS124 Win7 x64 Some old crt 
KeyboardPowerCaseMouse
digital Raidmax-450K Some cheap raidmax Labtec 
Mouse Pad
  hide details  
Reply
Synthkart
(13 items)
 
  
CPUMotherboardGraphicsRAM
1055T Asus Onboard x4200 2x2GB GeIL DDR 1333 (9-9-9) 
Hard DriveOptical DriveOSMonitor
Seagate 320GB Sata3.0 Liteon iHAS124 Win7 x64 Some old crt 
KeyboardPowerCaseMouse
digital Raidmax-450K Some cheap raidmax Labtec 
Mouse Pad
  hide details  
Reply
post #4 of 15
Quote:
Originally Posted by kenolak View Post
The newest AMD drivers "support trim", although they may (and probably aren't updated on the manu site) or may not work properly.
I'd really like it if any of the non bias/corporate SSD guru's could be as kind as to evaluate the "rumor" of the newest amd driver secretly having trim!
Yeah, OCZ forums believe they do.... but I would have though AMD would have provide an announcement.
Once again...
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 [4.28GHz, HT] Asus P6T + Broadcom NetXtreme II VisionTek HD5850 [900/1200] + Galaxy GT240 2x4GB G.Skill Ripjaw X [1632 MHz] 
Hard DriveOSMonitorKeyboard
Intel X25-M 160GB + 3xRAID0 500GB 7200.12 Window 7 Pro 64 Acer H243H + Samsung 226BW XARMOR-U9BL  
PowerCaseMouseMouse Pad
Antec Truepower New 750W Li Lian PC-V2100 [10x120mm fans] Logitech G9 X-Trac Pro 
  hide details  
Reply
Once again...
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 [4.28GHz, HT] Asus P6T + Broadcom NetXtreme II VisionTek HD5850 [900/1200] + Galaxy GT240 2x4GB G.Skill Ripjaw X [1632 MHz] 
Hard DriveOSMonitorKeyboard
Intel X25-M 160GB + 3xRAID0 500GB 7200.12 Window 7 Pro 64 Acer H243H + Samsung 226BW XARMOR-U9BL  
PowerCaseMouseMouse Pad
Antec Truepower New 750W Li Lian PC-V2100 [10x120mm fans] Logitech G9 X-Trac Pro 
  hide details  
Reply
post #5 of 15
Thread Starter 
Quote:
Originally Posted by DuckieHo View Post
Use neither drivers if you want TRIM.

Definitely use the AMD SATA ports.
Oh wow really? so those drivers are useless than? Alright well maybe U can help me with this. I'm getting decent speeds now (AVG 200M/B sec) but everytime I have to reboot, It goes to this http://img521.imageshack.us/img521/3945/imag0050v0.jpg and it takes a long time for it to finally Init the drive and progress on to windows 7(longer then 5mins at least). After it Init's it, it'll list the SSD drive with S.M.A.R.T - OK. I've went into bios and S.M.A.R.T is disabled. So IDK..I'm lost here.

EDIT: sry I just read the other posts. If I can't fix this long boot problem, I'll give the AMD drivers a try. Thanks Kenolak and Duckie, I appreciate the help!!!!!
Edited by reyesjr - 11/24/10 at 2:08pm
Noob Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T 4GHZ 1.47v NB 2.8GHZ 1.3v Gigabyte MA790FXT-UD5P 9600GT 4GB Corsair DHX 1600MHZ 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Win7 22" 120HZ Samsung Syncmaster 2233RZ Microsoft Digital 3000 
PowerCaseMouseMouse Pad
750W Cooler Master GX NZXT Apollo MX518SE Steelseries QCK Heavy 
  hide details  
Reply
Noob Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T 4GHZ 1.47v NB 2.8GHZ 1.3v Gigabyte MA790FXT-UD5P 9600GT 4GB Corsair DHX 1600MHZ 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Win7 22" 120HZ Samsung Syncmaster 2233RZ Microsoft Digital 3000 
PowerCaseMouseMouse Pad
750W Cooler Master GX NZXT Apollo MX518SE Steelseries QCK Heavy 
  hide details  
Reply
post #6 of 15
you need to use stock msahci driver for trim on amd mobos, and definitely use amd ports, gigabyte sata2 chip sucks.

intels ICH10R does the same thing when AHCI is enabled, nothing you can do about it.
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz GIGABYTE X99-SOC Force VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz GIGABYTE X99-SOC Force VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
post #7 of 15
Thread Starter 
Quote:
Originally Posted by Sin0822 View Post
you need to use stock msahci driver for trim on amd mobos, and definitely use amd ports, gigabyte sata2 chip sucks.

intels ICH10R does the same thing when AHCI is enabled, nothing you can do about it.

really? intel takes 10 minutes to boot with a SSD when AHCI is enabled? I think you maybe read my post wrong about that screen shot . 10 minutes to boot on a SSD is not normal lol
Edited by reyesjr - 11/24/10 at 4:40pm
Noob Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T 4GHZ 1.47v NB 2.8GHZ 1.3v Gigabyte MA790FXT-UD5P 9600GT 4GB Corsair DHX 1600MHZ 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Win7 22" 120HZ Samsung Syncmaster 2233RZ Microsoft Digital 3000 
PowerCaseMouseMouse Pad
750W Cooler Master GX NZXT Apollo MX518SE Steelseries QCK Heavy 
  hide details  
Reply
Noob Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T 4GHZ 1.47v NB 2.8GHZ 1.3v Gigabyte MA790FXT-UD5P 9600GT 4GB Corsair DHX 1600MHZ 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Win7 22" 120HZ Samsung Syncmaster 2233RZ Microsoft Digital 3000 
PowerCaseMouseMouse Pad
750W Cooler Master GX NZXT Apollo MX518SE Steelseries QCK Heavy 
  hide details  
Reply
post #8 of 15
Oh yea i read it wrong i thought you were complaining about that screen during post, ICh10R has that same type of deal for AHCI mode. Something isn't right if it take you 10 mins to boot, my b. Go into bios can change the HDD detect timeout time.
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz GIGABYTE X99-SOC Force VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz GIGABYTE X99-SOC Force VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
post #9 of 15
Thread Starter 
Quote:
Originally Posted by Sin0822 View Post
Oh yea i read it wrong i thought you were complaining about that screen during post, ICh10R has that same type of deal for AHCI mode. Something isn't right if it take you 10 mins to boot, my b. Go into bios can change the HDD detect timeout time.
I don't think there is such an option..but I'll take a look. I'm trying to reinstall windows. Going to try and use the AMD AHCI drivers and see what I get. Only problem is I don't know how to erase an OS off SDD? lol. I tried using HDDErase but I can't get it to regonize my SDD, so Looking for alternate solutions.
Noob Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T 4GHZ 1.47v NB 2.8GHZ 1.3v Gigabyte MA790FXT-UD5P 9600GT 4GB Corsair DHX 1600MHZ 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Win7 22" 120HZ Samsung Syncmaster 2233RZ Microsoft Digital 3000 
PowerCaseMouseMouse Pad
750W Cooler Master GX NZXT Apollo MX518SE Steelseries QCK Heavy 
  hide details  
Reply
Noob Build
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T 4GHZ 1.47v NB 2.8GHZ 1.3v Gigabyte MA790FXT-UD5P 9600GT 4GB Corsair DHX 1600MHZ 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Win7 22" 120HZ Samsung Syncmaster 2233RZ Microsoft Digital 3000 
PowerCaseMouseMouse Pad
750W Cooler Master GX NZXT Apollo MX518SE Steelseries QCK Heavy 
  hide details  
Reply
post #10 of 15
just use windows 7 setup disk tools to format.
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz GIGABYTE X99-SOC Force VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz GIGABYTE X99-SOC Force VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Amd ahci driver/gigabyte ahci driver