Overclock.net › Forums › Graphics Cards › AMD/ATI › Need help flashing a bios
New Posts  All Forums:Forum Nav:

Need help flashing a bios

post #1 of 10
Thread Starter 
Trying to flash the bios of a 5770 to make it the same as my other 5770, so I got a boot disk and flashrom on it, so I went to do it and got an error but the error was that video card 0 was not found...so I did flashrom.exe -i to check and it says ''no ATI adapter found''

Is there some newer utility to use than flashrom? Or maybe I just have an old version or something that doesn't recognize 5k series cards?
post #2 of 10
you need to download Radeon Bios Editor, the latest version pref.

then if you get download Nvflash u can use that in windows to flash your card providing your running 32bit. if your not running 32 bit find some one who does, or if your like me build one outa old parts, dont need much, as long as it has at least 1 PCI-e 1.1 lane then your set to go.

here is a link to the instructions. Creds go to PizzaMan here at OCN
http://www.overclock.net/nvidia-driv...g-modding.html

Just used that method 4 hours ago to flash my 9800GT to overclocked bios settings. works great
Finally Finished!
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 3930K Batch: 3135B495T Gigabyte X79 UD7 GTX 570 3-way SLi Corsair Vengeance 1600mhz CL9 
Hard DriveCoolingOSMonitor
60GB OCZ Vertex II / 3x 500GB Samsung Spinpoint EK Supreme HF Nickel, EK DCP4.0, Stealth GT 360... Windows 7 Ult 64bit Acer 22" G225HQ 
KeyboardPowerCaseMouse
Razor Lacosa Mirror Edition Silverstone Strider 1500w  Aerocool X-Preditor  CM Storm Sentinel Advanced 
Mouse Pad
Razer Goliathus Speed edition 
  hide details  
Reply
Finally Finished!
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 3930K Batch: 3135B495T Gigabyte X79 UD7 GTX 570 3-way SLi Corsair Vengeance 1600mhz CL9 
Hard DriveCoolingOSMonitor
60GB OCZ Vertex II / 3x 500GB Samsung Spinpoint EK Supreme HF Nickel, EK DCP4.0, Stealth GT 360... Windows 7 Ult 64bit Acer 22" G225HQ 
KeyboardPowerCaseMouse
Razor Lacosa Mirror Edition Silverstone Strider 1500w  Aerocool X-Preditor  CM Storm Sentinel Advanced 
Mouse Pad
Razer Goliathus Speed edition 
  hide details  
Reply
post #3 of 10
Thread Starter 
I'm flashing a 5770 not a Nvidia card....NVflash still works on ATI cards??

Edit- Oh I see the radeon editor changes the bios so it will work with NVflash?

Well I don't have 32 bit and think it would just be faster if I used a different program...what about ATI flash?
Edited by 87dtna - 12/20/10 at 3:46pm
post #4 of 10
You need Atiflash (DOS based) for flashing a ATI graphic card..

READ THIS GUIDE..

CHERS..
     
CPUMotherboardGraphicsRAM
E6750 G0 @ 3.3GHz (1.25V LOAD) Asus P5KPL-VM G31 GeForce 8500GT @ 700/1600/445 Apacer 2x1GB 800MHz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar 160GB (7200,8MB) LG DVD Win 7 Ultimate 64bit build 7601 LG 19" 
KeyboardPowerCaseMouse
5$ keyboard Cheap stuff Linkworld crappy/modded SmartBox cheap 
Mouse Pad
N/A 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
E6750 G0 @ 3.3GHz (1.25V LOAD) Asus P5KPL-VM G31 GeForce 8500GT @ 700/1600/445 Apacer 2x1GB 800MHz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar 160GB (7200,8MB) LG DVD Win 7 Ultimate 64bit build 7601 LG 19" 
KeyboardPowerCaseMouse
5$ keyboard Cheap stuff Linkworld crappy/modded SmartBox cheap 
Mouse Pad
N/A 
  hide details  
Reply
post #5 of 10
Thread Starter 
OK so now I'm having another issue. ATIflash does not fit onto a 1.44 floppy, so I tried making my USB stick bootable, and it seemed to work but when I'm in DOS there's only C: and I can't even access the usb stick to run the atiflash. Whats going on here!!!???
post #6 of 10
C:\\ is USB drive so you should be able to acces it ..

Make sure that you`ve put Atiflash.exe and BIOS.bin (or BIOS.rom) file onto root of the drive...

Use HP formating tool and boot files to create a bootable USB drive FAT formatted..

Then when you boot to DOS just type atiflash and hit ENTER and you should eneter utility..

Then type in command: atiflash -p 0 BIOSname.bin or atiflash -f -p 0 BIOSname.bin for force flash with a proper BIOS name and hit ENTER..

Reboot when flashing is done..

CHEERS..
Edited by KingT - 12/21/10 at 12:46am
     
CPUMotherboardGraphicsRAM
E6750 G0 @ 3.3GHz (1.25V LOAD) Asus P5KPL-VM G31 GeForce 8500GT @ 700/1600/445 Apacer 2x1GB 800MHz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar 160GB (7200,8MB) LG DVD Win 7 Ultimate 64bit build 7601 LG 19" 
KeyboardPowerCaseMouse
5$ keyboard Cheap stuff Linkworld crappy/modded SmartBox cheap 
Mouse Pad
N/A 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
E6750 G0 @ 3.3GHz (1.25V LOAD) Asus P5KPL-VM G31 GeForce 8500GT @ 700/1600/445 Apacer 2x1GB 800MHz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar 160GB (7200,8MB) LG DVD Win 7 Ultimate 64bit build 7601 LG 19" 
KeyboardPowerCaseMouse
5$ keyboard Cheap stuff Linkworld crappy/modded SmartBox cheap 
Mouse Pad
N/A 
  hide details  
Reply
post #7 of 10
Thread Starter 
OK there's the difference...I didn't just enter the atiflash utility first I just punched in to try to flash it right away. I did use the HP tool to make the bootable USB drive

OK, will try this...thanks!
Edited by 87dtna - 12/21/10 at 5:02am
post #8 of 10
Thread Starter 
OK the flashing apparently worked, however the XFX card has no video now.

Here's the two cards I'm trying the flash-

http://www.newegg.com/Product/Produc...82E16814150462

http://www.newegg.com/Product/Produc...82E16814161333


I'm guessing these are incompatible completely because if I open Winflash, it says that the flash type is different (meaning a different chip I assume). And if I try to program the bios in winflash it says that it has an incompatable subsystem or something like that. So when I forced the bios in atiflash in DOS it just screwed it up. So I just put in the HIS as the primary and the XFX as the secondary and flashed it back using winflash.
post #9 of 10
DO NOT USE WINFLASH AS IT BRICKS A CARD 5/10 TIMES (HAPPENED TO ME).

Just put original BIOS from bricked card to USB and put your bricked card to second slot and when flashing use this command:
atiflash -f -p 1 BIOSname.bin so use "1" to flash a card in the second slot when using two ATI cards..

Also there is command to test and see which card is which and to se how they are listed 0 or 1 adapter

It`s something like atiflash -t 0 or atiflash -i 0 (or you type 1 for second card)..

But becouse both cards havw the same BIOS it will be hard to recognize which is which..

I would recommend you to use nVidia or different ATI card to boot with in DOS to avoid flashing it accidentally and to be able to recgnize it wih command for listing adapters..

CHEERS..
Edited by KingT - 12/21/10 at 6:15am
     
CPUMotherboardGraphicsRAM
E6750 G0 @ 3.3GHz (1.25V LOAD) Asus P5KPL-VM G31 GeForce 8500GT @ 700/1600/445 Apacer 2x1GB 800MHz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar 160GB (7200,8MB) LG DVD Win 7 Ultimate 64bit build 7601 LG 19" 
KeyboardPowerCaseMouse
5$ keyboard Cheap stuff Linkworld crappy/modded SmartBox cheap 
Mouse Pad
N/A 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
E6750 G0 @ 3.3GHz (1.25V LOAD) Asus P5KPL-VM G31 GeForce 8500GT @ 700/1600/445 Apacer 2x1GB 800MHz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar 160GB (7200,8MB) LG DVD Win 7 Ultimate 64bit build 7601 LG 19" 
KeyboardPowerCaseMouse
5$ keyboard Cheap stuff Linkworld crappy/modded SmartBox cheap 
Mouse Pad
N/A 
  hide details  
Reply
post #10 of 10
Thread Starter 
Yeah I got it all figured out I put in my Asus 5850 as the primary so I would know which was which and reflashed the XFX 5770 as adapter 1 (atiflash -i to find out).

Thanks for all your help, running the XFX again right now and it runs just fine again. It just stinks that the bios was incompatable and I can't Xfire these two 5770 cards.

I didn't try to put the XFX bios on the HIS 5770, but I'm just assuming it won't work since it didn't the other way around....maybe I'll just try it anyway.
Edited by 87dtna - 12/21/10 at 11:43am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Need help flashing a bios