Overclock.net › Forums › Video Games › PC Gaming › Alt+Tabing?
New Posts  All Forums:Forum Nav:

Alt+Tabing?

post #1 of 22
Thread Starter 
Hey everyone, recently I've noticed for some reason when I alt tab out of a game into desktop or the other way around it always takes quite a while. My system specs are pretty up to date and I can't figure out why alt tabing takes so long for me. Does anyone have this problem or know how to solve this?
Yes
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 C3 MSI 790FX-GD70 Radeon HD 5870 Corsair Vengeance 16G 
Hard DriveCoolingOSMonitor
250Gx2 WD Caviar Blue Raid 0 Corsair H50 Windows 7 x64 21.5" Sceptre 
KeyboardPowerCaseMouse
Ducky 1087 OCZ 700W ModxStream Lian Li K62 Roccat Kone+ 
Mouse PadAudio
SteelSeries 4HD Klipsch Promedia 2.1 
  hide details  
Reply
Yes
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 C3 MSI 790FX-GD70 Radeon HD 5870 Corsair Vengeance 16G 
Hard DriveCoolingOSMonitor
250Gx2 WD Caviar Blue Raid 0 Corsair H50 Windows 7 x64 21.5" Sceptre 
KeyboardPowerCaseMouse
Ducky 1087 OCZ 700W ModxStream Lian Li K62 Roccat Kone+ 
Mouse PadAudio
SteelSeries 4HD Klipsch Promedia 2.1 
  hide details  
Reply
post #2 of 22
Must be something with your monitor : /
Randomness
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 980x @ 4.4 / Upgrade - Ivy Bridge X58A-UD3R [EVGA] 2x EVGA GTX 580 3GB 12GB Corsair DDR3-1600  
Hard DriveOSMonitorKeyboard
Seagate Barracuda XT ST32000641AS 2TB HDD Windows 7 64 bit nVidia Surround - 3x U2410 IPS 6048x1200 G15 
PowerCaseMouse
Thermaltake Toughpower 1200 Thermaltake SwordM Razer Naga, G400 
  hide details  
Reply
Randomness
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 980x @ 4.4 / Upgrade - Ivy Bridge X58A-UD3R [EVGA] 2x EVGA GTX 580 3GB 12GB Corsair DDR3-1600  
Hard DriveOSMonitorKeyboard
Seagate Barracuda XT ST32000641AS 2TB HDD Windows 7 64 bit nVidia Surround - 3x U2410 IPS 6048x1200 G15 
PowerCaseMouse
Thermaltake Toughpower 1200 Thermaltake SwordM Razer Naga, G400 
  hide details  
Reply
post #3 of 22
Quote:
Originally Posted by Lune View Post
Must be something with your monitor : /
Wait what? What does this have to do with the monitor? I dont know the cause but the monitor is probably working fine..
The Kandalf
(16 items)
 
  
CPUMotherboardGraphicsGraphics
I7 5820K MSI X99S Gaming 7 ASUS R9 280X TOP Crossfire X ASUS R9 280X TOP Crossfire X 
RAMHard DriveOptical DriveOS
Crucial DDR4 2133MHz 8GB (2x4GB) Samsung SpinPoint F1 1TB HP DVD630 Ubuntu 
MonitorKeyboardPowerCase
2x Philips Brilliance 220CW Microsoft Wireless Desktop Elite Keyboard Fractal Design Newton R3, 800W 80+ Platinum Corsair 900D 
MouseMouse PadAudioAudio
Mionix Naos 8200 Razer Pro Solutions Arcam rDAC B&W CM1 
  hide details  
Reply
The Kandalf
(16 items)
 
  
CPUMotherboardGraphicsGraphics
I7 5820K MSI X99S Gaming 7 ASUS R9 280X TOP Crossfire X ASUS R9 280X TOP Crossfire X 
RAMHard DriveOptical DriveOS
Crucial DDR4 2133MHz 8GB (2x4GB) Samsung SpinPoint F1 1TB HP DVD630 Ubuntu 
MonitorKeyboardPowerCase
2x Philips Brilliance 220CW Microsoft Wireless Desktop Elite Keyboard Fractal Design Newton R3, 800W 80+ Platinum Corsair 900D 
MouseMouse PadAudioAudio
Mionix Naos 8200 Razer Pro Solutions Arcam rDAC B&W CM1 
  hide details  
Reply
post #4 of 22
Quote:
Originally Posted by i_ame_killer_2 View Post
Wait what?
Mine used to be slow on the some stupid TV I was using for a while
Randomness
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 980x @ 4.4 / Upgrade - Ivy Bridge X58A-UD3R [EVGA] 2x EVGA GTX 580 3GB 12GB Corsair DDR3-1600  
Hard DriveOSMonitorKeyboard
Seagate Barracuda XT ST32000641AS 2TB HDD Windows 7 64 bit nVidia Surround - 3x U2410 IPS 6048x1200 G15 
PowerCaseMouse
Thermaltake Toughpower 1200 Thermaltake SwordM Razer Naga, G400 
  hide details  
Reply
Randomness
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 980x @ 4.4 / Upgrade - Ivy Bridge X58A-UD3R [EVGA] 2x EVGA GTX 580 3GB 12GB Corsair DDR3-1600  
Hard DriveOSMonitorKeyboard
Seagate Barracuda XT ST32000641AS 2TB HDD Windows 7 64 bit nVidia Surround - 3x U2410 IPS 6048x1200 G15 
PowerCaseMouse
Thermaltake Toughpower 1200 Thermaltake SwordM Razer Naga, G400 
  hide details  
Reply
post #5 of 22
Quote:
Originally Posted by thisispatrick View Post
Hey everyone, recently I've noticed for some reason when I alt tab out of a game into desktop or the other way around it always takes quite a while. My system specs are pretty up to date and I can't figure out why alt tabing takes so long for me. Does anyone have this problem or know how to solve this?
I think if you turn aero off it might be faster, not sure though.
If the game has the option to run windowed yet "fullscreen'd" it'll be instant. Starcraft 2 and TF2 have this.
Omicron Lyrae
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 720 BE @3.6 Asus M4A785TD-V EVO Sapphire HD5770 V2 OCZ 2x2GB Gold DDR3-1333 
Hard DriveOptical DriveOSMonitor
Samsung Spinpoint F3 1TB Sony Lightscribe DVD-RW Windows 7 Professional 64-bit AOC F22+ 1080p 
KeyboardPowerCaseMouse
Cherry Scissor Switch Flat Keyboard OCZ StealthXstream 600W Cooler Master Elite 334 Microsoft Sidewinder 
  hide details  
Reply
Omicron Lyrae
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 720 BE @3.6 Asus M4A785TD-V EVO Sapphire HD5770 V2 OCZ 2x2GB Gold DDR3-1333 
Hard DriveOptical DriveOSMonitor
Samsung Spinpoint F3 1TB Sony Lightscribe DVD-RW Windows 7 Professional 64-bit AOC F22+ 1080p 
KeyboardPowerCaseMouse
Cherry Scissor Switch Flat Keyboard OCZ StealthXstream 600W Cooler Master Elite 334 Microsoft Sidewinder 
  hide details  
Reply
post #6 of 22
It could be because you are low on RAM, so windows puts some stuff to pagefile so that your game can take up some more RAM.

What is your memory utilization like? Generally after ~75% utilization things get slower due to more swapping to disk (thats my general impression at least).
    
CPUMotherboardGraphicsRAM
C2D T7100 1.8 ghz (undervolted) ummm... Dell Intel X3100 2 x 1gb 667mhz 
Hard DriveOptical DriveOSMonitor
Fujitsu 7200 RPM 120gb CD-RW/DVD dual boot Vista business 1440x900 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
C2D T7100 1.8 ghz (undervolted) ummm... Dell Intel X3100 2 x 1gb 667mhz 
Hard DriveOptical DriveOSMonitor
Fujitsu 7200 RPM 120gb CD-RW/DVD dual boot Vista business 1440x900 
  hide details  
Reply
post #7 of 22
Try rebooting and see if the problem is still there... It may be that you are running low on memory.
O.C. Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 980x Extreme Gigabyte X58A-UD7 (rev 2.0) Gigabyte GTX 460 OC 768 Kingston HyperX 1600Mhz (3x4GB) 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 2 100GB Lite-On Lightscribe 24x Windows 7 Pro x64 Dell 2408wfp 
KeyboardPowerCaseMouse
MS Wireless Laser 6000 v2.0 Corsair Pro AX1200 Gold Cooler Master HAF 922 MS Wireless Laser 6000 
  hide details  
Reply
O.C. Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel 980x Extreme Gigabyte X58A-UD7 (rev 2.0) Gigabyte GTX 460 OC 768 Kingston HyperX 1600Mhz (3x4GB) 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 2 100GB Lite-On Lightscribe 24x Windows 7 Pro x64 Dell 2408wfp 
KeyboardPowerCaseMouse
MS Wireless Laser 6000 v2.0 Corsair Pro AX1200 Gold Cooler Master HAF 922 MS Wireless Laser 6000 
  hide details  
Reply
post #8 of 22
I've always noticed this issue as well but it was much slower on a slower computer (go figure) so it could be a number of things. It might be the way windows handles transitioning from the application to desktop, I'm not sure.

I know people that use windowed mode to combat this issue, but I personally dislike windowed mode so it's up to you.
The Blevinator
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom X4 9650 Agena 2.8GHz Biostar TA790GX A2+ Sapphire HD 4870 512mb 790MHz/1000MHz G.Skill 2 X 2gb DDR2 1066 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 500gb + 250gb Sony Optiarc DVD burner win32/ Linux Dell 17" 1280 x 1024 
KeyboardPowerCaseMouse
Razer Lycosa Antec Truepower New TP650 NZXT Tempest EVO Razer DeathAdder 
Mouse Pad
Razer Goliathus Fragged control 
  hide details  
Reply
The Blevinator
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom X4 9650 Agena 2.8GHz Biostar TA790GX A2+ Sapphire HD 4870 512mb 790MHz/1000MHz G.Skill 2 X 2gb DDR2 1066 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 500gb + 250gb Sony Optiarc DVD burner win32/ Linux Dell 17" 1280 x 1024 
KeyboardPowerCaseMouse
Razer Lycosa Antec Truepower New TP650 NZXT Tempest EVO Razer DeathAdder 
Mouse Pad
Razer Goliathus Fragged control 
  hide details  
Reply
post #9 of 22
I used to have this problem on a Toshiba laptop, but only if I had another screen maximized while running the game. (ie: A browser) I would minimize or close all other programs/windows and the problem would go away.
post #10 of 22
It's a software issue. Windows just sucks for everything. Macs Command+Tab much faster than Windows PCs.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 750 Gigabyte GA-H55M-S2V ASUS 9600 GSO 384 2x2gb G.Skill DDR3 
Hard DriveOptical DriveOS
2x250GB DVD Windows 7 64 bit 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 750 Gigabyte GA-H55M-S2V ASUS 9600 GSO 384 2x2gb G.Skill DDR3 
Hard DriveOptical DriveOS
2x250GB DVD Windows 7 64 bit 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Alt+Tabing?