Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Help me fix this raid array (MDADM)
New Posts  All Forums:Forum Nav:

Help me fix this raid array (MDADM)

post #1 of 2
Thread Starter 
so when i restarted this ubuntu machine i got an error saying

md1 failed to mount or is missing.

when i do a fdisk -l all the disks show

my array should be mounted like so:
mount /dev/md1

md1 consists of
/dev/sdc1
/dev/sdd1

but when i try to mount it manually i get this error

Quote:
mount /dev/md1
mount: wrong fs type, bad option, bad superblock on /dev/md1,
missing codepage or helper program, or other error
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
In some cases useful info is found in syslog - try
dmesg | tail or so
any ideas?


***EDIT***
NVM i fixed it.

Seems like after i did the updates the hdds got moved around.

sda1 became sdb1 and sdb1 became sdc1 etc etc....

strange...

but i fixed them, the UUIDs stayed the same
Edited by this n00b again - 12/23/10 at 12:14am
liger-zero
(13 items)
 
  
CPUMotherboardGraphicsRAM
930/920/920/2500k/2500k/x4-640/x4-630/ x58Pro/x58Ext/P6TD/P8P67/P35/A780L/785GM-E51/H55M 5870CFX/GTX260Sli/5870/GTX260-Sli/GTX260/9600/8800 Gskill/Gskill/Gskill/Gskill/Corsair/Corsair/GSkill 
Hard DriveOptical DriveOSMonitor
OWC 6G Extreme PRO / Crucial M4 SAMSUNG DVD-RW DL X64 Win 7 | X86 xp pro | OSX | Ubuntu | Backtrack Samsung 23 x 5 
KeyboardPowerCase
Saitek 850TX/MXS600/750TX/750TX/EA500/EA500/EA500/MxS500 700d + Rackmount server chassis 
  hide details  
Reply
liger-zero
(13 items)
 
  
CPUMotherboardGraphicsRAM
930/920/920/2500k/2500k/x4-640/x4-630/ x58Pro/x58Ext/P6TD/P8P67/P35/A780L/785GM-E51/H55M 5870CFX/GTX260Sli/5870/GTX260-Sli/GTX260/9600/8800 Gskill/Gskill/Gskill/Gskill/Corsair/Corsair/GSkill 
Hard DriveOptical DriveOSMonitor
OWC 6G Extreme PRO / Crucial M4 SAMSUNG DVD-RW DL X64 Win 7 | X86 xp pro | OSX | Ubuntu | Backtrack Samsung 23 x 5 
KeyboardPowerCase
Saitek 850TX/MXS600/750TX/750TX/EA500/EA500/EA500/MxS500 700d + Rackmount server chassis 
  hide details  
Reply
post #2 of 2
Usually when Linux starts it'll scan all of the devices to see if they belong to a RAID array. If it finds RAID partitions, it'll auto assemble them based on UUID. However, for this to work you'll need to ensure that the partition type for each partition in the RAID is set to "fd".

Use fdisk to check each partition in your RAID and ensure that each one is set to "fd".
Ryzen
(12 items)
 
  
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Gigabyte GA-AB350M Gaming 3 Palit GT-430 Corsair Vengeance LPX CMK16GX4M2B3000C15 
Hard DriveCoolingOSMonitor
Samsung 850 EVO AMD Wraith Spire Linux Mint 18.x Dell UltraSharp U2414H 
KeyboardPowerCaseMouse
Apple Basic Keyboard Thermaltake ToughPower 850W Lian-Li PC-A04B Logitech Trackman Wheel 
  hide details  
Reply
Ryzen
(12 items)
 
  
CPUMotherboardGraphicsRAM
Ryzen 7 1700 Gigabyte GA-AB350M Gaming 3 Palit GT-430 Corsair Vengeance LPX CMK16GX4M2B3000C15 
Hard DriveCoolingOSMonitor
Samsung 850 EVO AMD Wraith Spire Linux Mint 18.x Dell UltraSharp U2414H 
KeyboardPowerCaseMouse
Apple Basic Keyboard Thermaltake ToughPower 850W Lian-Li PC-A04B Logitech Trackman Wheel 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Help me fix this raid array (MDADM)